Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 11/11/2019 in all areas

  1. 4 points
    I would really like to know where you find that scientific experiment. I agree that the press isn't the most trustworthy source of knowledge. And I will not disagree that plants need CO2 to grow. But claim that we can solve all our problems by emitting more CO2 I find hard to agree on.
  2. 2 points
    There is now an updated version of this plugin available through the Marketplace, for all versions of Cura from 3.5 through 4.4.
  3. 2 points
    I can say something about that! The visual intents change the following settings: speed_infill = 50 wall_thickness = =wall_line_width * 3 top_bottom_thickness = =wall_thickness It's not a whole lot, but they were added last. I expect the visual intents to get more changes in the next releases. The engineering profiles do a whole lot more: infill_line_width = =line_width jerk_print = 30 jerk_infill = =jerk_print jerk_topbottom = =jerk_print jerk_wall = =jerk_print jerk_wall_0 = =jerk_wall jerk_wall_x = =jerk_wall jerk_layer_0 = 5 line_width = =machine_nozzle_size speed_print = 30 speed_infill = =speed_print speed_layer_0 = 20 speed_topbottom = =speed_print speed_wall = =speed_print speed_wall_0 = =speed_wall speed_wall_x = =speed_wall top_bottom_thickness = =wall_thickness wall_line_width_x = =line_width wall_thickness = =line_width * 3 xy_offset = =- layer_height * 0.2 Note that these intent changes sit on top of the existing profiles (so they override settings if both of them define it)
  4. 2 points
    Possibly more than those companies you mentioned 😉
  5. 2 points
    There are companies that take the open source, make changes and give these modified Cura versions to their clients, forgetting to share the changes. This does not make Cura any less open source, but it does make those companies arses.
  6. 1 point
    Das heisst im deutschen Cura auch Combing-Modus. Ich empfehle diesen hier bei Nicht in Außenhaut setzen. Wenn du den auf Aus setzt, hast du eine Retract Party. Diese Linien auf der obersten Schicht könntest du mit "Einziehen bei Fahrt zur nächsten Schicht" eventuell loswerden.
  7. 1 point
    Hallo Uli und willkommen im Forum! Diese Linien kannst du beseitigen indem du Combing auf OFF oder nicht in Außenhaut setzt. Falls du ein deutsches Cura verwendest, heißt das irgendetwas mit Kamm oder so. Einfach im Suchfeld über den Settings eingeben.
  8. 1 point
    Try the Sidebar GUI plugin from the Marketplace. It is quite a labour of love, and in my opinion restores some semblance of sanity to the UI. The plugin will soon be available for Cura 4.4 too.
  9. 1 point
    It's rare, but I've seen a pinched front fan cable (the black and white one) cause electrical interference with the active leveling. To test this unplug your front fan and run active leveling and see if it works. (Note: don't run your print this way; running prints without your front fan can make the filament swell in your Print Cores.)
  10. 1 point
    Randen van overhangende delen hebben de neiging om op te krullen, waarna de nozzle daar met geweld tegenaan kan botsen. Deed zich dat hier ook voor? En dunne paaltjes gaan soms wiebelen. Verder: kijk eerst eens in Cura met transparant view en x-ray view of er geen defecten in het model zelf zitten? Indien het okee is, probeer dan eens in een ander materiaal te printen? Gewoon standaard PLA of zo. Dit lijkt een "filled material" te zijn, dus met partikeltjes, en die zijn meestal veel brosser dan gewone materialen. Kan je de afgebroken paaltjes manueel makkelijk verder breken? Als opkrullende randen een oorzaak zouden zijn, probeer dan een dikkere laaghoogte. Als onvoldoende hechting tussen de lagen een oorzaak zou zijn, probeer dan dunnere lagen bij dezelfde snelheid en temperatuur. Of probeer nog meer randdikte, tot die paaltjes volledig gevuld zijn. Je snelheid en temperatuur lijken mij okee voor gewoon PLA, dus dat zou het niet mogen zijn. Wat je ook kan proberen als het zou blijven breken: de print ofwel even pauzeren, ofwel laten lopen, en dat losse stukje ofwel vastplakken met secondenlijm, ofwel manueel vasthouden tot het terug vastzit langs boven. Of los laten en nadien erin plakken. Afhankelijk van de hoeveelheid nabewerking die je wilt doen (vb. schilderen), kan dat ook nog acceptabel zijn.
  11. 1 point
    Jupp, Du hast recht, hab ich tatsächlich übersehen das dünne Ding 🙂
  12. 1 point
    G280 is responsible for the initial material feeding. The additional parameter S1 prevents the "blob". It should be sufficient to substitute lines 31 - 32 for reference: https://community.ultimaker.com/topic/20717-prime-blob-knocked-down-curaum3/?do=findComment&comment=197317 https://community.ultimaker.com/topic/20717-prime-blob-knocked-down-curaum3/?do=findComment&comment=197505
  13. 1 point
    Das ist 3 Jahre her... wie die Zeit vergeht...
  14. 1 point
    You need to turn off supports. That’s what the light blue indicates. As for pausing, I’ve done the same thing but for some reason it only works when specifying the height by layer number.
  15. 1 point
    If you loosen 2 screws at opposite diagonals then you can rotate them totally freely.
  16. 1 point
    You could try running the STL file through http://service.netfabb.com It’s a free service that just requires registration.
  17. 1 point
    Its for a Lego Car for a centerlock Its printed in Pla with Breakaway on UM S5
  18. 1 point
    A .ufp file is "just a zip". You can open it in a zip program (eg 7zip), extract the actual gcode file to edit it, and put the edited file back in the .ufp file.
  19. 1 point
    Hallo, Yesterday I printed a very small and fine torsion spring. I was very surprised how well that worked and how easily he printed the torsion spring. The spring has a diameter of 0.6mm theoretically and practically are 0.58-0.64mm. She is printed with a 0.25core and pla and breakaway from Ultimaker. The threaded nut has an M4 thread
  20. 1 point
  21. 1 point
    Hello together, some time ago I started 3D-printing RC-airplanes using Cura to generate the required G-codes. The way I go is that I just build the required volume models with a CAD programm and then print them with the "Cubic Infill" and one outer perimeter to get light but strong parts. To vary the strength within a part I use overlapping volumes and assign different infill values to them. (First the overlapping volumes, then the Infill without the outer perimeter) The "Cubic Infill" works quite well as an internal structure for wings and such, at least if the parts are positioned exactly in a 15° orientation on the bed, but, it could be even better. While the diagonal "cross pattern" provides a lot of strength and bonds really well to the outer surface, the "horizontal beams" dont add much strength but still add weight. A wing specific Infill profile, just containing this "cross pattern" and the ability to turn it as you need would be really great. (I am not sure if the turning is already implemented, I could not figure out how to do it) Designing the internal structure of an 3D-printable plane is usually a very long and labour intensive process, to be able to use a generic infill saves a lot of time! The next issue I encountered is the direction in wich the outer layer is printed. When the hinges to the flaps are designed as elasticflaps (basicly as a compliant mechanism) it is very important that they get printed the same way on the left and the right wing. Because the sides are mirror images of each other they would need to be printed going clockwise on the one, and counterclockwise on the other part - sadly they dont, and there is no such option. The only workaround I could find was to basically print the right wing two times, but with a reversed stepper motor during the second print. This does kind of a "hardware mirroring" effect, but it is quite inconvenient. In the left of the picture you can see the hinges - The anticlockwise printing direction is fine for the lower one, but the upper one would need to be printed clockwise. If there was an option to change the direction - that would be super cool! At last, it would be super cool if it was possible to drag the "Object List" around. When setting different infills for the various volumes it is kind of annoying to have the "Object List" overlaying the "Mesh Type" dialog. It would be a lot easier if I could just drag the "Object List" al little bit to the side... But please dont get me wrong - Cura is a superb slicer as it is, the things mentioned above would just make it a tiny bit more perfect... 😉 And to end this post just some more pictures of what I am doing... A video of the plane flying in 30km/h of wind: https://youtu.be/fBAJXu0zWDc
  22. 1 point
    If it is stuck in the Bowden tube and you are not able to get it out as Reiner described, you can also try to completely remove the Bowden with the filament and hold it under warm water. PLA gets soft at 60°C so your chances are higher that you will get it out.
  23. 1 point
    I am sure you will buy what you choose to but the original feeder is not (in my opinion) your best choice, the performance of the Bondtech is much superior
  24. 1 point
    Left side, and there is only left side for UM2+ https://www.igo3d.com/ultimaker-2plus-feeder Bondtech, just in case: https://www.3djake.uk/bondtech/extruder-ddg-kit-for-the-ultimaker-2 Did not find a UK-based shop.
  25. 1 point
    @mrtinfy Yes. There is an issue...but it is not as simple as you think. Many of us run Cura on systems that have the newer redistributables with no problem. My Surface Book v2 runs it fine in its laptop configuration that uses the NVidia GPU in the keyboard. But it will not launch properly when in tablet mode where it uses the integrated Intel GPU. I have given this info to the team both here in the forums and on the Github issues section, but I don’t pester the team asking, “Is it done yet?” One of the truly frustrating things in software development is to have bugs that a small group of customers see, but that you cannot reproduce on the computers you have available for testing. Letting other users know what worked for you, as you did in your initial posts about this issue, is good because it gave others who have the problem a possible workaround. It also let others add to that, for example my comments about needing to reinstall the later redistributables one Cura was installed so as to not break other programs. This is collaborative troubleshooting. And these points of information may provide clues to the development team.
  26. 1 point
    I also use DesignSpark Mechanical since several years. Its interface concept is close to that of SketchUp, and easy to learn. I never had any software problems when printing these designs (except for my own errors and omissions in the design). As said above, view a couple of Youtube tutorials, and see if it appeals to you. Also do this for other programs on your maybe-list.
  27. 1 point
    I don't understand why you're complaining, it was just a hint that your Cura version is 5 years old and no longer supported. Unfortunately, there are always people who buy a Chinese printer, get a very old software there and then expect an excellent support here in the forum, because they don't get it in China from the manufacturer. But even if you won't believe it, we give this support here gladly and often, no matter which printer. But as so often in life it depends on the way you behave. It's up to you, but I think we'll live with your decision. Have a nice day!
  28. 1 point
    +1 for Fusion360, never looked back to anything other.
  29. 1 point
    “mrtinfy” was simply doing as able to help by conveying that which he was told. I have no comment as associated with this seemingly protracted issue for the a Ultimaker development team but rather a thank you to “mrtinfy” for trying. Takes care, Shadowman
  30. 1 point
    That’s a 5 year old vrrsion of Cura you have there. It is no longer supported here. If it is still distributed by a printer manufacturer, please ask them for support. For future reference, if you want people to help you then try making it easy for them. Don’t make people hunt for problems in bad photos of your screen; Your pictures are NOT self-explanatory.
  31. 1 point
    It makes perfect sense if you are a support person when a non-programmer user of software not written by Microsoft is asking Microsoft to fix an issue. I’m sure @mrtinfy means well, but he needs to stop trying to wield that comment like a cudgel. He also needs to understand that in many open source projects, there are many packages that are used, but not written or supported by the developers of the product. If Package “X, version 1.23” is being used by the project, and that version has a hard dependency on msvc redistributables 2015, that could make the project as a whole not work with the fully backward compatible later version. It is possible that Package X v1.45 has remedied the problem, and you might ask why the project is still using the old version. It is common in many software development scenarios to use “outdated” versions. The first is that it is often not clear which package is causing the problem. Is it Package X or Package Y? The second is that it can be a lot of work to bring in a later version of the package. In addition to fixing the msvc issue, it may have changed fundamental things about how the package works. I am sure Team Ultimaker will fix the issue when they are able, but insinuating they are clueless is not useful.
  32. 1 point
    Sure, that could happen. The intent profiles are not magic. They are just a way to select a different combination of setting values that eg sacrifice printing speed for either accuracy. There are physical limitations that make it hard to eg print accurately AND fast. The profiles that ship for the UM3 are intended to be a compromise between the two. Between the UM2 and the UM3, the printhead became heavier (to allow for the printcores and dual extrusion). This made the physical limitations manifest more clearly. For the UM S5 and S3, the gantry became even heavier, which made "intent profiles" more necessary. You can already make your own profile that prints slower to be more accurate. Unfortunately I don't have an UM3, so I would not know what changes to make.
  33. 1 point
    I am not "from the team", but I think it is the shear number of profiles that need to be made and tested to support more printer, printcore, material, quality and intent profiles.
  34. 1 point
    I not a cura developer but a developer using Microsoft technologies and I concur with @nallath above...it makes no sense
  35. 1 point
    You are welcome, glad to see you brought to work. 👍
  36. 1 point
    SandervG, Any update on the availability of the Air handler and material station? I ordered it from a US distributor at the beginning of Oct. and still waiting. Rumor is that Ultimaker is having issues with the firmware.
  37. 1 point
    This is day 2 of "Inside the Ultimaker 3", Remote access. - Other days: Day 1 - GCode Day 3 - Remote access (part 2) - A new day, a new piece of information. Yesterday we took a quick look at the changes in gcode files. Which is the core of pretty much any 3D print. Today, we will look at the remote access trough the network. The remote API is designed to allow control of the machine trough the network. It is what Cura uses to control and monitor the machine remotely. - Even if you are not a software engineer, there is added value for you here. So do not stop reading yet! The technology behind the API The API is a REST interface using JSON. That could be 3 new words for you right there. Don't worry. API: Application Programming Interface. Simply meaning it's an thing designed so that applications can talk to eachter. Does not mean we cannot use it as an user. But the end goal is for other applications. REST: Representational State Transfer. Just a fansy way of saying that every "request" you do to the printer is "stateless". Also, just a standardized way of doing things. The really cool part here is that is done trough HTTP. JSON: Javascript Object Notation. A standadized way to represent data. This makes it easier for applications to understand each other. Nothing to worry here, it is quite easy to read by humans. HTTP: Hyper Text Transfer Protocol. For those that missed it, I introduced this term in the REST term. If you are now like "I have seen this before, but where?" that is most likely true. Http is the way your browser talks to a webserver. So, in a nutshell. Our remote access on the printer is actually just a website acting in a standarized way so applications (like Cura) can understand it. Example time! You most likely don't have your fansy Ultimaker 3 yet. But I do. Now, first things you need to do is connect your printer to a network. As it's not really possible to access something remotely without access. So setup that WiFi or just plug in a cable. - Next you need your IP address. You can find it in the {SYSTEM}->{Network}->{Connection status} menu. It is those 4 numbers with dots in between. For this example, I'll be using 10.180.1.71, as that is my printer. - Now, you don't need any tool. As you already have the tool for basic viewing of data. You are looking at it. It is your browser. You have this fancy location bar at the top of your browser. And if we enter http://10.180.1.209/api/v1/system/firmware there, we will see the result: "3.4.12.20161017" That is your firmware version. Could not be simpler. Just so you know, the firmware version is build out of [major].[minor].[revision].[date], every version we use, even internally for testing, gets a new number for tracebility. - I picked a simple example for a reason, so we could look into this at a bit more detail first. The address you entered. Or URL as it is called in fancy computer terms is made up out of these parts: http://: This means we are using http. Part of REST remember? 10.180.1.209: The IP address we looked up on the printer. /api/v1: This means we are accessing our API, and the first version of it. If we ever need to make incompattible changes, we will have a v2 here and keep the v1 for a long as we can. /system: We are accessing the "system" part. System contains things that are not really 3d printer specific. Any device could have these properties. /firmware: We are requesting the "firmware" part of system. Which is defined are returning the firmware version. Having that made clear, in the system we have the following parts: http://10.180.1.209/api/v1/system/platform - Returns the linux version that we are running on, who cares right? http://10.180.1.209/api/v1/system/hostname - Returns the hostname of the printer. This is not user configurable and will remain the same unless electronics are replaced. So you can use this to uniquely identify the printer. http://10.180.1.209/api/v1/system/name - This is the user configurable name. You are asked to configure this during the WiFi setup. http://10.180.1.209/api/v1/system/firmware - As explained, the current firmware version. http://10.180.1.209/api/v1/system/memory/used - The amount of memory in use by the system. http://10.180.1.209/api/v1/system/memory/total - The amount of memory available in total. http://10.180.1.209/api/v1/system/memory/log - The system keeps a log of many state changes, this API accesses that log. More on it later. http://10.180.1.209/api/v1/system/memory/language - The configured language, we are preparing for providing the printer in your native language as well. But we decided not to delay the release for this. So this is always empty right now. http://10.180.1.209/api/v1/system/memory/country - 2 letter country code, if configured. This is done during the WiFi setup. WiFi hardware needs to be configured for your region to make sure the proper WiFi channels are used. If you don't use WiFi this is most likely empty. - However, if you want all of these in a single go. You can just request: http://10.180.1.209/api/v1/system Which will respond with: {"country": "", "firmware": "3.4.12.20161017", "hostname": "ultimakersystem-ccbdd3000229", "language": "en", "log": ["...", "..."], "memory": {"total": 1057030144, "used": 125394944}, "name": "Ultimaker-000229", "platform": "Linux-4.2.0-rc7-opinicus-00001-g63c264e-armv7l-with-debian-8.1"} Note that I cut out the log data, the rest is a JSON response. It looks a bit hard to read, but computers have no problem in reading it. There are however, tools to format it in a more readable way: { "country": "", "firmware": "3.4.12.20161017", "hostname": "ultimakersystem-ccbdd3000229", "language": "en", "log": [ "...", "..." ], "memory": { "total": 1057030144, "used": 125394944 }, "name": "Ultimaker-000229", "platform": "Linux-4.2.0-rc7-opinicus-00001-g63c264e-armv7l-with-debian-8.1"} There is http://10.180.1.209/log.html currently on the printer that uses /api/v1/system/log to view the latest log data in a more readable format. It was quickly put together and I'm sure we will expand to a better web interface for the printer in the future. But, it is a 3D printer! Yes yes. It is a 3D printer. So we want 3D printer data. And we have that. There are 2 basic important start points: http://10.180.1.209/api/v1/printer http://10.180.1.209/api/v1/print_job The first contains a lot of information about the printer itself. And all of those things can be accessed in the same way as the system part. The second contains information about the currently running print job. If no job is running, you will get a "not found" error. For the technical people, this includes status code 404. /api/v1/printer Let us look at the /api/v1/printer first. This as the following sub parts: /api/v1/printer/led - Part to access the printer casing leds. /api/v1/printer/heads - Part to access the printer head (more on this one later) /api/v1/printer/bed - Part to access information of the printer bed, limited to current and target temperature. /api/v1/printer/status - Best thing to look at first. Basic status of the printer. This could be "idle", "printing", "error", "maintenance" or "booting". Will explain in a bit. /api/v1/printer/beep - Nothing to read from here. Can be written to to make the printer beep. /api/v1/printer/diagnostics - Different diagnostic functions. Retreiving this part does not do anything, but it has sub parts that are not collected in the /api/v1/printer that can be used for in depth diagnostic functions. We WILL go over this for sure. /api/v1/printer/network - Contains the WiFi and Ethernet information. Mostly usefull to see if it is cable of WiFi connected. But the WiFi setup process uses this to connect to a network and to see which networks are available. /api/v1/printer/status The main status of the printer, can be: idle: Printer is doing nothing and ready for action. printing: Printer is actively printing something, or still needs to be emptied, print_job needs to be retreived for details. error: Something is wrong with the printer, and requires action at the printer itself to be corrected. maintenance: Someone is actively doing things with the printer, for example changing materials or PrintCores. booting: Printer is still starting up. This only lasts for a few seconds. /api/v1/printer/heads The printer has a single head. However, the API is prepared for possible futures, so it accounts for multiple heads already. Do not take this as a reason to think we are developing multi head printers. It just good engineering practice to have this in place when it costs almost no effort. - So, the actual part that we need to access for print head information is: http://10.180.1.209/api/v1/printer/heads/0 Software engineers are mighty annoying, as we start counting at 0. So the first head is identified by 0. The first hotend is identified by 0 and the second one with 1. - In here we have some basic settings like acceleration values, maximum speeds, the current position and linked extruders with their hotends. Feel free to explore. As you are all in love with the current hotend temperature, I will show you that one: http://10.180.1.209/api/v1/printer/heads/0/extruders/0/hotend/temperature http://10.180.1.209/api/v1/printer/heads/0/extruders/1/hotend/temperature For the first and second extruder. But, by sheer magic, we also know what type of PrintCore you have in the machine, which can be seen from: http://10.180.1.209/api/v1/printer/heads/0/extruders/0/hotend/id In my case, it returns "AA 0.4" There is the fan entry: http://10.180.1.209/api/v1/printer/heads/0/fan Which contains the print cooling fan speed in 0% to 100% (not 0 to 255 as you see in GCode). The head cooling fan state is not accessible, but directly linked to the hotend temperatures. Small note of warning There is http://10.180.1.209/api/v1/printer/heads/0/extruders/0/active_material/GUID. However, this breaks with the rest of the API and will be removed. Use the lower case http://10.180.1.209/api/v1/printer/heads/0/extruders/0/active_material/guid instead. /api/v1/printer/diagnostics Currently, the only intressing part here is: http://10.180.1.209/api/v1/printer/diagnostics/temperature_flow/10 The last number can be changed up to 20000, but that might take a while to load. The printer takes about 10 samples per second. The result of this is: [["Time", "temperature0", "target0", "heater0", "flow_sensor0", "flow_steps0", "temperature1", "target1", "heater1", "flow_sensor1", "flow_steps1", "bed_temperature", "bed_target", "bed_heater"],[62868.34765625, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.299999237060547, 0.0, 0.0],[62868.453125, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.700000762939453, 0.0, 0.0],[62868.5625, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.399999618530273, 0.0, 0.0],[62868.671875, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.399999618530273, 0.0, 0.0],[62868.78125, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.399999618530273, 0.0, 0.0],[62868.890625, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.5, 0.0, 0.0],[62869.00390625, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.299999237060547, 0.0, 0.0],[62869.11328125, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.700000762939453, 0.0, 0.0],[62869.22265625, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.5, 0.0, 0.0],[62869.328125, 23.100000381469727, 0.0, 0.0, 0.0, 0.0, 23.0, 0.0, 0.0, 0.0, 0.0, 18.0, 0.0, 0.0]] It is a history of temperature data for both hotends, and the bed. There is the current temperature, the target temperature and the amount of heating output. There is also something in there called "flow", but that returns 0 for you. Sorry. Now, this data is a bit hard to parse. But lucky for you, if you want to save this data you can do so very easy, by adding ?csv=1 behind it. Note that this is the only API part that supports this download. http://10.180.1.209/api/v1/printer/diagnostics/temperature_flow/10?csv=1 However, like this you can store it for later viewing, or do all kinds of crazy math and graphing with it, as microsoft-excel or libreoffice-calc can both import this file with relative ease. - There is http://10.180.1.209/temperature.html currently on the printer that uses this data to plot a real-time temperature graph. It is not an official feature of the printer and something we used during development. But it is damn cool. I'm a 100% sure will will expand this diagnostics part later with more data collection. So stay tuned for firmware updates. /api/v1/print_job http://10.180.1.209/api/v1/print_job That's the part that returns the currently active print job. Or it returns: {"message": "Not found"} If there is no print job running. It does not return a whole lot of information, but I think it is the most important information that you can have about the printer. So I will go over it in great detail. A result when a job is running looks like: { "name": "Most awesome PVA print ever done.gcode", "progress": 0, "state": "pre_print", "time_elapsed": 0, "time_total": 0} Initially, the most important entry to look at is the "state", this is different from the printer status. And can have the following values: printing: Print is currently busy. Most common state. pausing: Print was busy and the printer is in the process of going to the paused state. This usually does not last long. paused: Print is paused and thus will not finish without used interaction. resuming: Print is resuming after a pause. Could be heating up the hotend again so this can take a while. pre_print: Preparing to print. This is the state before any gcode is run. Active leveling is done during this state as well as heating up the bed/hotends. post_print: Print is finished, cooling down things and homing the head. This state lasts a while because of how the hotends are properly released from filament. (user can skip part of this at the machine) wait_cleanup: Print is fully finished, everything is cooled down. But the print still needs to be removed from the printer. This waits for a conformation of the user at the printer itself. The progress value is from 0.0 to 1.0 for 0% to 100%, the time values are in seconds. Note that the time_total will be updated during a print as the estimate on when the print is finished will be adjusted during printing. Printing estimates from Cura are usually within the 5% error range. And due to some extra time markers we added the estimate is generally less then 1% off after 2 layers of printing. - If you only care about a single value, you can request just that, just like all the other parts of the API. http://10.180.1.209/api/v1/print_job/name http://10.180.1.209/api/v1/print_job/state http://10.180.1.209/api/v1/print_job/progress http://10.180.1.209/api/v1/print_job/time_elapsed http://10.180.1.209/api/v1/print_job/time_total Documentation I've uploaded our work-in-progress documentation files at: http://software.ultimaker.com/jedi/api/2016.10.20/, these can be viewed with http://editor.swagger.io/. Note that there could be errors and mistakes in this documentation. Wrapping it up This is day 2. I think this is a information overload for quite some people already. I also have actual work to do. Tomorrow I will go into the details of using the API to actually change things. That will be a lot more technical then today. Expect code. Also, I don't know how many days I will fill on remote access. As there is a lot to cover. Stay tuned. - - Disclaimer: Any information presented here could be wrong. I did my best to proof read everything, but it could conflict with official statements and the actual behavior of the printer.
  38. 1 point
    Hi Akke, it could be worth doing two checks before exchanging the print head cable: 1. testing the capacitive sensor via maintenance menu 2. checking the sensor cable, as described in the following post: https://community.ultimaker.com/topic/20852-um3-auto-levelling-not-working/?tab=comments#comment-205252 Regards
  39. 1 point
    No problem to test it out, PM me for a pre public release (if necessary). Another department at work have a 3E and an S5, so I can ask them to also test if possible (I believe they are still on 4.2).
  40. 1 point
    I found what the problem is. It is directly related to the creawsome settings that are applied in the cura start.g file. The max feedrate settings are M203 X500 Y500 Z10 E50. I am running my ender 3 pro with a duetwifi board where the M203 command is set at X900 Y900 Z600 E6000 so I commented out the M203 in cura start.g (and the rest of the speed settings) and now my printer is back up to speed. So I apologise for blaming cura, it is the ridiculously slow speed settings in creawsome. Like I pointed out in my first post a 18 minute print was taking well over 2 hours.
  41. 1 point
    Took me forever to do this. And it is still rougher than I would have liked. 3D concept rendering: Finished piece:
  42. 1 point
    This orange component removes the finished parts from the press. The part replaced an aluminum part, which in each case additionally had to be equipped with a teflon glider and was also much more expensive to manufacture. In addition, the 3d printed component was provided with a break point, which protects the upper punch against damage in the event of a crash.
  43. 1 point
    Just thought I'd try to print some glasses on a model rather than adding ,(my photogrammetry scanned cousin). Glasses were scanned separately on a table by the way. Printing worked great but made the eyes harder to clean up being behind the glasses. Default support settings. Sprayed white. I'm starting to experiment with paint now... Pooh brown colorfabb at 0.06 Hopefully ill have a model in space by Monday, fingers crossed.
  44. 1 point
    Hi, after many hours and prototypes my RC Mini Jet Boat is ready and online. You could find the files as download on https://cults3d.com/en/users/jtronics Follow us on Cults3d and on Youtube to get notice of our New Uploads!
  45. 1 point
    And in case you are wondering if there are more variables, there are (lots of them): http://files.fieldofview.com/cura/Replacement_Patterns.html
  46. 1 point
    Hi @ViennaBlood, you don't have to delete anything, just disable the blasted thing...
  47. 1 point
    I did a tutorial about this feature (as it was in older version already) The workflow is a bit different but it should be usefull i think
  48. 1 point
    Problem was that dilithium was very difficult with legislation, being an accidental space-time warp risk. So we removed that feature last second.
  49. 1 point
  50. 1 point
    Even on interior layers, combing as implemented in Cura is a bad idea, as it doesn't perform retraction, and that can result in the head oozing as it moves, especially as each time the head crosses a line of infill it can tend to pull our some plastic. You can also get some long moves (e.g., all the way around the curve of a 'C' shaped object when moving from one side of the opening to the other). This can result in the head being empty when it starts printing the perimeter again, with resultant under-extrusion effects. While the 'not crossing boundaries' effect is a good thing, in principle, the 'not retracting' is a bad thing. For that reason, I never ever enable combing on the UM2.
This leaderboard is set to Amsterdam/GMT+01:00
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!