Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 08/14/2019 in all areas

  1. 1 point
    Turn off active leveling. I don't recommend it. But keep in mind you need to not touch the printer during active leveling. Stay at least a foot away. Keep anything that radiates electromagnetic energy away from it also. It's very sensitive. Also the spring settings matter so make sure the bed springs aren't too tight and maybe take out the core, remove the clear top and stretch out that spring a little. You need the core spring to be stronger than the bed spring. Anyway, just turn off active leveling. It's just a gimmick and if your bed isn't level it makes the bottom of your parts tilted (on purpose of course - it slowly recovers level over the bottom few mm). For the S5 active leveling is much better as does more than just tilt correction - it corrects at each spot of potentially wavy glass. Also open the print head and look inside at the part that flops down - the inside bottom of the head. There should be 2 wires (typically red and white). Tug on them very gently. If either comes loose then that was your problem (that's the leveling sensor).
  2. 1 point
    If the Z axis is consistent then just change the steps/mm accordingly in tinkerMarlin. If the stepper is losing power sometimes and the weight of the bed moves it down enough to skip a step then lower the current to the Z stepper. Ultimaker has a history of lowering the current to the Z stepper I think 2 times over the years on the UM2. First down to 1000ma and then I think down to 900ma. The stepper can overheat and turn off for well under a second. Underextrusion sounds more serious. Did you get a clone print head of the UM2? Is the 3rd fan working well? There are many crazy details about the print head that seem unimportant but really matter a lot. Like the thermal contact between the round nut and the aluminum base plate and the thermal contact to the fan heatsink in the rear of the head. Is that 3rd fan working well? Is the teflon squeezed too much? Note that the bottom layer is printed slower and with a larger gap and when you speed up slowly on the next 5 layers underextrusion just gets worse and worse - maybe you are simply printing too fast. Here's my complete list of underextrusion issues for UM2. CAUSES FOR UNDEREXTRUSION UM2 AND HOW TO TEST FOR THEM AND REMEDY THEM One can quickly check the feeder (it takes seconds) so I would always do that first. The feeder on UM2+ and UM2 can push with 10 pounds (5kg) force easily so first thing is to lift that lever (if um2+, if um2 regular do move material) and insert filament so it is only part way into the bowden (e.g. half way). Then move the filament with "move material" command in menu so the feeder is energized and then pull down on the filament under the feeder. You should be able to pull with 5 to 10 pounds force without it slipping. Then have it move the material up while you pull down. 5 pounds force (2kg) is enough to make decent prints at moderate speeds listed below but you need 10 pounds (5kg) to print fast (e.g. 0.2mm layers and 60mm/sec) As far as underextrusion causes - there's just so damn many. none of the issues seem to cause more than 20% of problems so you need to know the top 5 issues to cover 75% of the possibilities and 1/4 people still won't have the right issue. Some of the top issues: 1) Print slower and hotter! Here are top recommended speeds for .2mm layers (twice as fast for .1mm layers) and .4mm nozzle: 20mm/sec at 200C 30mm/sec at 210C 40mm/sec at 225C 50mm/sec at 240C The printer can do double these speeds but with huge difficulty and usually with a loss in part quality due to underextrusion. Different colors print best at quite different temperatures and due to imperfect temp sensors, some printers print 10C cool so use these values as an initial starting guideline and if you are still underextruding try raising the temp. But don't go over 240C with PLA. 2) Shell width confusion. Shell width must be a multiple of nozzle size (in cura 15.X. In cura 2.X it doesn't matter as much but still makes a difference). For example if nozzle size is .4mm and shell width is 1mm cura will make the printer do 2 passes with .5mm line width which is possible but requires you to slow down much more to make a .5mm line out of a .4mm nozzle. If you really want this then set nozzle size to .5mm so it's clear what you are asking Cura to do for you. 3) Isolator - this is most common if you've printed extra hot (>240C) for a few hours or regular temps (220C) for 500 hours. It gets soft and compresses the filament under pressure. It's the white part touching the heater block. It's very hard to test when not under full pressure (spring and bowden) so sometimes it's best to just replace it. Also if you notice parts of it are very soft (the blacker end where it touches higher heat) then it's too old and needs replacing. 4) Curved filament at end of spool - if you are past half way on spool, try a fresh spool as a test. 5) curved angle feeding into feeder - put the filament on the floor -makes a MASSIVE difference. 6) UM2 only: Head too tight? Bizarrely MANY people loosen the 4 screws on the head by just a bit maybe 1/2 mm and suddenly they can print just fine! Has to do with pressure on the white teflon isolator. 6b) UM2 only: Bowden pushing too hard - for the same reason you don't want the bowden pushing too hard on the isolator. 6c) Um2 only: Spring pushing too hard. Although you want a gap you want as small as possible a gap between teflon isolator and steel isolator nut such that the spring is compressed as little as possible. 7) clogged nozzle - the number one problem of course - even if it seems clear. There can be build up on the inside of the nozzle that only burning with a flame can turn to ash and remove. Sometimes a grain of sand gets in there but that's more obvious (it just won't print). Atomic method (cold pull) helps but occasionally you need to remove the entire heater block/nozzle assembly and use flame. I found soaking with acetone does not help with caramelized pla. Even overnight. Maybe it works on ABS though. Simpler cold pull: https://www.youtube.com/watch?v=u07m3HTNyEg ūüėé Temp Sensor bad - even the good ones vary by +/- 5C and bad ones can be any amount off - they usually read high and a working sensor can (rarely) fail high slowly over time. Meaning the sensor thinks you are at 220C but actually you are at 170C. At 170C the plastic is so viscous it can barely get out of the nozzle. You can verify your temp sensor using this simple video at youtube - on you tube search for this: mrZbX-SfftU 9) feeder spring issues - too tight, too loose. On the black UM2 feeder you want the tension such that you can clearly see the diamond pattern biting into the filament. You want to see at least 2 columns of diamonds. 4 columns is too much. On the white UM2 plus and UM3 feeders you usually want the tension set in the center. 10) Other feeder issues, one of the nuts holding UM2 and UM3 together often interferes with the feeder motor tilting it enough so that it still works but not very well. Other things that tilt the feeder motor, sleeve misaligned so it doesn't get a good grip. Gunk clogging the mechanism in there. 11) Filament diameter too big - 3mm is too much. 3mm filament is usually 2.85mm nominal or sometimes 2.9mm +/- .05. But some manufacturers (especially in china) make true 3.0mm filament with a tolerance of .1mm which is useless in an Ultimaker. It will print for a few meters and then clog so tight in the bowden you will have to remove the bowden from both ends to get the filament out. Throw that filament in the trash! It will save you weeks of pain 11b) Something wedged in with the filament. I was setting up 5 printers at once and ran filament change on all of them. One was slowly moving the filament through the tube and was almost to the head when I pushed the button and it sped up and ground the filament badly. I didn't think it was a problem and went ahead and printed something but there was a ground up spot followed by a flap of filament that got jammed in the bowden tube. Having the "plus" upgrade or using the IRobertI feeder helps you feel this with your hand by sliding the filament through the bowden a bit to see if it is stuck. 12) Hot weather. If air is above 30C or even possibly 25C, the air temperature combined with the extruder temperature can soften the filament inside the feeder such that it is getting squeezed flat as it passes through the feeder - this is obvious as you can see the problem in the bowden. The fix is to add a desk fan blowing on the back of the printer. Not an issue on the UM3 or UM2 "plus" series. 13) Crimped bowden. At least one person had an issue where the bowden was crimped a bit too much at the feeder end although the printer worked fine when new it eventually got worse and had underextrusion on random layers. it's easy to pull the bowden out of the feeder end and examine it. 14) Worn Bowden. After a lot of printing (or a little printing with abrasive filaments) the bowden resistance can be significant. It's easy to test by removing it completely from the machine and inserting some filament through it while one person holds it in the U shape. Preferably i nsert filament that has the pattern from the feeder. 15) Small nozzle. Rumor has it some of the .4mm nozzles are closer to .35mm. Not sure if this is actually true. I'm a bit skeptical but try a .6mm nozzle maybe. 16) CF filament. The knurled sleeve in the extruder can get ground down smooth - particularly from carbon fill. 4 spools of CF will destroy not just nozzles but the knurled sleeve also. Look at it visually where the filament touches the "pyramids". Make sure the pyramids are sharp. 17) Hot feeder driver. I've seen a more recent problem in the forums (>=2015) where people's stepper drivers get too hot - this is mostly a problem with the Z axis but also with the feeder. The high temps means the driver appears to shut down for a well under a second - maybe there is a temp sensor built into the driver chip? The solution from Ultimaker is that they lowered all the currents to their stepper drivers in the newer firmware. Another solution is to remove the cover and use desk fan to get a tiny bit of air movement under there. TinkerMarlin lets you set the currents from the menu system or you can send a gcode to lower the current. Ultimaker lowered the default currents in July of 2015 from 1300ma to 1200ma for X,Y,Z but left extruder at 1250. Other people (I think the support team of a major reseller but I forget) recommend X,Y,Z go down to 1000mA. M907 E1250 Above sets the extruder max current to the default - 1250mA. So try 900mA. This will only change until next power cycle so if you like your new value and want to save it use M500. You can just put these into an otherwise empty gcode file and "print" this and it will change. Or get tinkergnome marlin! You will wonder how you lived without it: https://github.com/TinkerGnome/Ultimaker2Marlin/releases M907 E900 M500 18) third fan broken. This tends to cause complete non-extrusion part way through a print. In the rear of the head for UM2 and the front of the head for UM3. Without this fan several things can go wrong. It can take a while as usually you also need several retractions to carry the heat upwards. There are a few failure mechanisms and I don't understand them all. One of them is probably that the molten PLA spreads out above the teflon and sticks to the metal in a core or fills the gap at the base of the bowden in UM2. Later it cools enough to keep the filament from moving up or down. 19) Spiralize/vase mode. This is a rarely used feature of Cura but you might have left it on by accident? In this mode the wall of your part is printed in a single pass. So if you have a .4mm nozzle and the wall is .8mm thick it will try to over extrude by 2X. This is difficult to do and may instead lead to underextrusion. 20) non-standard or bent fan shroud. Sometimes people print some fan shroud off of thingiverse or youmagine out of PLA or ABS. Some of these are great but most of them are crap. One needs to do good air flow modeling. Also if it's PLA it will slump and direct air differently. Air directed at the block or nozzle can cause severe underextrusion and also sometimes HEATER ERROR. Put the original shroud back on or just turn off the fan to prove that the fan is the problem. 21) Firmware settings - for example UM2+ firmware on UM2 or vice versa will cause 2X over extrusion or 2X underextrusion. Downgrading or changing firmware can mess up steps/mm and other settings - so if you updated firmware and then problems started then do a "reset to factory settigns" which corrects all the steps/mm values. 22) too many retractions (this causes complete failure) - if you have too many retractions on the same piece of filament you can grind it to dust. 10 is usually safe. 20 is in the danger zone. 50 should guarantee failure. You can tell cura to limit retractions to 10 per a given spot of filament. Do this by setting "maximum retration count" to 10 and "minimum extrusion distance" to your retraction distance (4.5mm for UM2 and 6.5 for UM3 and 8mm for S5). 23) Brittle filament. Espciallty with older PLA but even brand new pla can do this. If you unspool some (for example if it's in the bowden) for many hours (e.g. 10 hours) it can get extremely brittle and it can snap off into multiple pieces in the bowden. It's not obvious if you don't look for this. Then it starts printing just fine and at some point one of those pieces reaches the print head and gets hung up somewhere and the printer suddenly stops extruding for now apparent reason. This usually happens within the first meter of filament - once you get to printing the filament that was recently on the spool it should be fine from then on. 24) The "plus" feeder can have an issue where the filament doesn't sit properly for one print and it permanently damages the arm inside the feeder as shown by this photo - the hole is ground down asymetrically: http://gr5.org/plus_feeder_issue.jpg 25) Other feeder issues. You can test the feeder by putting the filament only part way down the bowden and with the feeder electrically turned on (or moving) pull very hard on the filament until it slips. You should be able to pull with about 5kg or 10 pounds of force before it slips. 4kg is acceptable. 2kg is a problem. If the stepper motor isn't engaged you can try going into the move menu. After a minute or so power is removed again from the feeder stepper.
  3. 1 point
    Certainly you can also do this by messing with the firmware. But if this really bothers you then consider ordering a spare set of LED strips. Every reseller of Ultimaker has the ability to order and send you *any* part. These parts aren't shown in their stores (there are too many) but if you email them then you can get a price quote. For example 3dverkstan.se
  4. 1 point
    The lights are actually RGBW (last one is white). In other words there are 4 different controllable LEDs inside each of the 40 or so lights. But there is no way to control just the right or left side. They are all controlled together. Maybe you could dim the blue or white component on both sides to get it more balanced. So you used to be able to change the colors with M142. I'm not sure if that works with latest firmware. One method is described here (post by neotko): The more complicated way but more interactive way of trying out different colors is shown in this video (also by neotko):
  5. 1 point
    Das ist sch√∂n und gut mit deinem Beispiel Gerd, aber diese Pfeiler tauchen fast bei jedem Objekt auf, sobald man St√ľtztsrucktur aktiviert. Es f√§llt euch wahrscheinlich bis jetzt nicht auf , weil sie klein sind und wie St√ľtztstrucktur aussehen. Normal sind diese Pfeiler v√∂llig √ľberfl√ľssing und st√∂rend. Als diese Funktion entwickelt wurde, glaube schon vor mehrere Jahren, war sie automatisch (Standard) aktiviert und ausgeblendet und ich bekam davon nichts mit. Sie war immer da sobald ich St√ľtztstrucktur brauchte, konnte mit keiner St√ľtzstrucktureinstellungen wegbekommen, weil die Funktion versteckt war, ich war ziemlich ver√§rgert. Hier ein Beispiel wieso sie st√∂rend sind, normal ist sie auf 3mm hier habe ich auf 6mm gemacht um besser verdeutlichen zu k√∂nnen. Also diesen Bl√∂dsinn besser deaktivieren.
  6. 1 point
    You could try rotating it 90 degrees.The problem is that printers aren't simultaneous 3d so the Z will always be in small steps because they can't move all three axis at the same time. I work with cnc's and printer is what we refer to at 21/2D.
This leaderboard is set to Amsterdam/GMT+02:00
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!