Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up

Leaderboard


Popular Content

Showing content with the highest reputation since 08/19/2020 in all areas

  1. 5 points
    Today we celebrate the launch of Ultimaker Cura 4.7 stable. After yet another Beta test period where our amazing community helped us test, we feel comfortable to move forward. So, what do we have in store for you: With this launch we are also trying something new. We've created a short video where we inform you about a range of new features that are in Ultimaker Cura 4.7. What do you think? Is it useful for you? The usual description and highlights of Ultimaker Cura 4.7 you can find underneath. Improving your workflow Adding a Cloud printer to Ultimaker Cura became much easier. Where before you had to add each individual printer, Cura adds all printers you have in the Digital factory when you sign in with your Ultimaker account. If you don’t log in, account synchronization can be triggered later via the “Add a Cloud printer button.” A reboot is not needed to install printers. Improved search The wide range of available settings can be a blessing when you want to fully optimize and configure your print strategy. But sometimes it can also be overwhelming. “What was that one setting called again I used the other day? It had something to do with ...” With this improved search you can search for what a feature does, instead of what it is called. Practically this means you can now search for keywords that match the description of a feature. Model error detection. When you upload a model which is not a manifold or contains errors Cura will present you with a pop-up warning. You can go back to your CAD software to correct it and retry slicing it in Cura, saving you the time and frustration of discovering the error during mid-print. Thanks to @ahoeben smartavionics, and @bagel-orb for their contributions to this feature Tree-support improvements. Together with moving the tree support out of the Experimental category and into the support type dropdown, we also fixed multiple reported issues where the support branches would interfere with the model, or the support bottom distance was too small, or printing in the vase mode. Thanks everyone who helped testing! Rotation widgets.  @ahoeben has contributed code that adds three pairs of arrow widgets to the Rotate tool handle, enabling you to rotate objects by exactly 90 degrees.   Performance improvements with multiple 3D models.  In previous versions many objects on a build plate could cause Ultimaker Cura's performance and response to be slow. We have made some code optimizations to increase responsiveness in such cases.  Thank you all that helped with testing Ultimaker Cura 4.7 Beta, and realize this stable version. Your efforts mean a lot to us! That is not all! More features and bug fixes can be found via this link. Ready to give it a go? Download Ultimaker Cura 4.7 now. Direct link to dmg and exe. Let us know below what you think! Have a great day!
  2. 5 points
    I just read a rumour about a drop in core, bowden and feeder to handle continuous fibre.
  3. 5 points
    You know i'm not supposed to talk about it. But it is nice to make a product where "it sucks" is a feature!
  4. 5 points
    Get our crap together? Excuse me? You're using an open source product, on hardware that we don't sell or support. We don't even have those third party printers nor the capacity (and desire) to actually test them. So if you want to prevent issues like that, pleas use the beta and report these issues during the beta. As you can see, i've managed to create a fix for this within a single hour of this being reported. We test Cura as much as we can, but we greatly focus on Ultimaker machines since 99% of the development of Cura is paid from the revenus of Ultimaker.
  5. 3 points
    Thanks you. After some tests, trials and errors, I can now print whit the accuracy I need ! The settings I use are the one above with jerks at 20, retraction at every layers. I use the engineer profile at 1.5. Now my prints don't expand. The settings that help is Horizontal Expansion : -0.16 (For Ultimaker PLA Tough and Ultimaker PLA) Hope it help others as well. I got scared for a while, but the problem was the guy in front of the printer not the machine.
  6. 3 points
    I signed up just to say thank you so much. 4.7.1 fixed this for me. Much appreciated!
  7. 3 points
    here is the assembly video of my 3d printed JET BOAT
  8. 3 points
    Cute how in the video the 90 degree widgets are mentioned but then not used. Click the arrows on the arcs to rotate by 90 degrees. PS: @fieldofview is @ahoeben on the forum.
  9. 3 points
    We are two trainees in the Planetary and Robotics Laboratory at the European Space Agency and we built ExoMy, an educational mars rover: It is completely 3D printed on an Ultimaker 3 and an Ultimaker 2, which took us around two weeks of print time. We set up a website and a Github Wiki to guide through the whole build process. So we hope to see some ExoMy clones soon :)
  10. 2 points
    🙂 - let's better say it was a mix of a lot of options in Cura with difficult requirements. Thanks for the feedback, and happy that it is now working for you!
  11. 2 points
    Did you re-slice the model and try to print the new Gcode file - or did you run the previous Gcode that worked? Within the printer under Control / Filament make sure "E in mm³" is "Off". Looking at W1_underextrude.gcode in line 4 it says it uses 20.868m of filament. Dumping the file into AutoCad I come up with 505720.78mm of extrusion and a total E of 20.89mm. So that's whats going on in the Gcode file. With an initial layer height of .2, a layer height of .25, and a line width of .4 and doing some math (sorry grNadpa) then layer 1 is 16020.78mm extrusion and 534.5mm of filament. The rest of the file comes to 489650.5mm extrusion and 20357.30mm filament. Total filament on a piece of paper comes to 20.891meters of filament. That is a difference of .0238mm of filament which equates to about .5mm of extrusion out of 505720mm total extrusion. I would say that in the case of the W1_underextrude file that the problem is not in the Gcode. I did notice that in line 24 of the gcode file there is M92 E94.8. That number does represent your extruder E-steps right? Sincerely, Dr. Bunsen Honeydew Muppet Labs PS I printer about 10 layers and they looked good.
  12. 2 points
    Yes, I got the same problems, and only now found the solution. Just change the thickness of the filament from 2.85 to 1.75 in the settings. Of course it would help only if u use 1.75 mm filament.
  13. 2 points
    I generally respond to those pings, although I don't track issues on the forum itself. If you seek to modify the layer heights, look for the buildLayersWithHeight function of the Slicer class: https://github.com/Ultimaker/CuraEngine/blob/51ee4b7adf6dfd112241cdf3fd5681e87cf6370c/src/slicer.cpp#L929 In this function it determines the Z coordinate of each layer, either by calculating from the layer height and initial layer height, or by asking the AdaptiveLayer class.
  14. 2 points
    /facepalm Thank you good sir, I was certain there had to be an option for it somewhere, but for the life of me i couldn't find it yesterday lol. Was already doing the manual rename, but forget every now and then. Interesting to know, thank you again. Cheers Nallath, I went and found a plugin by fieldOfView (aka ahoeben on forum ?) called "Custom Printjob Naming" that works precisely as advertised.
  15. 2 points
    Got it. In my haste I missed the change button. This is the second spool we finished fo far and we have not yet really changed spools so never used the change feature. Thanks for your reply, this issue is resolved and the printer is happily printing again!
  16. 2 points
    Hi, You don't press the unload button when you have run out of filament, when you run out of filament and the prints auto paused you go to the filament thats run out and press the "change" button to change out the spool. The unload button is for just removing a spool and not loading a new one for when you are printing and only needing one print core so you can store your other spool somewhere. The load button is for when you wish to load a spool back onto the printer. This is why both the load and unload are greyed out when printing. When changeing spool always use the "change" button.
  17. 2 points
    Hi guys, After years of following the evolution of the mark2 project, I finally got my hands on relatively cheap second-hand Ultimaker 2 (non plus that wasn't in the best shape to be honest) and did the upgrade a week after receiving the machine! As a UMO veteran - not even the Ulticontroller was around when I first got my machine xD- I am super amazed how well the mark2 does! While I have been playing around with the original dual extrusion upgrade, I must say that the mark2 is lightyears ahead in every concern!! I created a magnetic head for my e3d-hotend that I'll be sharing any time soon : As well as a basic blade-holder for a vinyl-cutter to mimic a design I found here: @IRobertI With all of this being WIP, I am looking forward to try the cutter as soon as the blade arrives and give the e3D Hotend a try (all cables on the second head are already equipped with molex connectors to enable a very quick head-swap)!! Update: Turns out, that the mark2 penholder is a much besser way to attach the blade to the printer, as it exactly fits the 11m diameter of Roland-like blade holders AND also holdes a pen firmly! I adapted the design by making is little longer and tried it on the printer just yesterday, as I am still in the gcode generation process, there are no pics or upload yet.. -> I'll update you soon! Thanks again to every one involved in the mark2 project, @foehnsturm and @tinkergnome specifically! Cheers, JI
  18. 2 points
    I guess the root cause for your problem is that the fan in the back is not running or is blocked. This fan cools the upper part of the hot end. Check if the fan is working when you heat up the nozzle. It should start automatically when the temp of the nozzle is higher than 40/50C.
  19. 2 points
    One PC is all you need, you'll just add all the printers into Cura and choose which one you want to use for each particular job.
  20. 2 points
    The problem is it wont be fixed unless they can track it via github.
  21. 2 points
    Holes like to come out undersized. The plastic is viscous enough that it gets dragged towards the center as it extrudes. @gr5 calls it the "Snot Factor" and the smaller the hole the worse it is. Under "Shell" you'll find "Hole Horizontal Expansion" and it will get you much closer. It is an offset setting and so it acts on the radius. Your diameters are off by about .8 so set the Hole Horizontal Expansion to .4mm. Another thing - is that image of the part accurate as to the resolution of the STL file? Check in TinkerCad and see if there is an option for a higher resolution when it generates the STL file. A part with so few facets around the diameter will have it's own issues as the plastic gets dragged across the facet angles effectively making the hole smaller.
  22. 2 points
    Open %APPDATA%\cura\4.7\cura.cfg in a texteditor (eg notepad). In the [general] section, remove the lines starting with window_left and window_right Save the file and try starting Cura again. If that worked, go into the General preferences and uncheck the option to "Restore window position on start".
  23. 2 points
    I've set up my lights so they're on during printing and off otherwise, which is what I prefer. However, when I'm doing things like changing the build plate or applying glue, I'd like to be able to quickly switch the lights on so I can see what I'm doing. Currently I have to go into the settings and turn off the "only on during printing" option. It would be nice to have a button in the corner on the home screen to just turn the lights on or off, preferably available during prints as well! I'm not sure what the behavior should be when the printer performs an action that would change the lights, like starting a print. Perhaps the button could cycle through three options - on, off, and "as configured in settings".
  24. 2 points
    @ahoeben I just want to be the one who is responsible for this: Congratulations!
  25. 2 points
    Pssst! It is still a secret, but I have already seen a shop who has listed the new CC green (Cleaning Cores) for the vacuum cleaner. One for carpets and the other one for hard floors.
  26. 2 points
    Come on @nallath, tell use about the vacuum cleaner!
  27. 2 points
    After days of searching for this Easter egg, we finally found it. We can't believe how hard it was to find but it was very much worth it. Excellent challenge!
  28. 2 points
    On the left of the Cura workspace screen is a toolbar. The bottom tool is "Support Blocker". Select your model and then select Support Blocker. Click somewhere on the model to create a block. On the lower left there will be a list of the objects on the build plate (oddly enough called the "Object List"). Your new support blocker will be Eraser and additional blocks will be added to the list. You can make them active by selecting them on the list. When you select the Eraser block you can drag it around or type numbers into the Move tool dialog. You can also scale it separately in all three axis. When it covers the proper section of your model you can also elect to have different settings for the intersection volume between your model and the blocker (it's under "Per Model" settings just above the blocker tool). I found that if I wanted to block support AND infill from an area that I needed two blocks covering the same area with one set to infill and the other set to support. I haven't played with that aspect of Cura a lot though.
  29. 2 points
    If users of 3rd party printers aren't willing to try the beta releases, they should expect trouble when the releases arrive as UM do not have the resources to test on anything but their own products. Yes, Cura is supplied FOC but maybe people need to be willing to pay a price for it, the price is that they play an active role in the testing of new releases.
  30. 2 points
    I like that idea. Perhaps it's something that we should put in the first run wizard.
  31. 2 points
    Well, there is a reason why i fixed the bug. It's not like we don't care at all about what third party printers do / work with Cura. But well, there are hundreds of printers available in Cura. If we would need to test all of that, we'd need 20+ QA engineers. At a certain point, there is an end to the amount of money that Ultimaker is willing to invest into support third party printers. That value isn't zero, but it's obviously not the same as in our own printers. I guess my frustration with all of this is that the bug was blatantly obvious to someone who had that configuration. But even though there was a beta build out there for 2.5 weeks, it wasn't spotted (because not enough people used it, I guess). Then a lot of other people start complaining that they are "being tricked into beta testing something" because there is a pretty annoying bug to them in the release. A part of the value from supporting these third party printers stems from the goodwill / gateway that you describe. But a fairly significant part is also based on it helping us find issues that are generic for everyone. It's not that I ask people to run a complete testing plan or check every single feature they use. But a few percent of our users would just download and start the beta, slice a few things and maybe play with some of the new features, it would help a great deal. I still strongly believe in an open source product that works for everyone. But it's really hard to do it. That's why I push so much on people using that beta. I desperately need the feedback from that in order provide what I want to provide; A stable release for everyone.
  32. 2 points
    Old problem resurfacing? I start 4.7, try to add a non network printer, cura crashes.? Is it me? Windows 10, Intel I5
  33. 2 points
    Here's a blogpost with a summary of the repair: https://www.coredump.ch/2020/08/25/ultimaker-2-repair/
  34. 2 points
    In the interest of continuing this "I'll show you mine if you show me yours" thread... I'm attaching two project files. They contain the same model (25x25x25 cube with no features). Settings wise it's pretty vanilla with no skirt/brim and with infill at 100%. One has all flows at 100% and the other has all flows at 50%. When sliced in Cura 4.6.1 on my laptop the Gcode files turn out as I expected. The 50% file uses half as much plastic. If you would be so kind as to open each of the files and slice them on your computer and show the results - maybe we can figure this out. My expectations are that since we are running the same version we should come up with the same results. For reference - from my gcode file of the slice of the 25x25x100.3mf file: ;Filament used: 6.69192m and from my gcode file of the 25x25x50.smf slice: ;Filament used: 3.3331m 25x25Cube50.3mf 25x25Cube100.3mf
  35. 2 points
    There is no correct place to put this, but since accuracy and finish are involved I stuck it in this thread. I've started work on my own 3d printer design. It will: 1a. Produce 3d Prints with a finish like 12 coats of hand-rubbed lacquer. 1b. Provide an accuracy of +/- 1 nanometer. 2. Come with slicing software that knows what the user wants and never forgets to move the Z seam. 3. Have a Single Button-Single Function virtual "Start Print" control. 4. Provide a printing speed of 1,000,000 mm/sec. 5. Print any material from chocolate to tungsten. 6. Be powered by an on-board flux capacitor. 7. Be absolutely silent. 8. Be easily up-gradable. 9. Have a price tag of $19.95 and a 100 year warranty. 10. Remember birthdays and anniversaries and automatically print a nice gift. It's called the Harry Potter 3d Platinum Pro XL Extended v1 Cabriolet. It is available for pre-order now. I hope Ultimaker doesn't take exception to this blatant advertising blurb on their forum.
  36. 2 points
    @gmeardi If you can love the solution depends on how much you are willing to stretch 'easy', so here we go. Before working with the Ultimaker S5, I've never really put my mind to NFC technology, so there are very probably some gaps in my understanding. Most of what I've learned, I've deduced from comparing the data from different spools and with different amounts of remaining material. The rest I could fill in reading the relevant python code of the firmware after ssh-ing into the printer. As @Daid pointed out earlier, Ultimaker tried to implement NDEF records. According to the NFCForum-TS-Type-2-Tag standard, NDEF records need to be embedded in a NDEF Message TLV, which is missing on the Ultimaker NFC tags. That's why NFC apps report there are no NDEF records on the tags. Other than that though, the data adheres to the NDEF standard, so I was able to use the python package ndeflib to add custom record types to decode and encode the tag data. The code on https://gist.github.com/gandy92/a7eef12009045f7b3fc01d778c3b79a7 demonstrates just that. Based on this code, you can decode the data from your spools to check how much material is left (usually given in mg) or plug in the UUID from your custom material profile and the amount of material on the spool and create the data to write to your NFC tag. I will not elaborate on how to actually write the data. This depends heavily on your tag writer and OS and would by far exceed the scope of this comment. For our spools, we carefully extract the NFC tags from empty spool and transfer them to the third-party spools. Make sure to always write complete blocks to the tag: There are two stat-records on the tag, apparently with usage data at different times. My first guess was this is used for redundancy in case a stat-record gets corrupted, e.g. by the printer loosing power during a write operation. In my first writing attempts however, I failed to write the last block, rendering the whole tag unreadable for the UM-S5. I'm not sure if this is due to design or simply a bug in the firmware, but if any of the two stat-records show the wrong checksum, the whole spool is simply ignored by the printer. In Cura, I've learned it is important to actually have two filament profiles: {brand}_{material}.xml.fdm_material, where brand and color are set to "Generic" (in the profile, not in the filename) {brand}_{material}_{color}.xml.fdm_material fills in the actual values and additionally provides the amount of material Say you have material M of brand B in color C, you want two files, B_M.xml.material and B_M_C.xml.material. For a new brand and material combination, I suggest to select an existing material in Cura as template: When creating a new custom profile, Cura will pick a new UUID for it. Then add one profile for each color, each with a different UUID. Use these UUIDs for the tags. You will need to use a text editor to adjust the profiles. Later, Cura will sync the profiles with the printer, so there is no need to upload them yourself. Just make sure to increase the profile version number and never again change the UUID. There's one caveat however, when using the material station: The profile tells the printer how to load/unload the filament, but so far I couldn't find documentation on the parameters, so maybe using the profile of a material with similar properties would be a good idea. Being extra careful and standing by the printer is another good idea. For perfect integration in Cura, it would be great having intent profiles for the material, which we are still struggling to figure out how to create. If anyone managed, I'll be happy for tips or suggestions.
  37. 2 points
    Small python tool that helps adding 3rd party material to Ultimaker S5 on-display material type selection. https://github.com/flyinggorilla/ultimaker-s5 I do like the NFC enabled Ultimaker filaments and I am impressed how easy printing with the Ultimaker S5 can be. However, ordering filament through third party vendors is always a challenge, because they usually have only a fraction of filaments in their stores. Also do my use cases go beyond Ultimaker filament material types. So i complement Ultimaker material now primarily with FormFutura material (they have a great online store, and DimaFix is a great adhesion liquid). Just for completeness, material cost is not the key reason for me to use 3rd party material, as NFC comfort is absolutely worth the money. So this tool is using the S5 REST interface to upload .fdm_material types. You can create materials in Cura, but those dont work due to wrong machine name. The tool checks for that and tells you to fix it in the .fdm_material definition. However, once you have the material on the printer and in cura with the same material name, then you dont get the warning of incompatible materials anymore. @Ultimaker what really would be helpful is a description of the XML schema, especially the various settings attributes as the Cura documentation is not sufficient. e.g. settings like retract compensation, surface energy, adhesion tendency, flow sensor detection margin and retract compensation, … and for sure more are not documented. At least i couldn't find the doc. Thanks for creating such great printers and great Cura software. FG
  38. 1 point
    I just want to say Thank you. My problem of stl opening crash got fixed by Cura 4.7.1. Thank you.
  39. 1 point
    Within the settings you can find a checkbox called "Adaptive layering". I think it would be nice if, inside the "Modify settings for overlap" mesh type, the "Layer height" option would be there. This would allow you to set different layer heights for different parts of your model(s), e.g. say I wanted to print a Flexi Rex. Normally, I would set a small layer height so the joints don't fail, but then the whole model would have to be that layer height, therefore taking more time. But if I use this feature, I could add a cube, scale it to fit the joints, and set the joints to be a smaller layer height, so the joints would be a smaller layer height, but not the whole model. TL;DR Add kind of a manual adaptive layering. Thanks!
  40. 1 point
    Can you check if your front fan is running when the core heats up over 40 or 50°C ? How fast do you print? And do you use one of the default Cura profiles?
  41. 1 point
    We are also not in the US 😉 Ultimaker is a Dutch company, so I think we are "neighbors" 😉 LOL, I will try, espresso cappuccino?
  42. 1 point
    Yup, It do look like that little beastie. As soon as I selected a generic PLA instead of my eSun PLA+, they all came back. Thanks, Wayne
  43. 1 point
  44. 1 point
    Could you be so kind to open two issues for these points at https://github.com/fieldofview/Cura-SidebarGUIPlugin/issues ? Otherwise I might forget.
  45. 1 point
    Don't you have these 3 horizontal stripes to click on? It's under there..
  46. 1 point
    Ahoeben cheated by copy/pasting a previous comment he made.
  47. 1 point
    I printed a few more parts. I’m finding 0.4 to be ideal especially with larger parts with a lot of first layer geometry. Otherwise 0.3 is better for smaller parts. No warping or bed adhesion issues. But also yesterday I did maintenance on my hot end and mount. It was a bit loose before. Now my first layer adhesion is so good that I may not even need a brim. However it seems like no harm and lets the extruder work a little before the main print. With 0.4 gap it has no disadvantages at all so I’ll keep using a brim.
  48. 1 point
    That looks like 7 seriously under-extruded walls and a seriously under-extruded infill. You said there were no outer skins...was there a gap between the brim and the parts? If the answer is "no" then there is the answer. The walls are there, they just under-extruded so badly that the gaps make then look like infill. You have printed the set of parts before and Smithy mentioned warping. Those curved tuning fork looking parts are prime candidates for warping so I will assume you have an enclosure. I will also assume that the extruder is within the enclosure. The high heat environment may be having a bad effect on the extruder causing missed steps without making the normal clicking sound. If the reference voltage is off the extruder can run hot all by itself and that coupled with the heat of the enclosure the filament may not be getting pushed by the extruder. I exported the STL model out of Cura and sliced it with the Creality slicer - yes, there were some odd things going on with the infill. I have an Ender 3 Pro and much prefer the Cura slicer to the Creality slicer. (Actually, it isn't even close as Cura is far superior). I suggest you slice the file with Cura changing only the hot end and bed temps to PLA and then start a print with PLA. At layer 3 you can abort the print as you should have an idea of what is really going on. The walls/skins can be searched for in the gcode as ";TYPE:WALL-OUTER" and ";TYPE:WALL-INNER". I believe you will find them in there.
  49. 1 point
    OK I found a solution/hack: I cura under "Build Plate Adhesion" add a "Skirt" using the extruder you want to have for the textlayer. This material will be printed first for the skirt and therefore first for your textlayer.
  50. 1 point
    Brand new to Cura and 3D printing so please forgive the basic questions! Opened Cura and loaded a .STL from Thingiverse. File loaded fine but no "Print" icon appeared. Went to File-Print but the printer didn't respond. I also created a simple object on TinkerCad but got the same result in Cura. Other objects I downloaded from Thingiverse printed with no problem. What am I doing wrong? Using a PrintrBot Play printer. Thanks! Dave
This leaderboard is set to Amsterdam/GMT+02:00
×
×
  • Create New...