Jump to content
Ultimaker Community of 3D Printing Experts

nsa666

Dormant
  • Content Count

    8
  • Joined

  • Last visited

    Never

Community Reputation

0 Neutral
  1. I am getting strange "Line Number is not Last Line Number+1" errors from my printer while printing from USB. Some serial buffering error?
  2. manually configure port does not help in this case. if platform.system() == "Windows": return port in serialList(True) the serialList() return value remains empty. or should i change the True to False?
  3. Unfortunatly no. I am using RepRapPro Huxley (Melzi-based). Edit: I'm using Windows 8 and the printer is connected to COM9
  4. i think i found the bug. in machineCom.py line 30: try: key=_winreg.OpenKey(_winreg.HKEY_LOCAL_MACHINE,"HARDWARE\\DEVICEMAP\\SERIALCOMM") i=0 while True: values = _winreg.EnumValue(key, i) if not forAutoDetect or 'USBSER' in values[0]: baselist+=[values[1]] i+=1 except: the reg key looks like: The forAutoDetect is True and 'USBSER' is false. The list remains empty. The detection fails. Removing the "not" in front of forAutoDetect seems to help. but i don't know what side effects it has.
  5. I am sorry. Accedentialy pressed the post button. in function showPrintWindow (line 166) if button == 1: if machineCom.machineIsConnected(): printWindow.printFile(self._gcodeFilename) the second if allways delivers false even if the printer is connected. I will look at detection code now.
  6. I looked at the code. There seems to be a problem with printer detection.
  7. Hello, Great Update. It is somehow possible to change the default print button behavior from "save GCode.." to "Print with USB.." like it was on 13.04?
×
×
  • Create New...