Jump to content
Ultimaker Community of 3D Printing Experts

davendw

Dormant
  • Posts

    3
  • Joined

  • Last visited

    Never

davendw's Achievements

0

Reputation

  1. Does anyone have an example of the config file used in the command line CuraEngine? Is just filled with the settings seen in settings.cpp? Also, if I wanted to create a solid fill object should I be trying to set all the layers to skin? Is there a specific setting for that? Thanks, Dave
  2. Thank you for the response Daid. I have also used the make command and received the same error. Below is the full text on a clean clone of the github repository: C:ctestCuraEngine>make process_begin: CreateProcess(NULL, uname, ...) failed. g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" bridge.cpp -o bridge.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" comb.cpp -o comb.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" gcodeExport.cpp -o gcodeExport.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" infill.cpp -o infill.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" inset.cpp -o inset.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" layerPart.cpp -o layerPart.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" main.cpp -o main.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" optimizedModel.cpp -o optimizedModel.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" pathOrderOptimizer.cpp -o pathOrderOptimizer.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" polygonOptimizer.cpp -o polygonOptimizer.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" raft.cpp -o raft.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" settings.cpp -o settings.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" skin.cpp -o skin.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" skirt.cpp -o skirt.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" slicer.cpp -o slicer.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" support.cpp -o support.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" timeEstimate.cpp -o timeEstimate.o timeEstimate.cpp:203:6: warning: unused parameter 'previous' [-Wunused-parameter] void TimeEstimateCalculator::planner_reverse_pass_kernel(Block *previous, Block *current, Block *next) ^ timeEstimate.cpp:238:6: warning: unused parameter 'next' [-Wunused-parameter] void TimeEstimateCalculator::planner_forward_pass_kernel(Block *previous, Block *current, Block *next) ^ g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" clipper/clipper.cpp -o clipper/clipper.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" modelFile/modelFile.cpp -o modelFile/modelFile.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" utils/gettime.cpp -o utils/gettime.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" utils/logoutput.cpp -o utils/logoutput.o g++ -c -Wall -Wextra -O3 -fomit-frame-pointer -DVERSION="DEV" utils/socket.cpp -o utils/socket.o utils/socket.cpp: In constructor 'ClientSocket::ClientSocket()': utils/socket.cpp:28:29: warning: missing initializer for member 'WSAData::wHighVersion' [-Wmissing-field-initializers] WSADATA wsaData = {0}; ^ utils/socket.cpp:28:29: warning: missing initializer for member 'WSAData::iMaxSockets' [-Wmissing-field-initializers] utils/socket.cpp:28:29: warning: missing initializer for member 'WSAData::iMaxUdpDg' [-Wmissing-field-initializers] utils/socket.cpp:28:29: warning: missing initializer for member 'WSAData::lpVendorInfo' [-Wmissing-field-initializers] utils/socket.cpp:28:29: warning: missing initializer for member 'WSAData::szDescription' [-Wmissing-field-initializers] utils/socket.cpp:28:29: warning: missing initializer for member 'WSAData::szSystemStatus' [-Wmissing-field-initializers] g++ bridge.o comb.o gcodeExport.o infill.o inset.o layerPart.o main.o optimizedModel.o pathOrderOptimizer.o polygonOptimizer.o raft.o settings.o skin.o skirt.o slicer.o support.o timeEstimate.o clipper/clipper.o modelFile/modelFile.o utils/gettime.o utils/logoutput.o utils/socket.o -o CuraEngine utils/socket.o:socket.cpp:(.text+0x31): undefined reference to `__imp_WSAStartup' utils/socket.o:socket.cpp:(.text+0x70): undefined reference to `__imp_socket' utils/socket.o:socket.cpp:(.text+0x9e): undefined reference to `__imp_htons' utils/socket.o:socket.cpp:(.text+0xac): undefined reference to `__imp_inet_addr' utils/socket.o:socket.cpp:(.text+0xc2): undefined reference to `__imp_connect' utils/socket.o:socket.cpp:(.text+0xef): undefined reference to `__imp_closesocket' utils/socket.o:socket.cpp:(.text+0x112): undefined reference to `__imp_closesocket' utils/socket.o:socket.cpp:(.text+0x153): undefined reference to `__imp_send' utils/socket.o:socket.cpp:(.text+0x19a): undefined reference to `__imp_closesocket' utils/socket.o:socket.cpp:(.text+0x1d0): undefined reference to `__imp_send' utils/socket.o:socket.cpp:(.text+0x20a): undefined reference to `__imp_closesocket' utils/socket.o:socket.cpp:(.text+0x247): undefined reference to `__imp_recv' utils/socket.o:socket.cpp:(.text+0x296): undefined reference to `__imp_closesocket' utils/socket.o:socket.cpp:(.text+0x2d0): undefined reference to `__imp_recv' utils/socket.o:socket.cpp:(.text+0x316): undefined reference to `__imp_closesocket' utils/socket.o:socket.cpp:(.text+0x342): undefined reference to `__imp_closesocket' c:/mingw/bin/../lib/gcc/x86_64-w64-mingw32/4.8.2/../../../../x86_64-w64-mingw32/bin/ld.exe: utils/socket.o: bad reloc address 0x0 in section `.pdata' collect2.exe: error: ld returned 1 exit status make: *** [CuraEngine] Error 1 Thanks, Dave
  3. Hello Ultimaker team Great job on the new CuraEngine, it works great on Ubuntu. I am having issues with the build on windows with either the make or the g++ main.cpp modelFile/modelFile.cpp clipper/clipper.cpp -o CuraEngine The error is: c:/mingw/bin/../lib/gcc/x86_64-w64-mingw32/4.8.2/../../../../x86_64-w64-mingw32/bin/ld.exe: C:UsersDAppDataLocalTempccmRqjeG.o: bad reloc address 0x0 in section `.pdata$_ZnwyPv' I have the mingw32-gcc-g++ 4.8.1-4 installed and the MinGW Installation Manager. Am I missing a library or package? Thanks, Dave Full error: g++ main.cpp modelFile/modelFile.cpp clipper/clipper.cpp -o CuraEngine C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x61d): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x63b): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x686): undefined reference to `ConfigSettings::ConfigSettings()' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x6ac): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x6b8): undefined reference to `ConfigSettings::readSettings()' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x6d2): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x70a): undefined reference to `_log(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x7c1): undefined reference to `increaseVerboseLevel()' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x7cb): undefined reference to `enableProgressLogging()' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x8b7): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x8f6): undefined reference to `ConfigSettings::readSettings(char const*)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x929): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x9bc): undefined reference to `ConfigSettings::setSetting(char const*, char const*)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0x9f9): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0xada): undefined reference to `logError(char const*, ...)' C:UsersDAppDataLocalTempccmRqjeG.o:main.cpp:(.text+0xb8b): undefined reference to `logError(char const*, ...)' c:/mingw/bin/../lib/gcc/x86_64-w64-mingw32/4.8.2/../../../../x86_64-w64-mingw32/bin/ld.exe: C:UsersDAppDataLocalTempccmRqjeG.o: bad reloc address 0x0 in section `.pdata$_ZnwyPv' collect2.exe: error: ld returned 1 exit status
×
×
  • Create New...