Jump to content
Ultimaker Community of 3D Printing Experts

jflund

Dormant
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jflund

  • Birthday 09/30/1965

Personal Information

  • Field of Work
    Medicine
    Engineering
  • Country
    US
  1. I use SketchUp for modeling most of the objects I print, but on annoying "feature" with SketchUp is that it moves, merges, and even throws out vertices, edges, and faces that are extremely small or close together. The generally accepted workaround to this is to design objects at a scale 10, 100, or even 1000 times larger than needed and then scale back down in order to export the STL file for printing. However, this is a real pain. If you forget to scale the model down, Cura scales it down to fit the build plate, but you may not notice that is what happened if your model nearly fills the build plate. And even when you do remember, its annoying to have to keep scaling up and down. Even worse is to model objects at their actual size because then you often end up with problems that can take hours to repair. I would suggest a cleaner workaround. Could Cura be modified to allow a scale factor to be specified when an object is extremely large? That way, if I usually model at 100x, I could specify a scale factor of 0.01 for extremely large objects and Cura would do the scaling-down automatically for me when I load the model. The current functionality of scaling to fit the build plate could continue to be used if the model is still too large after applying the specified scale factor. This way, only the second scaling operation (i.e. the "scale-to-fit" operation) would need to generate a warning, and the first scale would seamlessly connect SketchUp with Cura, no warning necessary. So in summary: Can a new preference be added to the General section and the existing scaling preference be changed as follows: [x] Initially scale extremely large objects by ___0.01___ to attempt to make them fit the build plate [x] Scale models that are still too large so that they fit the build plate where the "0.01" value can be modified by the user (and saved as a preference)? Just a thought, but why not make life simpler whenever possible?
  2. I upgraded my printer with the 2+ upgrade from Ultimaker and updated the firmware as recommended. However, I can now no longer save modifications to materials. When I change the printhead temperatures and save the material as a custom material, the new material doesn't exist. When I save the Materials to a text file, modify the text file, and load the new file back into the Ultimaker, the changes I made in the file are not loaded. I have done this many times in the past, so I doubt I'm creating an error in the file or anything. Even just changing the name and loading the file doesn't work. I'd appreciate anyone's help with this.
  3. I just got my Ultimaker 2 and it initially worked great. I printed 5 or 6 item without problems. I then upgraded the printer firmware and since the retraction seems to be working incorrectly. When I print something with several different high areas separated by low areas (the latest is printing the ribs on a T-Rex skeleton with the ribs pointing up. I get massive stringing between the ribs, so much that they are essentially one solid part. I have determined that the problem seems to be that when one rib is printed and the head is ready to move to the adjacent rib, the Ultimaker 2 pauses the print head, performs the retraction, but then advances the filament forward BEFORE moving to the next rib. Because of this, it essentially prints the space between parts. It seems this has to be a bug. Is there utility in retracting AND advancing before a move? I have tried with combing enabled and disabled and the same think happens. Even stranger, it appears that when the print gets to the top-most layers where each layer is small, the extruder retracts and advances the filament repeatedly while it waits for the minLayerTime to expire. This has flattened the filament several times causing failure to extrude (just before the print finishes of course). I have tried using the default combing/retraction settings, and I have lengthened "Minimum travel" and "Minimal extrusion before retracting", and both enabling and disabling "Combing", but none of those settings seem to have any effect. Any ideas how I can stop this behavior of both retraction AND advancing BEFORE moves?
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!