Jump to content

boelle

Member
  • Content Count

    32
  • Joined

  • Last visited

Community Reputation

1 Neutral

Personal Information

  • Country
    DK
  1. oki, where would my questions have a bigger chance for getting an answer? i have posted one other thread but no luck there either otherwise i can only say thumbs up to the software, it has come a long way since i used it last time. I'm just a control freak when it comes to how the code is exported
  2. i'm confused, i allready have 3.5 beta so was it a type error? and have i posted the wrong place since no one are able to tell me where cura gets the extra M104 S0 and M104 S0
  3. when i try search and replce with boundry arround M104 S0 it of course removes it from all lines so that my own switch off lines are also altered i tried to google for how to do an precise match but i could not figure it
  4. ahhh google found this post for me: now i just need to figure how to make it remove: M82 ;absolute extrusion mode is that possible or can the search and replace plugin only replace?
  5. tried the search and replace script, worked ok for the M82 "problem" but created an empty line the double switching off could not be solved as it would remove both those from my end gcode and those that cura inserts on its own the latter is more important as i have a sequence that move the bed in front of a larger fan to cool the whole bed off after print, reducing the time i have to wait before the PEI will let go. this takes about 10 mins where the printer just waits and to be honest what is wrong in having full control of the prodcued Gcode? but yes, i will try and figure myself if there are other scripts that can do the trick
  6. the other mystery to me is the double switching off things in the end code so 2 times M104 and 2 times M140 and the json file for the mk2 has the start and end gcode empty to prevent it from adding stuff to start and end code i dont want
  7. will have a look btw i use windows, but as long there is a post process script out there that can remove it then i'm happy any idea why it also puts an M82 to the end code?
  8. nobody that can give pointers to where cura get's the M82 and the extra swith off in the end code?
  9. Hi I also tried the new beta and i got it almost where i want it but it add some to start and end gcode that i have not figured where comes from after install i picked prusa mk2 as machine and then i changed the start and end code to my liking and i removed the start and end code from the mk2 json so it would not adding anything i did not like but still it add M82 to both start and end gcode, and it also add heater and bed switch off to end code even thou i have them in my end code i made a post here: but i did not get the answers i was looking for
  10. i wonder if @SandervG can point me where the slicers gets those M82 and M140/M104 from the M104/140 with a comment after it are correct as those are in the end Gcode
  11. i might have looked the wrong place but i could not find any settings that would leave heaters on
  12. i will give it a check in cura, been a long time since i used it last its more that i like to be in control of the start and end gcode so i know kind of can depend on how its created or at least i can know where thing come from
  13. hmm strange, even with those to set to " " i get this in my start of saved gcode M82 ;absolute extrusion mode G28 Z; Home Z G28 Y; Home Y G28 X; Home X G29 M140 S100.0 ; set bed temp M190 S100.0 ; wait for bed temp G92 E0 ; zero the extruded length G1 X50 Y0 F3000 ; go to the middle of the front G1 Z0.1 ; close to the bed M104 S210 ; set extruder temp M109 S210 ; wait for extruder temp G1 X100 E10 F200 ; make a thick line to prime extruder G92 E0 ; zero the extruded length G1 Z0.3 ; lift Z G4 S2 ;wait 2 sec to bleed off excess pressure G92 E0 G1 F3600 E-4.5 where does the M82 come from? its not in my start code and its removed from the json i assume the G1 F3600 E-4.5 is inserted automatic based on my retract as not to ozze just before print start the end of the code looks like this: G1 F3600 E2091.48677 M140 S0 M104 S0 ; turn off extruder M140 S0 ; turn off heatbed G28 X; Home X G28 Z; Home Z G0 Y0 F5000 ; Move Y to middle of bed cooling fan M42 P11 S255 ; Turn on Bed cooling fan on M106 ; cool off nozzle G4 S660 ;wait 11 minutes M42 P11 S0 ;Turn off bed cooling fan M107 ; carriage fan off G28 Y; home Y M84 ; disable motors M82 ;absolute extrusion mode M104 S0 ;End of Gcode the M140 S0 and M104 S0 and the M82 also makes me scratch my head, they are not in the json and not in the end code for the printer
  14. changed my start code to: G28 Z; Home Z G28 Y; Home Y G28 X; Home X G29 M140 S{material_bed_temperature_layer_0} ; set bed temp M190 S{material_bed_temperature_layer_0} ; wait for bed temp G92 E0 ; zero the extruded length G1 X50 Y0 F3000 ; go to the middle of the front G1 Z0.1 ; close to the bed M104 S{material_print_temperature_layer_0} ; set extruder temp M109 S{material_print_temperature_layer_0} ; wait for extruder temp G1 X100 E10 F200 ; make a thick line to prime extruder G92 E0 ; zero the extruded length G1 Z0.3 ; lift Z G4 S2 ;wait 2 sec to bleed off excess pressure only get this extra line inserted automatic before that: M82 ;absolute extrusion mode my end code is: M104 S0 ; turn off extruder M140 S0 ; turn off heatbed G28 X; Home X G28 Z; Home Z G0 Y0 F5000 ; Move Y to middle of bed cooling fan M42 P11 S255 ; Turn on Bed cooling fan on M106 ; cool off nozzle G4 S660 ;wait 11 minutes M42 P11 S0 ;Turn off bed cooling fan M107 ; carriage fan off G28 Y; home Y M84 ; disable motors i also here get an extra line inserted before that: M140 S0 i have read arround that sometimes start and stop gcode are taken from the json files and in my case that would almost be prusa_i3_mk2.def.json "machine_start_gcode": { "default_value": "G21 ; set units to millimeters\nG90 ; use absolute positioning\nM82 ; absolute extrusion mode\nM104 S{material_print_temperature_layer_0} ; set extruder temp\nM140 S{material_bed_temperature_layer_0} ; set bed temp\nM190 S{material_bed_temperature_layer_0} ; wait for bed temp\nM109 S{material_print_temperature_layer_0} ; wait for extruder temp\nG28 W ; home all without mesh bed level\nG80 ; mesh bed leveling\nG92 E0.0 ; reset extruder distance position\nG1 Y-3.0 F1000.0 ; go outside print area\nG1 X60.0 E9.0 F1000.0 ; intro line\nG1 X100.0 E21.5 F1000.0 ; intro line\nG92 E0.0 ; reset extruder distance position" }, i could either remove all the code or just remove the M82 part but the end code i cant figure "machine_end_gcode": { "default_value": "M104 S0 ; turn off extruder\nM140 S0 ; turn off heatbed\nM107 ; turn off fan\nG1 X0 Y210; home X axis and push Y forward\nM84 ; disable motors" } there is only one M140 in there but i get 2, one without any comments one, where does that come from?
  15. i installed the printer as an prusa MK2 (one of the options when starting cura the first time) only changes i did was start gcode and end code and then the generic ABSsettings i made a copy off as the temps was ot what i wanted, and the default generic ABS also had the part cooling fan enabled.
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!