Jump to content

ZInventions

Dormant
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

Personal Information

  1. First off, Prime towers are AMAZING, and the way that Cura switches extruders for dual head prints is fantastic. What about more heads? I run an E3D cyclops, which can be run as a rudementary mixing head, leading to my printer having 15 "extruder" settings, that can run customized mixes of filament. What I would love to have is the ability to tell Cura to run more than two of these "extruders" in a given print, and for it to use more than just the one prime tower (or maybe a different style of prime tower) for additional extruders. I have noticed that when setting the printer to anything more than two extruders only the first two get primed, all the rest do not, meaning that mixes cannot become consistent. I would use a purge location, but as my printer is a delta bot (Rostock Max) the extruder moves in three axes, so a single purge location is very much suboptimal, and I cannot figure out how to tell cura to select the "previous" "current" and "next" extruders in the before and after extruder switch gcode. I have searched around trying to find a way to do this, but as my coding ability extends only a little bit past arduino and VBA I haven't been able to wrap my head around the slicing engine enough.
  2. I have a dual-head printer, and often cura seems to "forget" that the second extruder is still selected for the first layer of the part, i.e. it does not reset the extruder ID to the first extruder (or active extruder) before beginning the print. Below is a Gcode example ; Wait for all used extruders to reach temperatureM109 T0 S210M109 T1 S210;Layer count: 6;LAYER:0M107G0 F9000 X2.427 Y3.169 Z0.200G0 X2.833 Y3.367;TYPE:SKIRTG1 F1800 X3.547 Y2.849 E0.03081G1 X3.619 Y2.796 E0.03393 This code waits for both extruders to heat, but then immediately begins printing, and since the last tool command sent was T1, it prints the skirt AND the first layer of objects meant to be printed with tool 0 with the incorrect tool. This results in poor quality of the prints, as the first layer is the wrong material. What would be useful would be a way to have cura send a tool change command before the first extrusion, setting the ID. This way it would automatically use the correct head. I have also noticed that on parts that only use one extruder, it very often does not select the correct one by default. My setup is as follows: Repetier Host using bundled Cura controlling a Rostock Max V1 with an E3D chimera
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!