Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up

a2hill

Dormant
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

1 Neutral

Personal Information

  • Country
    US
  1. At my work we actually do it the other way around, wanting to view work prints from home. I've integrated camera from the UM3 into our security camera application (Synology Surveillance Station) which is accessible over the internet (after login of course). It displays as though it were just another camera, and since the security application handles recording and file management it makes it really easy to just pull the video of a specific print based on time or motion detection.
  2. So after taking the camera housing off, the usb cable was in fact unplugged. Plugged it back in and booted it up and everything works!
  3. Good to know, thanks. Just a note though, this is not a beta machine it was purchased last week through MatterHackers in Orange County. I guess I'll be contacting them for support.
  4. It looks like v4L2 is failing to load. From the USB logs:[/br] [/br] Full logs: http://pastebin.com/7bKFkbrN[/br] [/br] Hostnamenotset systemd[1]: Starting mjpg-streamer, Webcam streaming for all...Hostnamenotset systemd[1]: Started mjpg-streamer, Webcam streaming for all.Hostnamenotset systemd[1]: Starting Login Service...Hostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: starting applicationHostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: MJPG Streamer Version.: 2.0Hostnamenotset mjpg-streamer[167]: MJPG Streamer Version.: 2.0Hostnamenotset systemd[1]: Started getty on tty2-tty6 if dbus and logind are not available.Hostnamenotset systemd[1]: Starting Griffin camera service...Hostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: Using V4L2 device.: /dev/video0Hostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: Desired Resolution: 800 x 600Hostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: Frames Per Second.: not limitedHostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: Format............: JPEGHostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: TV-Norm...........: DEFAULTHostnamenotset mjpg-streamer[167]: MJPG-streamer [167]: init_VideoIn failedHostnamenotset net.agent[171]: ERROR: /sbin/ifup not found. You need to install the ifupdown package.Hostnamenotset mjpg-streamer[167]: i: Using V4L2 device.: /dev/video0Hostnamenotset mjpg-streamer[167]: i: Desired Resolution: 800 x 600Hostnamenotset mjpg-streamer[167]: i: Frames Per Second.: not limitedHostnamenotset mjpg-streamer[167]: i: Format............: JPEGHostnamenotset mjpg-streamer[167]: i: TV-Norm...........: DEFAULTHostnamenotset mjpg-streamer[167]: ERROR opening V4L interface: No such file or directoryHostnamenotset mjpg-streamer[167]: Init v4L2 failed !! exit fatalHostnamenotset mjpg-streamer[167]: i: init_VideoIn failed Sure enough when I run an ls /dev/video0: root@ultimakersystem-ccbdd300023e:~# ls /dev/video0ls: cannot access /dev/video0: No such file or directory
  5. I updated to the 'Testing' firmware with the same results. I've since switched back and the only ports I see open are 80 and 22. After reading today's remote access post and seeing that network settings are different when the printer is in hotspot mode I also tried that to no avail. Can I get ssh credentials so I can look at some logs?
  6. No there is no camera feed in Cura. Also I've tried ?action=snapshot as well but since port 8080 isn't open it does not connect
  7. I was able to get the ethernet lan connected after disabling wifi. Thanks! [br] [br] I've enabled developer mode and did a port scan and now see that port 22 is open for ssh (does anyone know what the username and password are?), however I'm still not seeing a port open 8080 for the camera stream.
  8. Thanks for the heads up, didn't realize there was a developer mode! I'll give that a shot when my print is done
  9. Just picked up an UM3 today, currently running my first print and wanted to watch the video of the print. After checking out Daid's post on remote access I found the camera stream URL (http://xxx.xxx.x.xxx:8080/?action=stream) however I get an 'Error Connection Refused' from my browser when I try to access it. [br][/br] [br][/br] After a quick nmap I can see that port 8080 is not open (only port 80 is). I also tried connecting using an ethernet cord however the amber light on the ethernet port just intermittently flashes and the settings menu says disconnected. [br][/br] [br][/br] I am on firmware 3.4.12.20161017, any advice?
×
×
  • Create New...