Jump to content

chintanjoshi1

Dormant
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

Personal Information

  • Country
    IN
  1. @ahoeben Thanks for the reply, how can I do that manually i.e by passing transformed geomoetry directly to CuraEngine ?
  2. CuraEngine produces different gcode files for different settings set for "Scale" in Cura desktop application. However I compared the settings which were passed to it(as they are visible in the terminal) and found no difference in those settings passed whether it was a normally placed model or scaled model or with differently positioned model, but the gcode files for such different settings was different. How to determine in which way the engine is taking those settings ? OS: Ubuntu 14.04 Cura: 2.3 CuraEngine: 2.3
  3. Thanks for explaining the part. It really helped.
  4. Hello all, I was looking into the json files and I saw this resolveOrValue('layer_height') Now, I tried to search what it does, and I found this ExtruderManager.py Now, I get the value part that it takes the value if resolve is not there, but my question is that what resolve actually means ? Does it means the value which user gave as input in the GUI or something else ? Thanks
  5. Thanks, it was as you said, different settings were indeed given, but I didn't knew from where they were going, now its all clear. Thank you for the help.
  6. Hello everyone, I am facing an issue when I generate a gcode from GUI and then from command line the output file is different. (I am new to this so pardon the formatting if its not correct.) Ultimaker2 Printer is selected in my Cura GUI from the log I found this command being passed 2017-06-06 16:31:40,883 - DEBUG - .../UM/Backend/Backend.py (_backendLog [88]): [backend] Calling engine with: ['/opt/cura/bin/CuraEngine', 'connect', '127.0.0.1:49674', '-j', '/opt/cura/share/cura/resources/definitions/fdmprinter.def.json', ''] Which is followed by a various settings. If I run the following command from the command line ./CuraEngine slice -v -j /opt/cura/share/cura/resources/definitions/fdmprinter.def.json -o /home/xyz/Desktop/gcodes/command_line_pause-start_100.gcode -l /home/xyz/Downloads/pigrrl-2-raspberry-pi-game-console-by-adafruit/pause-start.stl I get very different results... but if I pass this command ./CuraEngine slice -v -j /opt/cura/share/cura/resources/definitions/ultimaker2.def.json -o /home/xyz/Desktop/gcodes/command_line_pause-start_100.gcode -l /home/xyz/Downloads/pigrrl-2-raspberry-pi-game-console-by-adafruit/pause-start.stl the gcode files are quite same, although there are minor variations (2k-3k lines of gcode) So what could be causing the issue ? Also am I doing it correctly ? I also plan to pass custom settings from command line but I don't know how, is that done by appending -s to the command or do I need another json file ? CuraEngine Version : 2.3.1 OS : Ubuntu 14.04 Cura Version: 2.3.1 Thanks
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!