Jump to content
Ultimaker Community of 3D Printing Experts

arnaudcosson

Member
  • Content Count

    23
  • Joined

  • Last visited

Community Reputation

0 Neutral

Personal Information

  • Country
    FR

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. arnaudcosson

    Cura crashes after restore a backup made on windows

    Very strange behaviour. The Cura folder was there but not visible in ls or with autocomplete in terminal In the Cura folder I had the 3.4 and the zip from backup Cura Arnaud$ ls 3.0 3.4 3.1 3.4_20180911_141802.zip I unzipped the zip, override the files and remove the zip file. Cura now starts and I have the saved profiles from my colleague.
  2. arnaudcosson

    Cura crashes after restore a backup made on windows

    Yes that was my memories too but I have no "Cura" folder in my ~/Library/Application Support/ ? I will try uninstall and re-install Cura
  3. arnaudcosson

    Cura crashes after restore a backup made on windows

    Hi nallath, Can you please give me the path to Cura log file, I usually use the menu in UI to show the file but as I can't start Cura... Thanks
  4. I try to restore an online backup a colleague created on windows on my Cura 4.3.1 Mac. Just after click on "restore" on the profile, Cura crashed Since I can't start it, it crashes at launch. Does anyone succeed in restoring a "windows made" profile on a Mac ?
  5. arnaudcosson

    Remote access to UM3 API from a web server

    Thanks for your answers ! I will check the user guide for VPC VPN
  6. arnaudcosson

    Remote access to UM3 API from a web server

    Thanks for your answer. So your recommandation is to have a third part (like a local server) to manage the communication between the website and the UM3 ?
  7. Hi community, Did anyone ever tried to access the Ultimaker 3 API from a web server ? On my UM3E I can access the API from local network IP. But I can only do this when I am on the same WIFI network. I would like to send requests to the API from a website hosted on AWS. I think I will need to set up some NAT to access the printer from "outside". If some of you have feedbacks and tips on it, I'll be glad to ear. Thanks
  8. arnaudcosson

    Stuck up in creating a Docker image for CuraEngine

    Thanks for the information. I will try with this version
  9. arnaudcosson

    Stuck up in creating a Docker image for CuraEngine

    Little up on this post, still not able to build curaEngine on my docker In file included from /tmp/curabuild/CuraEngine/src/pathPlanning/Comb.h:11:0, from /tmp/curabuild/CuraEngine/src/LayerPlan.h:8, from /tmp/curabuild/CuraEngine/src/FffGcodeWriter.h:15, from /tmp/curabuild/CuraEngine/src/FffProcessor.h:5, from /tmp/curabuild/CuraEngine/src/commandSocket.cpp:7: /tmp/curabuild/CuraEngine/src/pathPlanning/../utils/LazyInitialization.h: In constructor 'cura::LazyInitialization<T, Args>::LazyInitialization(Args ...)': /tmp/curabuild/CuraEngine/src/pathPlanning/../utils/LazyInitialization.h:34:18: error: expected ',' before '...' token [args...]() ^ My search on the net drives me to this conclusion: I'm not able to compile CuraEngine because the version of the compiler that is used is not the good one. But I didn't figure how to change it. devtoolset-3-gcc was supposed to do the job... Here is my updated DockerFile: # Dockerfile for CuraEngine FROM centos #Global prerequisites RUN yum install -y epel-release RUN yum install -y libtool gcc-c++ wget unzip make devtoolset-3-gcc git RUN mkdir -p /tmp/curabuild # Install Protobuf RUN cd /tmp/curabuild/ \ && wget -O protobuffv3.4.1.zip https://github.com/google/protobuf/archive/v3.4.1.zip \ && unzip protobuffv3.4.1.zip \ && cd /tmp/curabuild/protobuf-3.4.1/ \ && ./autogen.sh && ./configure \ && make -j4 \ && make install #Install Python 3 RUN yum install -y zlib-devel openssl-devel python34-dev #Install libArcus RUN yum install -y cmake python-devel sip-devel RUN cd /tmp/curabuild \ && git clone https://github.com/Ultimaker/libArcus.git \ && cd libArcus \ && sed -i '/option(BUILD_PYTHON "Build " ON)/c\option(BUILD_PYTHON "Build " OFF)' ./CMakeLists.txt \ && mkdir build && cd build \ && ls -la .. \ && cmake .. \ && make -j4 \ && make install RUN cd /tmp/curabuild \ #Install CuraEngine && git clone https://github.com/Ultimaker/CuraEngine.git \ && cd CuraEngine/ \ && mkdir build && cd build \ && cmake .. \ && make CXX=gcc-4.9 -j4
  10. arnaudcosson

    Stuck up in creating a Docker image for CuraEngine

    To disable build with python on libArcus, simply change the line option(BUILD_PYTHON "Build " ON) by option(BUILD_PYTHON "Build " OFF) in CMakeLists.txt
  11. arnaudcosson

    Stuck up in creating a Docker image for CuraEngine

    Thanks nallath. Any link to a how-to or some tips ?
  12. Hi, I am working on creating a docker image to have a centos machine with CuraEngine. The purpose is to have an hosted instance to slice files from command lines. I decide to base the image on centos because it is the distribution usually deployed in my compagny. For install I followed instructions from https://github.com/Ultimaker/CuraEngine but I have an error with python version while installing libArcus. Thanks for your help Arnaud Error: -- Found PROTOBUF: /usr/local/lib/libprotobuf.so CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:108 (message): Could NOT find PythonInterp: Found unsuitable version "2.7.5", but required is at least "3.4.0" (found /usr/bin/python)Call Stack (most recent call first): /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:313 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake/Modules/FindPythonInterp.cmake:139 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) cmake/FindSIP.cmake:32 (find_package) CMakeLists.txt:23 (find_package)-- Configuring incomplete, errors occurred!See also "/tmp/curabuild/libArcus-master/build/CMakeFiles/CMakeOutput.log".See also "/tmp/curabuild/libArcus-master/build/CMakeFiles/CMakeError.log".The command '/bin/sh -c cd /tmp/curabuild && wget -O libArcus-master.zip https://github.com/Ultimaker/libArcus/archive/master.zip'>https://github.com/Ultimaker/libArcus/archive/master.zip && unzip libArcus-master.zip && cd libArcus-master && mkdir build && cd build && ls -la .. && cmake .. && make -j4 && make install' returned a non-zero code: 1 Dockerfile: # Dockerfile for CuraEngineFROM centos#Global prerequisitesRUN yum install -y epel-releaseRUN yum install -y libtool gcc-c++ wget unzip makeRUN mkdir -p /tmp/curabuild# Install ProtobufRUN cd /tmp/curabuild/ \ && wget -O protobuffv3.4.1.zip https://github.com/google/protobuf/archive/v3.4.1.zip \ && unzip protobuffv3.4.1.zip \ && cd /tmp/curabuild/protobuf-3.4.1/ \ && ./autogen.sh && ./configure \ && make -j4 \ && make install#Install Python 3RUN yum install -y zlib-devel openssl-devel python34-dev#Install libArcusRUN yum install -y cmake python-devel sip-develRUN cd /tmp/curabuild \ && wget -O libArcus-master.zip https://github.com/Ultimaker/libArcus/archive/master.zip \ && unzip libArcus-master.zip \ && cd libArcus-master \ && mkdir build && cd build \ && ls -la .. \ && cmake .. \ && make -j4 \ && make installRUN cd /tmp/curabuild \#Install CuraEngine && wget -O CuraEngine3.0.zip https://github.com/Ultimaker/CuraEngine/archive/3.0.zip \ && unzip CuraEngine3.0.zip \ && cd CuraEngine-3.0 \ && mkdir build && cd build \ && cmake .. \ && make -j4
  13. Hello, I'm playing around with CuraEngine and would like to use the same print parameters in command line and from GUI. I didn't find a way to export my print parameters from Cura to a def.json file. Is there a way to do so ?
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!