Jump to content

dragsterbox

Dormant
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

Personal Information

  • Field of Work
    Design
  1. Hi, I adjusted the the figures in marlin and reset the eeprom but still having the same issue in cura. When I do the homing in pronterface (G28), the print is perfectly centered but not in Cura. Here is the part of my marlin code: // Travel limits after homing (units are in mm) #define X_MIN_POS -1 #define Y_MIN_POS -25 #define Z_MIN_POS 0 #define X_MAX_POS 210 #define Y_MAX_POS 270 #define Z_MAX_POS 235 About Cura, I have tried a very basic start code with G28 only but I am still having the same issue. The print is perfectly centered after the G28 but just after printing moves back 35 mm behing and 12 mm on the right. See the picture attached.
  2. Well, I have a print that will finish Tomorrow morning. I will reset the eeprom afterwards and let you know. Considering the fact that I never reset the eeprom, there is a strong probability that this is the root cause. With the new build plate holder, the positioning is a bit different than before. Yes, 135 on the lcd screen but not centered on the build plate.
  3. Yes, I needed to use the full printing area for a big par and had to give a couple of tries before starting the print because of this. 1. Yes, this is what I have done. I have put a piece of masking tape on the glass, put a cross on the center and then printed. Indeed, the filament dot was 35 mm toward the rear and 15 mm toward the right. 2. Neither X and Y are centered. Not centered in the Y direction then 3. Yes, this is what I mean. The same for X. From 0 to 220
  4. Thanks a lot gr5. Sorry for my ignorance, everything was working perfect until I upgrade the bed in fact. If I summarize different steps: 1. re-check my config file and make sure that new settings are alright and calibrated, especially all about after homing limits, limits for the probe, etc ... 2. Re-upload firmware 3. About the eprom Is it correct if I proceed as described below: Open pronterface just after the flash Enter M502 to reset settings Enter M500 to save it in the eeprom
  5. Hi, Please find the answer to your questions: 1. The code is part of Marlin, except point five that I removed from cura because not working anymore since I changed the bed holder structure 2. Because my machine has been customized, not sure that reseting to factory settings will totally fix the problem --> Hictop with some upgrades: E3d hothend with custom holder, proximity sensor, better quality bedholder (aluminium structure), reworked brackets 3. I upload the firmware with the arduino app, not from cura or octoprint. By reset the firmware, do you mean clear the memory from the lcd screen menu may be ? 4. About your last question, yes I did :-) --> The head is about 35 mm behind the center and 15 mm on the right. Please find a link to my config file (Marlin): here Here, my start code in cura as well G28 G90 ; absolute positioning G21 ; units to mm G29 ; auto level bed (G29 assumes position is home XYZ = 0, auto levels, moves to XYZ = 0) G1 X100 Y100 Z10 M300 M0 G1 Z4.0 ; Glass bed thicknes G92 Z0 G1 X3 Y6 F3000 ;move to front left corner M104 S{material_print_temperature} ;Start heating extruder M140 S{material_bed_temperature} ;Start heating bed M109 S{material_print_temperature} ;Wait for extruder to reach temp before proceeding M190 S{material_bed_temperature} ;Wait for bed to reach temp before proceeding M83 ; extruder relative mode G1 Z.4 F200 ; raise Z .4mm @ 5mm/s **Change this to to your nozzle size** G1 X15 E2.0 F75 ; extrude a thick line of 2 mm of filament **This should be good for .35 to .50 nozzles** M82 ; extruder to absolute mode G92 E0 ; reset E to 0 **Print G-code takes over from here** Hope that it will help a little bit.
  6. Hi gr5, The head is about 35 mm behind the center and 15 mm on the right. Yes, I have tried a couple of different adjustments but it didn't fix my issue. About the travel limits after homing, yes this is accurate and gives me the right positioning in pronterface. About reset to factory settings, you mean in cura ?
  7. Dear all, Little by little, I am getting crazy with this issue. I am trying to figure out how to have a perfect centered print on Cura but none of my fixes have worked out. My printer: - Prusa mendel i3 (hictop/Anet type) - Surface: 220 x 270 x 235 - Firmware: modified Marlin - Proximity sensor placed 60 mm behind the printhead #define X_PROBE_OFFSET_FROM_EXTRUDER 0 #define Y_PROBE_OFFSET_FROM_EXTRUDER 60 #define Z_PROBE_OFFSET_FROM_EXTRUDER 0 Solutions that I have tried: 1. Unthick origin at center in Cura machine settings 2. Input surface dimensions in Cura X (width): 220mm Y (depth): 270mm Z (Height): 235mm 3. Adjust limits after homing in firmware and re-upload --> Everything is perfectly centered in Pronterface (G28) but not in Cura // Travel limits after homing (units are in mm) #define X_MIN_POS 0 #define Y_MIN_POS 0 #define Z_MIN_POS 0 #define X_MAX_POS 203 #define Y_MAX_POS 270 #define Z_MAX_POS 235 4. Manually sent home position in firmware // Manually set the home position. Leave these undefined for automatic settings. // For DELTA this is the top-center of the Cartesian print volume. #define MANUAL_X_HOME_POS 3 #define MANUAL_Y_HOME_POS 6 5. Modify G code to redefine origin e.g.: G0 Y-60 ;Move Y to -60 G92 Y0 ;Set this position as the new Y zero Do some of you experimented the same issue ? A fix would be highly appreciated. Thanks to all and merry christmas
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!