Jump to content

gui-rider

New member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

Personal Information

  • Field of Work
    Other
  • Country
    FR
  • 3D printer
    Anet a8
  1. Hi guys, I'm using cura 3.2.1 on my anet a8 and I'm having problems with my gcode. Because of the udapte (I think it's because of that), there is 2 gcode section, one for the machine (start/end gcode) and one for the extruder (extruder start/end gcode), the problem is that when I try to find a g-code for my printer on the internet I only find one (start/end) g-code, it's not separated in two section and I don't know what to put in each section Here is my start gcode : G21 ;metric values G90 ;absolute positioning M82 ;set extruder to absolute mode M107 ;start with the fan off G28 X0 Y0 ;move X/Y to min endstops G28 Z0 ;move Z to min endstops G1 Z15.0 F3600 ;move the platform down 15mm G92 E0 ;zero the extruded length again G1 F3600 M117 Printing... end : M104 S0 ;extruder heater off M140 S0 ;heated bed heater off (if you have it) G91 ;relative positioning G1 E-1 F300 ;retract the filament a bit before lifting the nozzle, to release some of the pressure G1 Z+0.5 E-5 X-20 Y-20 ;move Z up a bit and retract filament even more G28 X0 Y0 ;move X/Y to min endstops, so the head is out of the way G1 X0 Y+180 F3600 ;move buildplate forward M84 ;steppers off G90 ;absolute positioning What should I put in both section ? At this point, what my printer does is home, start the skirt, randomly goes at the Y axes end, keep doing the skirt and randomly goes at the X axes end.. Can someone please help me ?
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!