Jump to content
Ultimaker Community of 3D Printing Experts

ralfg

Member
  • Posts

    47
  • Joined

  • Last visited

Everything posted by ralfg

  1. Hello in Cura from version 4.2 there are new Start-G-Codes. So I have in the profile a line "M203 X500.00 Y500.00 Z10.00 E50.00". My first question is, what is this line for? The option "Maximum Z Speed" was replaced by "Z Hopp Speed". According to the explanation, the speed at which the vertical movement (Z-axis) takes place during Z-jumps should be. But with me exactly this value is always used for the Z-speed. Stupid is, that you only see this option "Z Hopp When Retracted" is activated. If this point is not active, the "Z Hopp Speed" option is not displayed, but the value entered in it is used in the G-Code. If this value is higher than the value entered in the line ""M203 X500.00 Y500.00 Z5.00 E50.00 ;Setup machine max feedrate", it is not limited, so the whole line there is obsolete. If I enter a 0 in "Z Hopp Speed", the value from M203 is not used either, although this is supposed to replace a missing value in the firmware. Then with each Z-movement an F0 is written into the G-code. Here the programmers have probably shot themselves in the knee. I'm sure they only wanted to achieve something good, I needed half an hour yesterday to find out where the feedrate for the Z-movement comes from. I didn't get the idea that I first had to activate a Z-hopp to find the hidden option with the wrong explanation. Greetings ++ralfg++
  2. Hallo in Cura ab Version 4.2 gibt es neue Start-G-Codes. So habe ich im Profil eine Zeile "M203 X500.00 Y500.00 Z10.00 E50.00" Meine erste Frage ist, wozu soll diese Zeile sein? Die Option "Maximum Z Speed" wurde durch "Sprunghöhe Z" ersetzt. Laut Erklärung soll die Geschwindigkeit, mit der bei Z-Sprüngen die vertikale Bewegung (Z-Achse) erfolgt. Bei mir wird aber genau dieser Wert immer für die Z-Geschwindigkeit verwendet. Dumm ist, das man diese Option "Sprunghöhe Z" nur sieht wenn "Z-Sprung beim Einziehen" aktiviert ist. Ist dieser Punkt nicht aktiv wird die Option "Sprunghöhe Z" zwar nicht angezeigt, aber der darin eingetragene Wert wird verwendet. Ist dieser Wert höher als der in der Zeile ""M203 X500.00 Y500.00 Z5.00 E50.00 ;Setup machine max feedrate" eingetragene Wert, wird dieser nicht begrenzt, also ist die ganze Zeile dort obsolet. Trage ich in "Sprunghöhe Z" eine 0 ein wird ebenfalls nicht der Wert aus M203 verwendet obwohl dieser ja einen fehlenden Wert in der Firmware ersetzen soll. Es wird dann bei jeder Z-Bewegung ein F0 in den G-Code geschrieben. Hier haben sich die Programmierer wohl ins Knie geschossen. Ich bin mir sicher die wollten nur was gutes erreichen, ich habe gestern eine halbe Stunde gebraucht um rauszubekommen woher die Geschwindigkeit für die Z-Bewegung kommt. Darauf das ich erst einen Z-Hopp anstellen muß um die versteckte Option mit falscher Erklärung zu finden bin ich nicht gekommen. grüße ++ralfg++
  3. ralfg

    Cura 4.1.0

    Das habe ich irgendwo doch gelesen, aber ich kann mich nicht daran erinnern wo, ist schwierig wenn man alt ist… In den Profil-Optionen unter "Geschwindigkeit" findest Du "Maximale Z-Geschwindigkeit". Der Wert steht standardmäßig auf 0 was den Drucker dazu veranlassen sollte den Wert aus der Firmware zu verwenden. Diesen Wert gibt es aber oft nicht in der Firmware was dazu führt das bei Z-Bewegungen diese Pausen entstehen. Ich habe dort einen Wert von 100mm/s eingegeben und die Pausen finden nicht mehr statt. Der Wert ist letztlich egal, er sollte höher sein als Deine gewünschte Z-Geschwindigkeit. Es darf nur keine 0 drin stehen. grüße ralf ps: wieder gefunden:
  4. Hallo ich sehe da nur ein Moiré. Ein Moiré ist ein rein optisches Phänomen und entsteht wenn zwei Raster übereinander liegen. Hier dürften die Layer ein Raster sein und das zweite sind die Bildschirmpixel. Bei einer Vergrößerung der Abbildung sollte das nicht mehr sichtbar sein und zeigt das es nur ein Darstellungsproblem ist. Mit dem Druck oder dem Objekt hat das meiner Meinung nach nichts zu tun. grüße ralfg
  5. Hello I was already looking forward to the usable sidebar. But it doesn't work. The area where values are displayed is only the top half of the screen. Mac OSX 10.13.5 on mac Pro
  6. Yesterday I tested the Cura V4 Beta. 1.) Extremely slow on both Mac OSX 10.13.5 and Windows 7. 2.) I don't know what to teach people at Gui-Design today but this user interface gets the badest grade. - I know my model. I just want to slice it. So it has a much higher priority for me to see the settings than the model. The window with the settings is fixed in size, but on my 24"monitor has only a third of the screen height. For what purpose should I use the whole area below it? Maybe sticky notes? It's an endless scrolling and clicking back and forth. Today you have a bigger monitor, or like me multiple monitors. If the programmers only have money for 17 inches, you should make a collection. Why, when the surface is being renovated, not even the possibility to arrange the palettes on several monitors in the desired size is built in, that would be a step forward. What I see here is just the arrangement of familiar elements according to questionable taste. This has nothing to do with "new user interface". Since the interface already disqualifies itself on such a low level, the speed is again so extreme in the basement, I don't see the learning ability of the programmers either. With the 3.6 it went well, after upgrade to osx 10.13.5. Apart from the new user interface, I don't see any great changes. So what's going on? I'm out testing new versions. You start with 0 every time. greetings and a healthy, quiet and successful new year ralf
  7. Ich habe gestern mal noch die Cura V4 Beta getestet. 1.) Sowohl unter Mac OSX 1013.5 als auch unter Windows 7 extrem langsam. 2.) Ich weiß ja nicht was man den Leuten heute bei Gui-Design beibringt aber diese Benutzeroberfläche bekommt bei eine Note 6. • Ich kenne mein Modell. Ich will es nur noch slicen. Es hat für mich also eine wesentlich höhere Priorität die Einstellungen zu sehen als das Modell. Das Fenster mit den Einstellungen ist in der Größe fixiert, hat aber auf meinem 24" nur ein drittel der Bildschirmhöhe. Wozu soll ich den ganzen Bereich darunter verwenden. Haftnotizen hinkleben vielleicht? Das ist ein endloses hin und her gescrolle und geklicke. Heute hat man nun mal einen größeren Monitor, oder wie ich mehrere. Wenn die Programmierer nur Geld für 17-Zöller haben sollte man mal eine Sammlung machen. Warum wird, wenn die Oberfläche renoviert wird, nicht mal die Möglichkeit eingebaut die Paletten auf mehreren Monitoren in gewünschter Größe anzuordnen, das wäre ein Fortschritt. Was ich hier sehe ist nur die Anordnung gewohnter Elemente nach fragwürdigen Geschmack. Mit "neuer Benutzeroberfläche" hat das nichts zu tun. Da sich die Oberfläche schon auf so einem niedrigen Level disqualifiziert, die Geschwindigkeit erneut so extrem im Keller ist, sehe ich auch die Lernfähigkeit der Programmierer nicht. Bei der 3.6 ging es ja. Außer der neuen Benutzeroberfläche sehe ich keine großartigen Änderungen. Was ist da also los? Ich bin raus beim Testen neuer Versionen. Da fängt man ja jedes mal bei 0 an. grüße und ein gesundes, ruhiges und erfolgreiches neues Jahr ralf
  8. Hallo Cura ist für mich nicht so wichtig. Ich habe es alternativ, in der Zeit wo es auf dem Mac nicht ging, unter Windows in Parallels laufen lassen. Dort läuft auch ein CAM für das ich seit Jahren die deutschen Übersetzungen mache und teste, und eine RIP Software für meinen großformatigen Epson. Cura unter Windows hat auch zur jetzt gut funktionierenden Version 3.6 eine wesentlich höhere Geschwindigkeit im slicen. Um Das Problem mit Cura zu lösen müsste ich parallel beide OSX Versionen laufen haben und dann endlos die Logs entziffern. Ich hatte in den Logs, sei es Cura oder System,Error und sonstwas keinerlei Probleme gefunden als Cura so langsam lief. So weit stecke ich nicht in der Programmierung das ich da Werkzeuge hätte um die Performance-Fehler zu finden. Wenn jemand einen alten, nicht mehr unterstützten Mac hat würde ich ihm lieber raten das gepatchte Update zu machen, das kostet ja nichts. Ich habe kaum etwas gefunden was wirklich nicht geht. Das Einzige war die neueste Version von XAMPP, die Hyperthreading vom Prozessor her haben will, das geht erst mit Macs nach 2010. Eine Version älter läuft aber auch anstandslos. Macbook und Mojave hatte mit Version 10.14.1 extreme Probleme wenn ein zweiter Monitor angeschlossen ist. Anfang Dezember ist ein Update auf 10.14.2 gekommen was die Probleme lösen soll. Ich hab bis jetzt nirgendwo Mojave laufen da die für mich wichtige und teuer bezahlte AdobeCC bis jetzt nicht sauber läuft. Das neueste ist nicht immer das beste. grüße ralf
  9. Hallo Smithy ich denke nicht das es nur an einer Wellness-Kur lag. Ich hatte ja bereits vorher einiges getestet. Auch mit einem frisch angelegten Benutzer war Cura langsam. Die Libraries die zu den Programmen gehören liegen im Benutzerordner. Nach meinem gepatchten Upgrade auf 10.13.5 habe ich ein Update auf 10.13.6 gemacht. Danach ging gar nichts mehr. Ich habe dann eine saubere Installation mit 10.11(el capitan) gemacht und dann wieder das gepatchte Update auf 10.13.5. Mit dem frischen und absolut sauberen 10.11 war Cura genauso langsam wie auf meinem alten System. Damit würde ich eine unverträgliche Library ausschliessen. Ein Update auf 10.13.6 spare ich mir erstmal bis ich weiß ob das alles so läuft, aber bis jetzt bin ich begeistert. grüße
  10. I wrote after the release of Cura 3.5 about how extremely slow it runs on my Mac Pro with 10.11.6 (el capitan). Today I did a system update to 10.13.6 (High Sierra). Now Cura 3.6 runs again fast and without problems. So you should update the system requirements, because it says MacOS version 10.10 as the system requirement. ++ralf
  11. Hallo ich habe heute meinem Mac ein High Sierra beigebracht. Eigentlich geht das nicht, denn Apple hat die neuen Systeme so gebaut das sie sich nicht mehr auf meinem Mac installieren lassen. Ich habe es heute geschafft mit dem Patch von DosDude ein High Sierra auf meinem Mac zu installieren. Alle Programme laufen sauber ( AdobeCC, C4D). Die Geschwindigkeit ist (mit Geekbench gemessen) sogar etwas höher als vorher. Und jetzt läuft auch Cura 3.6 wieder flott! Kein Unterschied mehr zur Version 3.5 grüße
  12. Die Antwort das eine Bibliothek sich verändert haben soll bezog sich auf eine Frage warum 3.5 nicht unter osx 10.9.5 läuft. Der User der geantwortet hat ist kein Insider, also nur eine Annahme. Es gibt ja eine Webseite wo die Systemanforderungen aufgelistet sind. Es gibt keinen Unterschied zwischen Version 3 und 3.5: Operating systems Windows Vista or higher, 64 bit Mac OSX 10.11 or higher, 64 bit Ubuntu 14.04 or higher, 64 bit System requirements OpenGL 2 compatible graphics chip, OpenGL 4.1 for 3D Layer view Intel Core 2 or AMD Athlon 64 or newer 205 MB available hard disk space 4GB RAM memory Alle aufgelisteten Kriterien werden von meinem Rechner/Betriebssystem erfüllt. Ein mittlerweile aufgetauchtes Argument das diese Software ja kostenlos wäre und ich deshalb keine Ansprüche stellen könnte ignoriere ich. Sonst wäre meine Antwort das ich gerne bereit wäre für einen gut funktionierenden Slicer Geld zu bezahlen. Ich bereite mich jetzt auf ein Systemupdate mit dem Patch vor. Ich muß dafür sinnvoller Weise eine weitere SSD einbauen um ein geklontes System zu patchen. Kein Problem bei meinem Mac wo ich auch eine vierte Festplatte während des Betriebs einfach reinschieben kann, ich hab nur keine SSD rumliegen. Es wird also noch einige Tage dauern bis ich mit der komplizierten Operation anfangen kann. grüße
  13. system requirement for version 3.x is Mac OSX 10.11. For me it doesn't work on 10.11.6 either. Operating systems Windows Vista or higher, 64 bit Mac OSX 10.11 or higher, 64 bit Ubuntu 14.04 or higher, 64 bit System requirements OpenGL 2 compatible graphics chip, OpenGL 4.1 for 3D Layer view Intel Core 2 or AMD Athlon 64 or newer 205 MB available hard disk space 4GB RAM memory ralf
  14. Der Bug ist bereits von einem Leidensgenossen gemeldet, ich werde noch mal nachschauen ob es Reaktionen gibt. Ansonsten habe ich einen Patch gefunden der es mir erlauben soll auf ein neueres System zu wechseln. Die Sperre die von Apple eingebaut wurde ist nicht in der Hardware begründet sondern rein ins Betriebssystem eingebaut, sieht die meinen Rechnertyp weigert sie sich ein neueres System zu installieren. Nach dem was ich gelesen habe kann ich mit einem Patch bis auf Mojave updaten allerdings ist dann eine andere Grafikkarte empfohlen. Ich denke da werde ich mal mit Vorsicht dran gehen.
  15. @Smithy Ich suche nach einem 12 Core mac pro ab 5,1. Nur die Konfigurationen sind annähernd gleich schnell wie mein jetziger Rechner. Die Preise sind aber irrsinnig zur Zeit. Oft werden Rechner von 2012 über dem Neupreis angeboten. Ich wurde von der Stuation überrascht und muss halt etwas meditieren. An S3D gefällt mir die Geschäftspraktik nicht das es keine Testversion gibt. Erst zahlen dann testen, das möchte ich nicht unterstützen. Ansonsten ärgert mich das ja angegeben ist das die 3.5 ab osx 10.11 läuft. Aber das wurde anscheinend nicht getestet. Es gab auch keine Rückmeldung das irgendjemand unter 10.11 diese Probleme nicht hat. Alle die etwas dazu geschrieben haben und dieses System verwenden bestätigten die Probleme. Zwischen 10.11 und 10.11.6 liegen immerhin einige Jahre, 10.11.6 wird selbst von Apple noch unterstützt. Ich sehe Ultimaker Cura auch jetzt nicht als Software für den professionellen Gebrauch an wo immer das Allerletzte aus einem Rechner heraus geholt werden muß. Wenn eine Mindestvoraussetzung aufgeschrieben wird muß man sich auch dran halten, nicht dann bis zum nächsten Major-Update warten und dann die Systemvoraussetzungen weiter hoch schrauben… upps Es nützt aber nichts sich da weiter Gedanken drüber zu machen, ich habe versucht weitere Logs etc im englischen Thread los zu werden damit man das Problem einkreisen kann. Aber anscheinend besteht da kein Interesse dran. grüße ralf
  16. Nein, das ist keine Option. Auf den superschnellen 12-Kern Rechnern des Typs Mac Pro 3.1 ist el Capitain das letzte Betriebssystem was installiert werden kann. Das ist eine böse Angelegenheit von Apple denn das Betriebsystem ist nicht mal 3 jahre alt. In den Benchmarks sind die Rechner schneller als einige der aktuellen schwarzen Eimer. Leider sind die neueren macs durch diese überraschende Vorgehensweise zur Zeit absolut überteuert. Ich sehe aber das Problem nicht bei meinem Rechner sondern in der Unfähigkeit der Cura-Programmierer. Wenn ich auf dem Rechner Windows 7 starte läuft Cura 3.5.1 problemlos, die Version 3.4.1 läuft auch under osx sauber. Als Mindestanforderung an das Betriebsystem wird von Ultimaker die mac osx Version 10.11 angegeben. Also sollte eine um 6 Versionen jüngere Version deren letztes Update vom Juli 2017 ist ordentlich laufen. Zur Zeit bin ich ziemlich eingespannt was Arbeit betrifft. Wenn ich Zeit habe werde ich mir Alternativen anschauen, aber nicht ohne über die Art und Weise zu schreiben wie, oder eben wie nicht mit den Fehlprogrammierungen umgegangen wird. Ist schon dreist 1 Woche nach dem Erscheinen einer neuen Version etwas los zu lassen wie "wird in Version 3.6 behoben". Es sind ja nicht nur die Probleme die bei Mac Usern entstehen, es funktioniert an vielen Enden mit Ultimaker Cura seit Version 3.5 nichts. Man braucht nur mal zu lesen. Es kommt mir vor als wäre das ein neues Programm mit absoluten Startschwierigkeiten. grüße
  17. Man muß diese Funktionen ja nicht verwenden, ich denke das z.B. bei flexiblen Material das Combining nicht ausgestellt werden darf, weil es sonst Lücken gibt. Man muß sich seine Funktionen schon zusammenstellen und dann sinnvoller Weise speichern.
  18. Hallo @Nicolinux ich will nicht behaupten das ich so gut bin um alle Prozesse zu analysieren, Ich habe einige Zeit mit Cura und Konsole verbracht und Cura 3.5.1 immer wieder neu gestartet und in den Logs gesucht, Cura wieder geschlossen, wieder geöffnet, Einstellungen verändert und zurück gesetzt, das ganze auch ohne Netztwerk, ohne USB Hub, sogar unter einem frisch angelegten User, und immer wieder in der Konsole alles durch gesucht, Prozesse analysiert und immer wieder gesucht ob ich in der Konsole irgendwelche Auffälligkeiten finde. Finde ich aber nicht. Nur die normalen Eintrage beim Programm Start und die wiederkehrenden Einträge im stderr.log, was ich schon mehrfach angehängt hatte. Aber jetzt nichts was so einen Rechner dermaßen in die Knie zwingen würde. Ich arbeite hier den ganzen Tag mit den Adobe CC Programmen und Grafik, da ist nichts langsam. Auch die Cura Version 3.4 ist schnell. Ich habe nur mit Cura und da auch nur mit den Versionen 3.5.x Probleme. Mehrere User haben mit dieser Version Probleme weil alles gnadenlos langsam ist. So wie ich mich erinnere haben alle das System 10.11.6 (el Capitain) in Verwendung. Es gab vor einem Jahr ein Update was ein " Kernel-Problem behebt, durch das es zum kurzzeitigen Einfrieren der Benutzeroberfläche kommen kann." Letztlich beschreibt dieser Fehler genau das vorkommende Problem, ein kurzes einfrieren von einem Sekundenbruchteil, wiederkehrend und dadurch alles nur ruckelnd und mit starker Verzögerung. grüße
  19. Richtig, das sind Eilgänge oder andere Verfahrwege. Es wird aber, wenn Combining eingeschaltet ist, weiter Filament gefördert und deshalb sind diese Wege zu sehen. Wird Combining für die Außenhaut abgeschaltet wird das Filament bei diesen Wegen zurück gezogen und die Spuren sind nicht zu sehe. Der Verfahrweg bleibt aber logischer Weise bestehen. In Cura 3.5 gibt es eine weitere Einstellung für den Combining Modus "Innerhalb der Füllung". In der Beschreibung steht das diese Einstellung das Gleiche bewirkt wie vorher die Einstellung "Nicht in Außenhaut". Die Einstellung "Nicht in Außenhaut" gibt es aber auch noch in V 3.5. Eine Erklärung was der Unterschied zwischen "Innerhalb der Füllung" und "Nicht in Außenhaut" ist habe ich noch nicht gefunden. ++ralfg
  20. Hallo zur Version 3.5 kann ich nichts sagen, die (und auch die 3.5.1 Beta) laufen bei mir auf dem Mac so gnadenlos langsam das ich damit nichts anfangen kann. In Version 3.4.1 war die Einstellung unter -> Bewegungen -> Combining-Modus -> Nicht in Außenhautbereichen. Dadurch geschieht bei diesen Bewegungen auf den Außenhäuten ein Retract und es sollte kein Filament aus der Düse kommen. Ich habe gelesen das sich in Version 3.5 etwas im Zusammenhang mit Combining verändert hat, kann das leider aber nicht testen. grüße ++ralf
  21. Yes, even after a clean install and previous deletion of all associated files in /Application Support/cura/ the folder 3.5. I have zipped the folder 3.4 so it is not an update but a fresh install. After starting Cura 3.5.1 everything is immediately slow. Rotating the object in the window is jumping in 10° steps. The construction of the menus takes forever and if I rotate the print area I can prevent the construction of the menus with it. I made a screencast that you can see that no working is possible. Even at the beginning, directly after the installation, it is not possible to enlarge the window. Only after a delay of seconds the window will be enlarged. ++ ralf
  22. yes, I deleted the configuration folder twice. I make twi clean installs. One without network I tried that, too. I made a clean installation without network connection. It doesn't change anything The stderr.log is attached ++ralf stderr.log.zip
  23. I installed version 3.5.1 Beta on my Mac today. Nothing has changed to version 3.5.0 regarding the extremely lame performance. The software is not usable. Even the rotation of a small object, the Benchy, with the mouse happens time-delayed and jerky. As long as the software doesn't run clean I can't test anything. This is too annoying. Mac 3.1, 2x Quadcore 3 Ghz, 32 Gb RAM, SSD HD, mac osx 10.11.6 ++ ralf
  24. I tried a lot with version 3.5.0 over the weekend. After I had deleted all definitions for material and printers many error messages are gone when starting the program. The extremely slow speed doesn't change (mac osx 10.11.6). Every time I open a menu and it builds up very slowly the line "DEBUG - [MainThread] cura.AutoSave._onTimeout [48]: Autosaving preferences, instances and profiles" is displayed in stderr.log. I have added the stderr.log to my file ++ ralf stderr.log.zip
  25. today i tested a fresh installation on a newly created account on my Mac, data see above. In the first minutes Cura 3.5.0 ran remarkably fast, but became slower with every mouse click. Then I installed this version on a virtual machine on my Mac under Windows 7 64 bit. There Cura runs fast and without any performance problems. ++ ralf
×
×
  • Create New...