Jump to content

TK_HPU

Member
  • Content Count

    23
  • Joined

  • Last visited

Everything posted by TK_HPU

  1. Cura3.3 cannot connect printer via USB. But Simplify3D can connect to the printer. Is it the bug of Cura3.3? Here is the log info. WARNING - [Thread-6] UM.Logger.logException [85]: serial.serialutil.SerialException: could not open port 'COM2': PermissionError(13, '拒绝访问。', None, 5) DEBUG - [Thread-6] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 19200 works WARNING - [Thread-6] UM.Logger.logException [81]: Exception: Unable to create serial WARNING - [Thread-6] UM.Logger.logException [85]: Traceback (most recent call last): WARNING - [Thread-6] UM.Logger.logException [85]: File "C:\Program Files\Ultimaker Cura 3.3\plugins\USBPrinting\AutoDetectBaudJob.py", line 41, in run WARNING - [Thread-6] UM.Logger.logException [85]: serial = Serial(str(self._serial_port), baud_rate, timeout = timeout, writeTimeout = timeout) WARNING - [Thread-6] UM.Logger.logException [85]: File "serial\serialwin32.py", line 31, in __init__ WARNING - [Thread-6] UM.Logger.logException [85]: File "serial\serialutil.py", line 182, in __init__ WARNING - [Thread-6] UM.Logger.logException [85]: File "serial\serialwin32.py", line 62, in open WARNING - [Thread-6] UM.Logger.logException [85]: serial.serialutil.SerialException: could not open port 'COM2': PermissionError(13, '拒绝访问。', None, 5) DEBUG - [Thread-6] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 9600 works WARNING - [Thread-6] UM.Logger.logException [81]: Exception: Unable to create serial WARNING - [Thread-6] UM.Logger.logException [85]: Traceback (most recent call last): WARNING - [Thread-6] UM.Logger.logException [85]: File "C:\Program Files\Ultimaker Cura 3.3\plugins\USBPrinting\AutoDetectBaudJob.py", line 41, in run WARNING - [Thread-6] UM.Logger.logException [85]: serial = Serial(str(self._serial_port), baud_rate, timeout = timeout, writeTimeout = timeout) WARNING - [Thread-6] UM.Logger.logException [85]: File "serial\serialwin32.py", line 31, in __init__ WARNING - [Thread-6] UM.Logger.logException [85]: File "serial\serialutil.py", line 182, in __init__ WARNING - [Thread-6] UM.Logger.logException [85]: File "serial\serialwin32.py", line 62, in open WARNING - [Thread-6] UM.Logger.logException [85]: serial.serialutil.SerialException: could not open port 'COM2': PermissionError(13, '拒绝访问。', None, 5) DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 230400 works DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 57600 works DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 38400 works DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 19200 works DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 9600 works DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 115200 works DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 250000 works DEBUG - [Thread-3] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM2 if baud rate 230400 works Thanks!
  2. I connect my printer(not ultimaker) via USB cable with cura 3.4. Sometimes it can connect successfully, but sometimes it cannot connect to the machine. I have do many test, but cannot find some regular to connect correctly. What can I do? Is there any help to make the connection 100% successfully. Thanks!
  3. Thanks! I have tried 3 ways: (1) Not modify anything of the fdmprinter.def.json, just add the command '-s support_extruder_nr="1" ' It is not help. (2) Just modify the dmprinter.def.json, as this: It is not help. Just like this: (3) If I modify the default value of "support_infill_extruder_nr", like this: It worked! But, there is an additional cylinder!As this: Here is my json file. Thanks!!! json_file.zip
  4. I execute CuraEngine.exe by command line. The version is 3.3, I use ultimaker3.def.json and ultimaker3_extruder_left.def.json and ultimaker3_extruder_right.def.json. Now it is only one extruder, even though it have generate support. How to modify the .json file, so that it can use both extruder1 and extruder2. I mean, I want extruder1 be used for the model, the extruder2 be used for support. Is there any demo? Thanks!
  5. Cura3.3, I run the project and the application start up. When I add a printer, if I chose "Custom FDM printer", it will break down immediately. But, if I chose "Ultimaker ***", it will start up with no crash. It may be connected to the resources/quality/. What is the reason? Thanks!
  6. I use Pycharm develop the cura project, I want debug the qml file. I write console.log(), but there is no output. Where can I find the output? Is there need any settings on the Pycharm? Thanks!
  7. Cura3.3, I clicked the button "Support Blocker", and then, clicked the model face to eraser the support, the model just disappeared from the build plate. What happened? I did nothing to the code. Just as the gif picture show. Thanks so much!
  8. Really it worked!!!! The PyQt is v5.7, I update to 5.8, the cura mainwindow can show up. I appreciate your help.
  9. However, it still crashed, it crashed during the dialog "Connect to Networked Printer" is showing. just as the screenshot: Also, there is no error in the log file. Any suggestion? Thanks! cura.log
  10. Thank you so much. My project is in the VMware workstation windows10. I doubt the virtual environment called this problem, and I have abandon the virtual environment. Using a new PC, the project work well, there is no crash any more. Thanks a lot.
  11. And there is no stderr.log or stdout.log under the AppData\Local\cura path.
  12. The log is all right, just as the attachment. When it run at the dialog "User Agreement", and then, it disappeared, not “exit” to the desktop. Not any more dialog or notes/tips. I debug here when it crashed, just as the following screenshot. cura.log
  13. There's no error now, but still crashed. Is there any suggestion? Thanks a lot
  14. Thank you. Now I delete UFPWriter plugin, it have no error, but still crashed
  15. Thanks for your help, there is no materials folder in the path"Cura/resources", I make a director named materials just now and clone the fdm_materials into /Cura/resources/materials, it does worked! Thank you so much!!! But it still cannot run start up the interface, and here is the error: "ERROR - [MainThread] UM.PluginRegistry.loadPlugin [391]: Plugin UFPWriter did not return any objects to register" When it runs the User Agreement dialog, it will break down.
  16. On Windows10. There are some errors, such as: ERROR - [MainThread] UM.PluginRegistry.loadPlugin [391]: Plugin UFPWriter did not return any objects to register ERROR - [MainThread] UM.Logger.logException [85]: Traceback (most recent call last): ERROR - [MainThread] UM.Logger.logException [85]: File "C:\TK\Cura3.3\Uranium-3.3\UM\Settings\ContainerRegistry.py", line 178, in findContainers ERROR - [MainThread] UM.Logger.logException [85]: new_container = provider.loadContainer(metadata["id"]) ERROR - [MainThread] UM.Logger.logException [85]: File "C:\TK\Cura3.3\Uranium-3.3\UM\..\plugins\LocalContainerProvider\LocalContainerProvider.py", line 63, in loadContainer ERROR - [MainThread] UM.Logger.logException [85]: container.deserialize(f.read()) ERROR - [MainThread] UM.Logger.logException [85]: File "C:\TK\Cura3.3\Cura-3.3\cura\Settings\ExtruderStack.py", line 138, in deserialize ERROR - [MainThread] UM.Logger.logException [85]: super().deserialize(contents, file_name) ERROR - [MainThread] UM.Logger.logException [85]: File "C:\TK\Cura3.3\Cura-3.3\cura\Settings\CuraContainerStack.py", line 255, in deserialize ERROR - [MainThread] UM.Logger.logException [85]: super().deserialize(contents, file_name) ERROR - [MainThread] UM.Logger.logException [85]: File "C:\TK\Cura3.3\Uranium-3.3\UM\Settings\ContainerStack.py", line 378, in deserialize ERROR - [MainThread] UM.Logger.logException [85]: raise Exception("When trying to deserialize %s, we received an unknown ID (%s) for container" % (self.getId(), container_id)) ERROR - [MainThread] UM.Logger.logException [85]: Exception: When trying to deserialize ultimaker3_extruder_left #2, we received an unknown ID (generic_pla_ultimaker3_AA_0.4) for container How to figure it? Here is my screenshot of my pycharm project and the error.
  17. I'm stuck here for two days, is there any help or suggestion?
  18. I build cura-build-environment 3.3.0 cmake is done and no error. but, during nmake there are some errors. as following picture shows. I have tried to solve it, install visual studio 2010. But, it does not work.
  19. Thanks a lot! I really appreciate for your project struct.
  20. I've been confused for days. I'm the "hello world" of Cura. I want buil cura3.3 project by Pycharm, I don't know the process to build it. I have read the readme and wiki in github-Ultimaker/Cura , but, it make me confused. please make a demonstration,like: first step, second step, and where did the file in the project come from? If you have a diagram of the project(like my attachment), that would be great thank you very much!
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!