Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up


  • Content Count

  • Joined

  • Last visited

Everything posted by freesbee

  1. ...sorry, I'm on vacation several thousand miles away from where I could test anything on the printer, not even which firmware version I have on. I am afraid that you need to ask to the guy who is responsible of firmwares at Ultimaker @Daid (well, if he didn't correct such a problem after one year of time I wouldn't know what to expect... it's quite embarrassing...). BTW I am not a big fun of connection manager... it's normally one of the first things that I disable on my linux machines.
  2. Make a forum were your users can propose ideas and a voting mechanism for each idea (or "kudos" if you prefer to call them that way). It won't take very long to figure out which ideas have more votes/kudos, and will help you in prioritizing your tasks quite efficiently. 2 hints in one day.... ?... maybe too much...
  3. ...so if I may give you a suggestion, let IT personnel do their job and implement an easier way to set and protect a static IP in the firmware. Nothing wrong with the SSH and connman for me, but somebody with less linux experience could be in trouble and normally people dealing with design are not linux experts (nobody is questioning why you use connman instead of /etc/network/interfaces so please do not question why we prefer to have printers on static IPs outside the DHCP area). Here the full guide for anybody who might need it: 1. on the printer panel enable developer mode (printer restart needed) 2. SSH to the printer (default credentials would be root/ultimaker) 3. $ connmanctl services and note the name of the interface that must be configured (remember: the machine has 2 network interfaces): from now on that will be the <service> (no "<" or ">" needed, just the service/interface name which will look like ethernet_<MAC_ADDR>_cable for the wired one, the other one I didn't have time to check ) 4. $ connmanctl config <service> --ipv4 manual <IP address> <netmask> <gateway> at this point the SSH connection will be broken because the printer switches immediately to the new IP so verify if everything went fine and 5. on the printer panel disable developer mode just in case you want to re-enable DHCP the command is: $ connmanctl config <service> --ipv4 dhcp
  • Create New...