Jump to content

cjc0306

Member
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

1 Neutral

Personal Information

  • Country
    US
  • Field of Work
    (Product) design
  1. I too have been looking for a way to print layouts. Artfreak45 you're the coolest, it worked great on my mac, except I had to open the .txt file directly from pages. Now if only cura would get on board with a print option!
  2. Thanks gr5. I figured it out, someone from another forum pointed me in the right direction. The answer was setting my motors in the right direction relative to my home point. My home is in the right rear, which is not the norm, so a few adjustments were required. This is the link to the document that pretty much explains how everything should be aligned, https://drmrehorst.blogspot.com/2017/08/setting-up-3d-printers-origin.html. I learned quite a bit from it, and fixed my issue.
  3. Im using Cura with the FT-5 printer. I can move around and home perfectly fine both with the individual axis and with the home all. The problem arrises when I try to print a file generated in Cura. After homing the printer and loading up a file, the head noisely vibrates, misses a bunch of steps, then starts printing in the wrong direction. Ive been trying to get up and running for a weeks now with no success. Any help on getting my prints set up in the middle would be great! Here is a youtube video of the behavior on print, My Config.g file:ibrates ; Configuration file for Duet WiFi (firmware version 1.21) ; executed by the firmware on start-up ; ; generated by RepRapFirmware Configuration Tool on Wed Oct 17 2018 15:55:24 GMT-0400 (Eastern Daylight Time) ; General preferences G90 ; Send absolute coordinates... M83 ; ...but relative extruder moves ; Drives M569 P0 S1 ; Drive 0 goes forwards M569 P1 S0 ; Drive 1 goes backwards M569 P2 S1 ; Drive 2 goes forwards M569 P3 S1 ; Drive 3 goes forwards M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation M92 X80.22 Y80.22 Z400.5 E420 ; Set steps per mm M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min) M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min) M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2) M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent M84 S30 ; Set idle timeout ; Axis Limits M208 X0 Y0 Z0 S1 ; Set axis minima M208 X300 Y300 Z400 S0 ; Set axis maxima ; Endstops M574 X1 Y1 S1 ; Set active high endstops ; Z-Probe M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed M557 X15:285 Y15:285 S20 ; Define mesh grid ; Heaters M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0 M143 H0 S120 ; Set temperature limit for heater 0 to 120C M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1 M143 H1 S280 ; Set temperature limit for heater 1 to 280C ; Fans M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on ; Tools M563 P0 D0 H1 ; Define tool 0 G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C ; Automatic power saving M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss ; Custom settings M501 The Start code from Cura: G21 ;metric values G90 ;absolute positioning M82 ;set extruder to absolute mode M107 ;start with the fan off G28 X0 Y0 ;move X/Y to min endstops G28 Z0 ;move Z to min endstops G1 Z-5.0 F3000 ;move the platform down 5mm G92 E0 ;zero the extruded length G1 F200 E3 ;extrude 3mm of feed stock G92 E0 ;Zero the extruded length again G1 F3000 ;Put printing message on LCD screen M117 Printing... Can anyone please help me with this?
  4. I have a duet wifi board running the latest firmware 1.21, using Cura with the FT-5 printer. I can move around and home perfectly fine with both the individual axis and with the home all. The problem arrises when I try to print a file generated in Cura. After homing the printer and loading up a file, the head wants to move beyond the print area. The Z moves up into the head, the X moves further away in the + direction. My home position is in the upper right corner of the 300x300 bed, the Z is 400mm. My axis movements all begin in the minus X, Y, and Z direction from home as I am using the minus quadrant relative to my zero. I suspect the problem is in the Cura start code? Ive been trying to get up and running for four days now with no success. Any help on getting my prints set up in the middle would be great! My Duet wifi Config.g file is : ; Configuration file for Duet WiFi (firmware version 1.21) ; executed by the firmware on start-up ; ; generated by RepRapFirmware Configuration Tool on Wed Oct 17 2018 15:55:24 GMT-0400 (Eastern Daylight Time) ; General preferences G90 ; Send absolute coordinates... M83 ; ...but relative extruder moves ; Drives M569 P0 S1 ; Drive 0 goes forwards M569 P1 S0 ; Drive 1 goes backwards M569 P2 S1 ; Drive 2 goes forwards M569 P3 S1 ; Drive 3 goes forwards M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation M92 X80.22 Y80.22 Z400.5 E420 ; Set steps per mm M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min) M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min) M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2) M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent M84 S30 ; Set idle timeout ; Axis Limits M208 X0 Y0 Z0 S1 ; Set axis minima M208 X300 Y300 Z400 S0 ; Set axis maxima ; Endstops M574 X1 Y1 S1 ; Set active high endstops ; Z-Probe M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed M557 X15:285 Y15:285 S20 ; Define mesh grid ; Heaters M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0 M143 H0 S120 ; Set temperature limit for heater 0 to 120C M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1 M143 H1 S280 ; Set temperature limit for heater 1 to 280C ; Fans M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on ; Tools M563 P0 D0 H1 ; Define tool 0 G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C ; Automatic power saving M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss ; Custom settings M501 The Start code from Cura is: G21 ;metric values G90 ;absolute positioning M82 ;set extruder to absolute mode M107 ;start with the fan off G28 X0 Y0 ;move X/Y to min endstops G28 Z0 ;move Z to min endstops G1 Z-5.0 F3000 ;move the platform down 5mm G92 E0 ;zero the extruded length G1 F200 E3 ;extrude 3mm of feed stock G92 E0 ;Zero the extruded length again G1 F3000 ;Put printing message on LCD screen M117 Printing... Can anyone please help me with the correct parameters here to get my first print?
×
×
  • Create New...