Jump to content
Ultimaker Community of 3D Printing Experts
valcrow

UMO steppers taking unpredictable steps

Recommended Posts

Hey all you knowledgeable people out there.

So I have this really bizarre issue with my UMO and for the life of me, I can't figure it out.

Basically everything seems to work fine for the first 30 seconds or so. Preheat, start process all works great.

Then once it gets to about 30 seconds in, the stepper motors start making clicking noises and stopping periodically fairly unnaturally. It will do a zig zag when it's suppose to do a straight diagonal line on the infill.

Watch this video of it in action. (I have the filament out so it's not suppose to be extruding, just watch the action of the pullies + printhead.) At this point it should be doing long diagonal strokes for the bottom layer infill.

 

It's not getting caught on anything and there isn't an abundance of friction on any axis. There is something electronic at fault.

Ok, so that's not so weird. but it gets weirder! I have another UMO I have access to that has a broken ulticontroller wire. So I thought hey. Maybe I'll just swap the Ulticontroller over so I can use the other printer instead of mine. Sure enough I swapped over the controller to another UMO and sure enough it does the same thing, but not consistently the same as the other one.

So I thought maybe there's some issue with my file. So I re-slice. Same issue.

Maybe it's my Ulticontroller, I swap the controllers keeping only the wires. Same issue.

Maybe it's my memory card, swap memory cards, and re-slice. Same issue.

Ok, maybe it's my CURA... I run a standard ulti-bot code already on the SD card. SAME ISSUE!

IMG_20150528_040520-1024x576.jpg

As you can see the first 2 layers went down perfect and then clicking started and motor stalls. Funny thing this time though, the extruder motor was doing the same thing...

So I'm at a loss. This CAN'T be the same issue with both machines it just seems completely unlikely. The ONLY part that is consistent with both machines is the Ulticontroller flat cables, of which I only have 1 set of so I can't swap that out to test.

Could a bad cable cause such a strange failure?

Any thoughts?

Edited by Guest

Share this post


Link to post
Share on other sites

Hi Valcrow,

Lets try to tackle one problem at the time.

Maybe they are not related.. (or maybe they are..)

Have you tried swapping around your stepper drivers?

My initial thoughts were that maybe they were overheating.

Pay attention when swapping them around that you replace them with the pot meter facing the right direction.

There should also be 3 small black blocks next to the stepperdrivers, are those all intact?

If it helps, try to take a micro-picture (I don't know if you have access to such a lens?:p)

If that doesn't make a difference, you could try to swap the X&Y motors around.

See if that makes a difference.

Looking forward hearing about your findings,

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the suggestions.

Very similar issues to you peggy.

I have no idea which are stepper drivers or what pot meters are... But I think your initial assessment of overheating might be right?

I took pictures of both UMO boards.

UMO1

IMG_20150528_160301-1024x576.jpg

UMO2

IMG_20150528_1608351.jpg

So here's the thing, apparently both mobo fans were kaput in some way.

UMO1, the fan was shorting or something because after plugging it in for a few minutes the fan was SUPER hot. I could feel it through the label. Something must be shorting, in addition there was a burny electronic smell. I thought it was just weird stuff purging from the nozzle, but I'm convinced it's the mobo fan. I have disconnected it for safety.

UMO2, the red wire on the fan had broken off so the fan hasn't been running. I soldered it back on and it seems to be working albeit a bit slowly. I successfully printed an Ulti-bot so I guess the fan had something to do with it, either a short or too hot or something... the cooling it provides doesn't seem very significant but it seems to be working so far.

The heat sink on one of the microchips fell off, 1 on each printer...

Share this post


Link to post
Share on other sites

The stepper drivers are those blue 'squares', 3 in a row and 1 in the opposite.

You can also see that on 1 of the 3, the black cube is missing.

That black cube is a heat sink and helps the stepper driver cool down, when it is becoming hot.

Obviously, the fan is helping the same cause.

So the fact your fan is kaput, but it is missing also its own cooling you are probably over heating.

On both pictures you have 1 stepperdriver with a heatsink missing, however on the second photo it is on the extruder motor, so that should not interfere with your X or Y movement.

Share this post


Link to post
Share on other sites

Nice one, Peggy! Good catch.

The difference between no fan and a little bit of fan is theoretically infite (0 miles per hour versus 1 miles per hour is more than 2X. It's more than 10X). But of course in reality there is some convection without the fan so there is a tiny bit of wind. But even a very weak fan cools maybe 10X or 100X better than no fan.

Getting the fan up to full speed might add another 2X to 4X cooling. Which may be relatively very little improvement. That's why even a very slow fan can make a huge difference. I discovered this years ago when doing temp measurements on an electric part. I was experimenting with different fan speeds and the part never changed temperature. Until the fan was off - then the part got very hot.

  • Like 1

Share this post


Link to post
Share on other sites

K, done that.

You guys are right, the fan was the issue at least for my UMO. After I soldered the wire back on I ran the thing for a 12 hour or so print and it had no funky mis-steps. So even the slow fan made it better, or the fan wiring had interfered somehow.

Regardless the solution is to make sure the fan is connected and running for this particular case.

Now to figure out the other one!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!