Jump to content
Ultimaker Community of 3D Printing Experts
printrev

Retracting way too far after print is finished?

Recommended Posts

I just upgraded to cura 15.04 and now when I finish or abort a print my printer retracts the filament 20mm or more, removing it from the print head entirely.

 

20mm is the default "end-of-print" retraction on the UM2 - from the start on...?

AFAIK this is only relevant if you use Cura with the gcode-flavor "UltiGcode". Do you made any changes on this side lately? Which slicer do you used before?

In addtion - there was a firmware issue - if you pause a running print and subsequently abort it the end-of-print retraction was doubled.

This is fixed with Cura/Firmware version 15.04.1 (or later). I think, the current version is V15.04.3 - the last digit is important.

Share this post


Link to post
Share on other sites

Do i have to use Marlin with the Tinker firmware? and do i just simply click "install custom firmware" to fix the retraction after print?

 

Hi @craftee,

if you want to install this firmware you can download the appropriate *.hex file for your printer (from the link above) and install it with Cura and "install custom firmware"...

...but... ...

...it still does not automatically fixes all printing issues... (i'm working on it... :) )

I gradually made some minor changes on the user interface and - as a side effect - the amount of the "end-of-print" retraction is adjustable (V15.09 or later - Advanced -> Preferences -> Retraction settings)

BTW: there was a short - but similar - discussion recently.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!