Jump to content
Ultimaker Community of 3D Printing Experts

Thoughts about the new Cura


Recommended Posts

  • Replies 211
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Posted (edited) · Thoughts about the new Cura

And the sad thing is there was absolutely no reason at all to rush this release.... just as with the new forum.....

 

You are right, there is no reason to rush it and we didn't. What makes you think so?

For the beta-team there is just an additional step needed right now (removing the Beta-version). There is a blog on our homepage that gives a release note and suggests for some users to continue using the old Cura. This will also be linked to the download-page.

Edited by Guest
  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura
    What makes you think so?

    * I got the error on a machine that did not have a beta installation (last was cura 15.02.1)

    * the planned public beta release was skipped

    And I'm sure it's a conscious decision, but I wonder if it's smart to release with some real functionality missing. I'm not talking about mine-craft stuff, but f.e. print one-at-a-time...

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    Well, beta releases do give an additional step but that 'cost' ensures that the quality of your release improves. The only difference would have been calling it an open-beta (hence my confusion about this). It's all about expectation management; If you download a beta and it crashes, that is sortof to be expected. If you do the same with a release version, it's bad.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    * I got the error on a machine that did not have a beta installation (last was cura 15.02.1)

     

    Same here on a Win 8.1 VM with 15.02.1 being the last installed Cura.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

     

    * I got the error on a machine that did not have a beta installation (last was cura 15.02.1)

     

    Same here on a Win 8.1 VM with 15.02.1 being the last installed Cura.

     

    We had a bug like this before, where an old version was the problem. It seems that is not the case here. We're working on a hotfix.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    Installing a beta version (15.05.97) and relaunching 15.06 allowed it to run on Win 8.1.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    In order to take away any miscommunications; an open beta test was not skipped.

    In fact, there was an open beta-version available on a dedicated link where people were directed to when shown interest to test.

    This finished together with the closed beta group, and together we moved towards an official launch. Hopefully this takes away any confusion.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    And may i add that Cura releases were often done in Beta versions before going to release candidates, it has worked like this for a long time before.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura
    Download Cura 12.11

    For Windows

    What is this version, and notification. Did you take down the 12.06.01 that hotfixed the issue.

    WHAT is going on? What is it with all these versions, and the facebook post about the new Cura, and now giving the users some crazy new old one?

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    Hi @Titus,

    1 new version has been uploaded that should fix the problem some users encountered on windows, it is 15.06.01.

    12.11 was a human mistake, where the upload date was set at 2015, instead of 2012, where it originates from. That has been corrected. Everything is ok :)

    What is up with the facebook post?

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    I already had direct contact with Jaime and Arjan(or Arjen) to notify them of the wrong upload :)

    Every thing seems fixed now.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura
    1 new version has been uploaded that should fix the problem some users encountered on windows, it is 15.06.01.

    just tried, it works ok for me now.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    Just installed on Win7 PC. Seems to be working fine.

    I really like the layout and interface. I can see this will be a huge step forward once the plugin functions are utilized.

    Just messing around, I loaded a complex model and let it slice using the speed/quality slider bar. Seemed to work alright. Auto slicing seemed have a delayed start. Maybe it just didn't show any indication when it had already started. Maybe because it was a large model.

    Personally, I'd still rather have a button "Start Slicing", but I have grown accustomed to the live slicing. The delayed start made me wonder if was actually going to live slice or if I needed to find a button.

    I then cleared that model, and loaded a simple model I have been printing alot.

    The simple model wouldn't begin to slice for some reason. I had to restart Cura to get a slice.

    It was fine after that, but I noted a critical setting that is either missing or in a non-obvious location: Nozzle size

    (I tried to BOLD that last sentence, but the tags don't seem to work. [ b], [ /b])

    Have to get to work now. I'll be watching the thread closely

    I can tell already, its going to be great.

    Thanks UM!

    • Like 1
    Link to post
    Share on other sites
    Posted (edited) · Thoughts about the new Cura

    It is a setting, just not one that is visible by default, as most users tend to use the default nozzle of the machine.

    Edited by Guest
  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    I just downloaded CURA from the shiny new page that screamed "ALL NEW CURA - GET YOUR FIX HERE", and clicked on the captcha button to confirm I was not a robot. Thing is, how did the captcha know I'm not a robot? That was really freaky! Maybe it can see me through my web cam? I'm getting really worried here.

    But that's not all. I installed the download and ran CURA, and discovered my goldfish died. I was really shocked. How could this new program kill my goldfish? I asked my wife, and she said that the goldfish had been dead for a while, and it probably had nothing to do with CURA, but I'm not convinced.

    Well, the shock, horror and disappointment did not end there. The new CURA looks exactly the same as the old one. Right down to the models I loaded into it. The models looked exactly the same as the models I loaded into the old CURA. Where was the "make awesome" button we were promised? Where was the all-new singing and dancing wireless neural interface with the Minority Report blue holographic interface?

    Then is occurred to me. I am a humble Linux user. For me, the world is grey and drab, and all the world looks down on me as a sad freak. So does CURA. It hates me for being too geeky, so it makes itself look like CURA 15.04.

    There is a lesson to be learned from this. When releasing a beta onto a fickle public, they will whine, gripe and complain incessantly about all those things that have very little importance despite the fact you spend long hours trying to make even that part look pretty. They will ignore the rocket engines and turbocompressor, superchargers and laser cannon you installed under the hood only a few buttons and a trigger pull away that took nights of electric shock therapy and nitric acid baths for your eyeballs to get it all in to such a crammed space. And you will weep.

    You see, I too was a software engineer, and I loathed marketing and despised the management, for they thought only in marketing terms. They would describe a good meal as a "upward-moving consumer-facing victual for discerning gastronomes, going forward". They knew ought about software development. And the users made me shudder. They gave me sleepless nights because they persisted in asking for picayune and useless functions that they could have sorted out quicker with pen and paper.

    And so dear CURA developers, you have my sympathy. I know exactly how you feel. And I empathise. I weep for you too.

    And so, if I don't get my CURA-Pink-Unicorn-for-Linux-fix soon, I will hang my head and shamefully join the ranks of the chatterati, discard all my morals, empathy and sense of justice and rant and rave about how badly thought out the title bar border was. Just to annoy you.

    • Like 4
    Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    just not one that is visible by default,

     

    So I should be able to make it visible? maybe i'm blind but I can't find it in the machine configuration list of settings .....

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    It should be in the .json settings file. Not a 100% sure anymore if its in the machine configuration list.

  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    New Cura does not like my machine ... crashing all the time within a minute or so of gentle playing around... "CuraEngine.exe has stopped working". I tried restarting Cura, loaded different models but it keeps crashing...

    On a high end win7 laptop, core I-7 + Nvidia Quadro K1100M

    Here's the log;

    Traceback (most recent call last):

    File "c:\dev\cura\cura\PlatformPhysics.py", line 108, in _onChangeTimerFinished

    File "c:\dev\uranium\UM\Operations\Operation.py", line 49, in push

    File "c:\dev\uranium\UM\Operations\OperationStack.py", line 34, in push

    File "c:\dev\cura\cura\PlatformPhysicsOperation.py", line 22, in redo

    File "c:\dev\uranium\UM\Scene\SceneNode.py", line 310, in setPosition

    File "c:\dev\uranium\UM\Scene\SceneNode.py", line 427, in _transformChanged

    File "c:\dev\uranium\UM\Signal.py", line 94, in emit

    File "c:\dev\python34\lib\weakref.py", line 387, in items

    RuntimeError: dictionary changed size during iteration

    • Like 1
    Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    @danilius;

    I hope he found his peace. May he swim freely in the everlasting sewer pipes of the plenty.

    8d17d6cfd5a85347ac45ac6111f0c1a6.jpg

    • Like 2
    Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    @nallath, I sobbed when I saw this image. Such compassion that drives you to create such a beautiful tombstone. What a wonderful person you are. And it was a she, not a he. And a shubunkin, not veiltail. And we did not flush it down the toilet.

    We ate it. Waste of good protein otherwise.

    • Like 2
    Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    Why is there no option to load already saved profile or to load profile from gcode like in old Cura? I didn't really do much testing but, right out of the blue after installation I wanted to use existing profile on similar model, and just couldn't find any options to load that. I just need to redo profile again..? And then what..? Do i have to type all the settings again for next model i plan to print...

    • Like 1
    Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    Is Cura exclusively Ultimaker now, or just for this build?

    I'm not seeing a clear way to add other, not as beautiful, machines.

  • Link to post
    Share on other sites
    Posted (edited) · Thoughts about the new Cura

    I really miss the x/y size of the bed (to change it in machine properties) . The supports on the preview look ok... Nice beta, but for my taste it still has a lot to go. The way the options are customized it's quite the opposite of what I would have design/use, too much scroll/scroll/scroll to change stuff.

    Edited by Guest
  • Link to post
    Share on other sites
    Posted · Thoughts about the new Cura

    Is Cura exclusively Ultimaker now, or just for this build?

     

    Its not exclusively Ultimaker, but we have a lot of new settings. We rely on comunity / other companies to provide us the settings. You can add new machines by adding .json files to the resources/settings folder. Cura should pick up on it automatically.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...