Jump to content
Marrit

Cura 15.10 Open Beta

Recommended Posts

Posted (edited) · Cura 15.10 Open Beta

When a customize profile is re-imported, it doesn't display with a name that matches the file name.  They come in something like "High Quality (Customized)"  I have several now so I have to rename them as I bring them in, else they all display with the same text name.  This has to be done every time Cura is ran because the profiles aren't retained on shut down.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

 

@mastory; Please create issues on github about the problems that you have. Helps us keep track (and gives you notifications if they are fixed :))

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

@nallath, I think creating an issue on github is quite a barrier, especially since people(myself included), don't know if they are doing something wrong, or that it is actually an issue.

I'll make one of my last post, I hope it's useful.

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

@nallath, I think creating an issue on github is quite a barrier, especially since people(myself included), don't know if they are doing something wrong, or that it is actually an issue.

I'll make one of my last post, I hope it's useful.

 

If you're doing something wrong, its very easy for us to say what you're doing wrong and closing it. If we never see the issue because you assumed it was your fault, its a much harder thing for us to solve.

Also if we're getting a lot of issues where users make a certain 'mistake' it probably means the interface is wrong (in which case our UX people want to know)

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 15.10 Open Beta

I'm having problems with fan control on Cura since 15.06: it generates numbers that apparently the UM2 firmware can't handle.

Here are the M106 commands in a recent print:

M106 S21.25000

M106 S42.500

M106 S63.750

What happens in the print is that the fan speed is indicated at 2% and it just stays there. If I manually set it to 25%, for example, the next M106 resets it back to 2%.

Sliced with Cura 15.04, the M106 values would have been whole numbers.

Can anyone verify this, or is it an issue with firmware in the UM2?

Edited by Guest

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 15.10 Open Beta

Thanks for the Fuzzy Skin feature!

I manufacture a part for handles used on sport fencing weapons: pommels, in several ergonomic designs. The Fuzzy Skin feature is just what I needed for a nice non-slip surface, sort of wrinkled-looking, which won't twist or slip in the fencer's hand.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 15.10 Open Beta

Well, exhaustive testing has pinned it down to fan control in 15.10.991

The fan runs fine from Cura 15.04, from Printrun, and from the control knob. However,  I can't get the fan to run correctly with b991 - fan starts on layer 2 as expected, but at 1% instead of 10%, and it then increases only to 2% instead of 20%.

I can only get the fan to run under control by selecting Prusa as the printer type, instead of UM2.

------------------------------------------------------

Update: User Error, due to undocumented, hidden, behavior in UM2 firmware.

Tinkergnome pointed out that when using UltiGcode, the fan % set in the Material setting is Multiplied times the speed set in Cura, to set the fan speed. I had 20% set in the printer.

This is simply so Wrong in so many ways:

- If this 'feature' is documented anywhere, I haven't found it,

- It overrides fan control set in Cura,

- it is hidden behavior - no way to tell that it is happening, or Help anywhere,

- it is buggy: I had set 20% fan speed at layer three in Cura and had 20% set in the Material setting of the UM2. That should result in 2% fan at layer 2 and 4% at layer 3. What was actually displayed on the printer was 1% at layer 2, and 2% at layer 3 and subsequent.

 

So the net is that if you want to control fan speed in Cura while using UltiGcode to a UM2, you need to set the Fan % in the Material Setting of the UM2 to 100%. IMHO, this is as counterintuitive as any software feature I've ever seen.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

15.09.09 UMO with HBK(official)

The bed temperature isn't showing, so I can't change it xD

Nor can I find the nozzle size setting.

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

I get a little confused with this version numbering so just go by date. Isn't Cura 1.99.0-dev.20151112 the latest version? It's the only one that runs without a CureEngine crash for me (except for older cura version).

Anyway with this version I notice USB Printing doesn't work, not even a attempt to connect to a printer in the log files. Bit of a shame really.

I did manage to get the Gcode working on my flashforge clone printer ok except when I set the bed temperature it seems to not store it in the gcode correctly, bit of a mystery. Wish I was a good programmer, could really solve allot of these basic script issues.

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

Same here, any news?

Tried to run 1.99.0 20151117

UMO with heated bed kit checked heated bed at the settings but won't show.

Where to find nozzle size setting?

and things as buildsize volume?

Regards Kees

 

15.09.09 UMO with HBK(official)

The bed temperature isn't showing, so I can't change it xD

Nor can I find the nozzle size setting.

 

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 15.10 Open Beta

don't know about the heated bed kit as I'm on a UM2 but just played around with the latest 1.99 and it's still disappointing.  It's slow in the interface, just f.e. changing the speed from 50 to 30 takes time, it so slow it only takes the 3 and not the 0....

I had hoped after the weeks on silence there would be a real machine settings solution but you still have to modify the "json file" you can find it here   C:\Program Files\Cura 1.99\resources\machines

Also other basic stuff doesn't work, f.e. print one at a time just leaves 2 items next to each other, no "head size shadow" to be seen, while this was ok in the previous version.One-at-a-time-Not-working.jpg.2b5c8215aebf6040d525f07f25d514e7.jpg

The responsiveness of moving items around on the build plate is poor even with just 2x the ultibot. I will not start the discussion on the autoslicing again  :(     but apart from testing I will not work with Cura like this...

The import and export of profiles does work, but unfortunately there still no link between settings and profiles, so instead of automatically opening the settings used in a profile you still get the silly warning and need to change the settings manually.

5a33145cb4c67_settingvsprofiles.jpg.4146b2c5331f09c5f22c0ff6f701b996.jpg

To end with something positive, it did not crash on me a single time, the previous version still did that frequently.

One-at-a-time-Not-working.jpg.2b5c8215aebf6040d525f07f25d514e7.jpg

5a33145cb4c67_settingvsprofiles.jpg.4146b2c5331f09c5f22c0ff6f701b996.jpg

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

Thanks for the Jason file thing, was looking onto the new cura for the bearing contest.

The heated bed is not to hard to do manually.

It keeps crashing on Wire print, was wondering what that was.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 15.10 Open Beta

@3dcase you know you have to use a .4 nozzle for the contest :)

maybe for what you want to do you can use the "line width" which you can turn on in "settings"

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta
you konw you have to use a .4 nozzle for the contest

Heuh... :(.

ooh ooh, time to develop a plan B...

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

The new UI looks quite nice. Only thing is that the visual color representation makes it very difficult to view. Wish it has better color visual representation in future release.

CraftWare has the best color visual representation. You can check it out on their web site https://craftunique.com/craftware.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 15.10 Open Beta

I have created a simple machine profile for my 3D printer. After going into the preference and machine settings and set up the proper profile, it seems that I can not export a complete machine profile to share with other users with same 3D printers.

Is it possible to add the ability in future release to export a complete machine profile? I look forward to future release.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

Machine settings are separate from the profiles. Profiles override machine settings.

Machine settings are stored in the /resources/machines folder in Cura's installation. We haven't yet made a way to create, import and export machines within Cura, and it's quite low on our priority list. But it should be simple enough for a technical person to create a JSON file for a specific printer, and if you make a pull request on GitHub, we can include it in a future release.

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

Looks like there's a bug in the latest Cura build.

Shouldn't M190 S50.000000 be on the next line and not right after ";POSTPROCESSED"? See the 3rd line below on the beginning of generated gcode.

;FLAVOR:RepRap

;TIME:6040

;POSTPROCESSEDM190 S50.000000

M104 S180.000000

M109 S180.000000

; -- START GCODE --

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

Would it be easier to add the function to export Preference profile? It would be nice after finished setting proper preference profile, we can export it.

Machine settings are separate from the profiles. Profiles override machine settings.

Machine settings are stored in the /resources/machines folder in Cura's installation. We haven't yet made a way to create, import and export machines within Cura, and it's quite low on our priority list. But it should be simple enough for a technical person to create a JSON file for a specific printer, and if you make a pull request on GitHub, we can include it in a future release.

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

Shouldn't M190 S50.000000 be on the next line and not right after ";POSTPROCESSED"?

 

Already fixed this.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

The new UI looks quite nice. Only thing is that the visual color representation makes it very  difficult to view. Wish it has better color visual representation in future release.

 

Can you explain what you mean by "visual color representation"? What is it that CraftWare does better than Cura in this regard? Do you need more contrast? I'm currently working on a (hopefully final) rework, so input is appreciated.

Share this post


Link to post
Share on other sites
Posted · Cura 15.10 Open Beta

Would it be easier to add the function to export Preference profile? It would be nice after finished setting proper preference profile, we can export it.

 

Yeah, that'd be nice. It would just save the JSON file somewhere user-specified. Similarly, importing a profile. This could increase community participation.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 21 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!