Jump to content
Ultimaker Community of 3D Printing Experts

Heated bed no power/ possible electronics failure?


Recommended Posts

Posted · Heated bed no power/ possible electronics failure?

Hello everyone!

I recently managed to get self sourced heated bed that is nearly identical to HBK, except the converter board (it is absent). Also i assembled a mosfet key to operate a heated bed's power, but didn't connected it. First I tried to turn bed heating on, without actual power connection, and it turned out, that output voltage was around 0 and corresponding led was also turned off, while ulticontroller was showing target temperature.

I tried a couple of firmwares, and default one, and built using https://bultimaker.bulles.eu/ - all of them showed no errors but no power was present on heated bed terminal.

Is it dead electronics or am I missing something? How can I configure marlin to use second extruder's output for heated bed?

Thanks in advance!

  • Link to post
    Share on other sites
    Posted · Heated bed no power/ possible electronics failure?

    First:

    How are you going to power your bed since the UMO standard power brick does not deliver enough power.

    Now about measuring on the output of the UMO terminals. The UMO has a opencollector output for the heated bed. Without connection anything you will always measure 0V.

    The best you can do is to connect a resistor (for example 10K) from the vcc terminal (19V) to the heatedbed terminal

    19V -----------

    --------| 10K |---- Heated bed connection on UMO board.

    -----------

    And measure with a voltmeter over the 10K resistor. When the bed is on you should measure 19V and when it is off you should measure 0V.

  • Link to post
    Share on other sites
    Posted · Heated bed no power/ possible electronics failure?

    Thanks, @zoev89!

    I use dedicated 300W 24V industrial PSU for my HB, so my intentions are to use UMO board heated bed connections only to control MOSFET key.

    I assembled a test circuit with 10kOhm resistor and a diod, but i used both heated bed connections (as V+ and GND), should I use 19V direct from the power inlet of UMO board to check if 19V is available on the socket? After all, diod on the UMO board near the HB connector is always off too.

  • Link to post
    Share on other sites
    Posted · Heated bed no power/ possible electronics failure?

    This is what I was thinking about:

    hkb.thumb.png.3ab0c0da0920ea4b4d83e544927aee4d.png

    So on the connector there is a 19V terminal and the mosfet output that can pull the other terminal to ground. The 10K resistor now acts like a heated bed and by measuring parallel across the resistor with a volt meter you can see what is happening.

    How are you planning connect you heated bed? I have a similar setup a heated bed with 24V power supply and an external mosfet. I used a optical isolator at the time which became redundant when I started powering the UM board from the 24V with a 24->19V stepdown converter.

    hkb.thumb.png.3ab0c0da0920ea4b4d83e544927aee4d.png

  • Link to post
    Share on other sites
    Posted · Heated bed no power/ possible electronics failure?

    Oh, I see, I did exactly as you explained. When the heated bed is "powered" from the controller, the drain is still in closed state. No connection to the ground, the led is turned off and the voltage is zero.

    It is either dead output of my Arduino Mega, or strange behavior of the firmware or some hardware problem of the UMO board (shield) itself. While connection to the +19V from terminal is ok.

    Does anyone knows how to build marlin to use second extruder heater's terminal as heated bed's one?

    I decide to use https://www.youmagine.com/designs/ultimaker-heated-bed-mosfet-relay-hack-v2 by Jonny Bischof. And after a while I also plan to switch to powering the whole setup with single psu. Which 24 -> 19 V stepdown regulutor do you use?

  • Link to post
    Share on other sites
    Posted · Heated bed no power/ possible electronics failure?

    Well I found this marlin build guide, I definitely should give it a try.

  • Link to post
    Share on other sites
    Posted · Heated bed no power/ possible electronics failure?

    Yuhu! I actually managed to find out where my problem was! It was pt100 with 4k7 setup. Somehow it showed big error and temperature of the bed was around 2°C. And actually firmware is blocking heating without any message. After I heated the bed a little (with a lighter) it started the circuit! Thanks a lot for your help @zoev89! Can you tell me which circuit do you use now to control and power HB?

  • Link to post
    Share on other sites
    Posted · Heated bed no power/ possible electronics failure?

    Good that you found it. I have to it dig up (can't at the moment) some of my photos of my setup they were on the old forum and are lost now....

    The circuits I used were mainly parts that I had laying around but it does give you some idea.

  • Link to post
    Share on other sites
    Posted (edited) · Heated bed no power/ possible electronics failure?

    I want to know something more about your problem.

    Can you please tell me the type and the specification of your board?

    Also did you make any change in your firmwares?

    I want to know more about your MOSFET and also the heatbed you are using with it.

    pcb assembly services

    Edited by Guest
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • 16 Visiting our virtual showroom

      1. 1. Have you visited our virtual showroom before?


        • Yes
        • No
      2. 2. If yes - what content did you find most interesting?


        • Information about Ultimaker ecosystem
        • Applications & application stories
        • Customer success stories
        • Webinar sessions
        • Material wall & ecosystem partners
        • New product introduction; software subscription plans
      3. 3. What of the below would make you consider visiting (again)?


        • New Live Ultimaker Webinar streams
        • ‘Ask Me Anything’ with industry experts or Ultimaker staff via main stage and public chat
        • New customer success stories
        • New applications
        • Presentations/news from ecosystem partners
        • Opportunity to meet representatives for an interactive tour
        • Helpful videos like Software tutorials
        • Other; leave input in a comment below!

    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
          • Like
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...