Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker 2 Dual Extruder einstellen.


Recommended Posts

  • Replies 693
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo Holger,     Falls Interesse, Ich habe hier     ein externes Python Script für das Dual Drucken mit S3D geschrieben.   Gruß Gerd

Posted Images

Posted · Ultimaker 2 Dual Extruder einstellen.

Hi, ultiarjan

Ich habe vorne eine einfache Plexiglasplatte und oben einen Karton gelegt.

Es tritt starkes warping auf, nur der Brim hat das Bauteil auf der Platte gehalten.

Muss in die Richtung geschlossener Bauraum Optimieren.

Gruß

Marin

  • Like 1
Link to post
Share on other sites
Posted (edited) · Ultimaker 2 Dual Extruder einstellen.

Kleines Feedback noch von meiner Seite:

Ich habe mit FW 17.02 jetzt bestimmt 5-6 30h Drucke hinter mir und keinen einzigen Abbruch gehabt.

Bei zwei Drucken wollte ich altes ABS "verballern" und habe 2x verstopfte Düse und dadurch viel Abrieb in den Bondtech-Ritzeln gehabt. Druck war wegen Underextrusion nicht zu gebrauche. Daher habe ich alles alte Filament entsorgt, alles gereinigt und drucke jetzt wieder mit Material4Print ABS in schwarz seit mehreren Tagen problemlos.

Es ist echt unglaublich, wie unterschiedlich ABS sein kann. Mit dem alten RepRap Filament und auch von einer anderen Firma gabe es viele "Blobs" auf der Oberfläche und jetzt mit dem ABS von Material4Print sehen die Drucke fast perfekt aus. Ich muss jedenfalls vor dem Bedampfen mit Aceton kaum nacharbeiten.

Ich werde die FW 17.02 weiter testen, aber bisher scheint alles stabil zu laufen. Habe damit aber noch nicht dual gedruckt, weil ich erst einige Bauteile fertigen musste.

Ach Marin, was muss man für Peek hinlegen? Ist für mich an einigen Stellen sicherlich auch interessant, im Motorraum einzusetzen.

Gruß, Stephan

Edited by Guest
  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hi, ultiarjan

    Ich habe vorne eine einfache Plexiglasplatte und oben einen Karton gelegt.

    Es tritt starkes warping auf, nur der Brim hat das Bauteil auf der Platte gehalten.

    Muss in die Richtung geschlossener Bauraum Optimieren.

    Gruß

    Marin

     

    I've been thinking about high temp printing myself (just thinking...) but it seems to me that if you really want to get to a serious chamber temperature you probably need;

    - water cooling (I don't have it)

    - direct drive XY motors, mounted outside of the box

    - better heated bed

    - maybe an extra heater in the chamber + chamber temp control.

    Probably all doable if you have the time to spend....

  • Link to post
    Share on other sites
    Posted (edited) · Ultimaker 2 Dual Extruder einstellen.

    Hi SKlasen

    Das ist noch in der Test Phase mit dem PEEK Material.

    Muss den Ultimaker kapseln um die Temp im Drucker auf ca 60-70°C konstant zu bekommen. Wäre für ABS Drucke auch von Vorteil.

    Das PEEK Material hat ca 90€ für 10Meter gekostet.

    Hi ultiarjan

     

    I've been thinking about high temp printing myself (just thinking...) but it seems to me that if you really want to get to a serious chamber temperature you probably need;

    - water cooling (I don't have it)

    - direct drive XY motors, mounted outside of the box

    - better heated bed

    - maybe an extra heater in the chamber + chamber temp control.

    Probably all doable if you have the time to spend....

    "direct drive XY motors, mounted outside of the box" denke ich an eine Wasserkühlung der Motoren.

    "better heated bed" habe 230V Heizplatten bis 200°C gefunden.

    "maybe an extra heater in the chamber + chamber temp control." Noch keine Idee ;)

    Gruß

    Marin

    Edited by Guest
    • Like 1
    Link to post
    Share on other sites
    Posted (edited) · Ultimaker 2 Dual Extruder einstellen.

    "maybe an extra heater in the chamber + chamber temp control." Noch keine Idee ;)

     

    Ich hätte dazu eine Idee: https://www.amazon.de/gp/product/B000OIH1FU/

    Gerade für seinen originalen Einsatzzweck gekauft, könnte man aber auch unter / neben den Drucker stellen um den Bauraum zu beheizen. Macht 60-70 Grad, 1.000 Watt.

    Ist im Prinzip ein Heizlüfter mit Beinen und oben einem Gestell mit dem Ballon für die Wäsche.

    Der Lüfter sieht so aus: https://img.clasf.co.za/2014/09/19/Dri-Buddi-Super-Fast-Electric-Clothes-Dryer-20140919003450.jpg

    Die Stange oben kann man abnehmen. Die Füsse sollte man wg. Lufteinlass dranlassen.

    Edited by Guest
  • Link to post
    Share on other sites
    Posted (edited) · Ultimaker 2 Dual Extruder einstellen.

    Soviel zur 17.02 - läuft doch nicht stabil. Ich werde jetzt originale FW installieren. Wenn es damit auch nicht geht, muss es am Board liegen.

    Ultimaker_2017-03-09_064604.thumb.jpg.742da79e0e9cdb99a2452a48e2e12a9c.jpg

    Muss dem Problem jetzt schnell auf die Schliche kommen, weil auf Dauer wird es teuer mit dem Filament und ist sehr ärgerlich. Ich schaue gleich mal, ob das Modell genau so groß wie beim letzten Abbruch ist.

    Ultimaker_2017-03-09_064604.thumb.jpg.742da79e0e9cdb99a2452a48e2e12a9c.jpg

    Edited by Guest
    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Habe jetzt Marlin aus dem aktuellen Cura 2.4 installiert, Factoryreset gemacht, die E-Steps für den Bondtech sowie den Strom auf 1100mA eingestellt und einen ABS-Druck gestartet.

    Die Leistungsaufnahme an der Steckdose liegt jetzt schon beim Aufheizen des Heizbetts bei 204W. Werde jetzt am Stück 4-5 Bauteile á 30h drucken. Danach weiß ich mehr, ob es am Mainboard liegt oder einfach an der Tinkergnome 17.02.

    Gruß, Stephan

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Oh Stephan

    Wie ärgerlich das der Druck nach 30h abbricht ohne einen Grund….

    Den Fehler hatte ich mit der Version 16.12.1 darum habe ich die Version 16.01 wieder draufgemacht.

    Gruß

    Marin

  • Link to post
    Share on other sites
    Posted (edited) · Ultimaker 2 Dual Extruder einstellen.

    Hallo,

    ich hab zwischenzeitlich meinen Ultimaker 2+ mit dem Umbausatz von Creme auf den Dual Extruder umgebaut. Weiterhin hab ich 2 Bondtech Felder verbaut.

    Der erste Extruder funktioniert gut. Wenn ich jetzt aber das Material für den 2. Extruder einlegen will (Insert Material) kommt immer die Meldung "Cooling nozzle (2) for Insertion. Die Nozzle 1&2 haben eine Temperatur von ca 22°C.

    Das Aufheizen der Düse funktioniert. Auch der 2 Feeder arbeitet sauber!

    Kann mir jemand sagen, was ich hier falsch mache, bzw. welche Einstellung ich hier noch anpassen muß?

    Ich verwende die Firmware "Tinker-MarlinUltimaker2plus-dual-16.12.1.hex".

    Danke für eure Unterstützung.

    Gruß

    Ralf

    Edited by Guest
  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hallo,

    ich hab zwischenzeitlich die Lösung meines Problems gefunden.

    Da ich bisher noch nicht mit dem zweiten Extruder gearbeitet hatte, war auch kein Material eingestellt. Dies führt scheinbar dazu, daß die Firmware die Nozzle immer runterkühlen will.

    Nachdem ich jetzt das Material eingestellt hab, hat der Materialeinzug auch funktioniert.

    Also erst mal Entwarnung.

    Gruß

    Ralf

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hallo zusammen,

    ich bastle gerade ein wenig am G-Code und bin über ein Kommando gestolpert, bei dem ich nicht so recht weiß, was es bewirkt. Kann mir das bitte jemand kurz erklären, und zwar:

    "G92 E0 ; zero the extruded length"

    Ist das so etwas wie ein Retract?

    Danke schon einmal im Voraus!

    Gruß Frank

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hallo zusammen,

    da ich mit S3D arbeite, habe ich das Script von Gerd soweit übernommen.

    Leider habe ich das Problem, dass beim ersten Tool Wechsel der Druckkopf eine Zeit lang, ohne Filament zu fördern, hin und her fährt. Ich habe schon einiges ausprobiert, komme aber irgendwie nicht weiter.

    Kann mir da jemand einen Tip geben?

    So sieht mein Script derzeit aus:

    -----------------------------------------------------------

    Starting Script:

    G28 ; home all axes

    G1 X20 Y10 F3000 ; bring extruder to front

    T0

    G92 E0 ; zero the extruded length

    G1 Z30 ; lower

    G1 E19 F200 ; purge nozzle quickly

    G1 E26 F150 ; purge nozzle slowly

    G92 E0 ; zero the extruded length

    G1 E-5.5 F400 ; retract

    G92 E0 ; zero the extruded length

    T1

    G92 E0 ; zero the extruded length

    G1 Z30 ; lower

    G1 E19 F200 ; purge nozzle quickly

    G1 E26 F150 ; purge nozzle slowly

    G1 E-5.5 F400 ; retract

    G92 E0 ; zero the extruded length

    -----------------------------------------------------------

    Tool Change Script:

    G92 E0

    G1 E-5 F1800

    G92 E0

    G1 X180 Y227 F9000

    T[new_tool]

    {IF NEWTOOL=0}M104 S160 T1

    {IF NEWTOOL=0}M109 S200 T0

    {IF NEWTOOL=1}M104 S160 T0

    {IF NEWTOOL=1}M109 S200 T1

    G1 E5.05 F200 ;recover retract

    G4 P50

    G92 E0

    G1 E-4.5 F2400

    G4 P50

    -----------------------------------------------------------

    Danke!

    Gruß Frank

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hallo Frank,

     

    Kann mir das bitte jemand kurz erklären, und zwar:

    "G92 E0 ; zero the extruded length"

     

    G92 Überschreibt die aktuelle jeweilige Achse Position, in deinen Fall die E-Achse mit den Wert 0

    http://reprap.org/wiki/G-code#G92:_Set_Position

     

    Leider habe ich das Problem, dass beim ersten Tool Wechsel der Druckkopf eine Zeit lang, ohne Filament zu fördern, hin und her fährt. Ich habe schon einiges ausprobiert, komme aber irgendwie nicht weiter.

    Das Problem liegt an deinen Tool Change Script (das ist nicht meiner!!)

    S3D hat da einen Fehler (das erste G1 E0.0 fehlt), am Anfang habe ich es von Hand rein geschrieben, jetzt habe ich es so gelöst (Auszug aus meinen Tool Change Script)

     

    G1 X[next_position_x] Y[next_position_y] Z[next_position_z] F3000G1 E-5.0 F2400G1 E0.000 F2100

     

    Gruß Gerd

    P.S.: Wer das noch nicht gelesen hat WARNING; Ultimaker removed 5th stepper driver of Ultimaker2

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hallo Gerd,

    erst einmal Danke für Deine Erklärung zum G92. Jetzt habe ich noch ein Frage: Was bewirkt das Kommando? Was bringt es mir, wenn ich die E-Achse mit dem Wert 0 überschreibe?

    Sorry, dass ich dir das Tool Change Script zugeordnet habe. Ich hatte es aus diesem Thread kopiert, und da sah es so aus, als ob es von Dir wäre.

    Wie sieht denn dein komplettes Tool Change Script aus für s3d?

    Gruß Frank

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    erst einmal Danke für Deine Erklärung zum G92. Jetzt habe ich noch ein Frage: Was bewirkt das Kommando? Was bringt es mir, wenn ich die E-Achse mit dem Wert 0 überschreibe?

    Hier ein beispiel von Cura gcode5a3328a5a60ca_G92Curagcode.thumb.JPG.cb218ee05df3b836ba76c9bb88a8ecb1.JPG

    Das sollte doch alles erklären, wenn´st du dein S3D gcode anschaust wird der regelmäßig abgenullt, Cura macht das nur beim Düsen wechsel

     

    Sorry, dass ich dir das Tool Change Script zugeordnet habe. Ich hatte es aus diesem Thread kopiert, und da sah es so aus, als ob es von Dir wäre.

    Wie sieht denn dein komplettes Tool Change Script aus für s3d?

     

    Ok, das kann schon sein aber bestimmt zu den Zeitpunkt wo ich noch gar kein Dual gedruckt habe, oder bei meine ersten Versuche!

    Ich habe in diesen Post mein "halbwegs" aktuelles FFF Profil gepostet, bitte beachte ein paar Post danach, (z.B. das ABS Profil gleich mal löschen)

    Gruß Gerd

    5a3328a5a60ca_G92Curagcode.thumb.JPG.cb218ee05df3b836ba76c9bb88a8ecb1.JPG

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Wollte euch nur mitteilen das unsere Möglichkeit von Dual Drucken mit Ultigcode unter Cura 2.5 Beta schon wieder gebrochen wurde!:angry:

    Mein Versuch das Plugin zu ändern schlugen fehl!!

    Werde jetzt endgültig auf RepRap gcode umsteigen!

    Folgende Fehler sind aufgetreten die es zu lösen gilt:

    Mit Profile von Cura 2.4 kann man drucken aber nicht zuverlässig, habe drei druck Abbrüche mit folgenden Fehler:

    5a5df27cdaef5_Error_Triedprintingoutofprintingarea_Meldung.thumb.JPG.26fe9995bf0ea73bcb592c71dae4e50f.JPG

     

    Nach Betrachtung von gecode und Layer Ansicht konnte ich den Fehler sehen, ab und zu schlagen Düsen Wechsel fehl.

     

    G0 X106.629 Y104.126G0 X-18.1 Y0.2;TIME_ELAPSED:922.530431;LAYER:33G0 X-18.1 Y0.2 Z3.55G92 E0T0G92 E0M109 S200M104 T1 S190G0 X124.8 Y129.2 Z3.55;TYPE:SUPPORTG11
     

     

    Vielleicht ist das noch ein Bug, aber bei UMO Dual & UM3 schaut alles richtig aus.

    Nachdem ich die json Datei geändert habe war dieser Fehler auch weg, aber auch das G10 S1. Habe dann das G10 S1 über das Plugin einfügen lassen wollen aber leider, wenn schon ein normales G10 in vor raus drin steht schlägt der Düsen Wechsel fehl. T1 kein Material, der nächste Düsen Wechsel zu T0 hat zu viel Material)

    Vielleicht hat ja ein anderer eine Lösung!

    Gruß Gerd

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hallo Gerd,

    wie hast den den erzeugten g.code von Cura geändert?

    Also bei mir tut cura 2.5 mit meinem Plugin.

    Gruß

    Marin

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    wie hast den den erzeugten g.code von Cura geändert?

    Also bei mir tut cura 2.5 mit meinem Plugin.

    Aufpassen Marin, ist nicht bei jeden Teil.

    Konnte 3 CAD Teile mit Support (Dual) drucken ohne Probleme, bei 4ten CAD Teil mit Support (Dual) obiger Fehler. Hast du gesehen es steht X-18. das wurde schon falsch erzeugt, Fehler ist auch ohne Plugin vorhanden.

    Versuch mal die 3DBenchy zu slicen (das war das zweite Teil mit diesen Fehler), und schau dir in der super Layer Ansicht die Eilgang Bewegungen an! Es darf nur eine blaue Linie von unten links kommen, erster Layer. Danach darf keine mehr vorhanden sein!

    Der Fehler lässt sich beheben mit der Änderung der zwei extruder json Dateien, danach ist aber das G10 S1 weg.

    Bin gespannt ob du auch den Fehler hast?

    Gruß Gerd

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Habe deine json Dateien geladen + Cura zurückgesetzt, das gleiche Bild!

    5a33355a93e12_Cura2.5Beta2Fehler.thumb.JPG.338c02fc02551b200cee44c07cda60f9.JPG

    G0 X103.53 Y90.076
    G0 X-18.1 Y0.25
    ;TIME_ELAPSED:161.236601
    ;LAYER:1
    M106 S255
    G0 F5400 X-18.1 Y0.25 Z0.4
    G92 E0
    T0
    G92 E0
    G0 X175 Y179 Z0.4
    G10

    Fehlgeschlagener Düsen wechsel

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Hallo Gerd

    Tatsächlich du hast recht, eine total untypische Bewegung findet statt.

    Bewegung.thumb.PNG.97710ceac8d2c16845ccfef838a79ad3.PNG

    Aber erst, wenn nur noch eine Düse benutzt wird und eigentlich kein Düsen Wechsel mehr gebraucht wird.

    In Cura 2.4 schaut alles gut aus.

    Gruß

    Marin

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Moin,

    Gibt es schon neuigkeiten was Cura 2.5 betrift?

    Werde mir demnächst einen Schrank mit Luftfilterung und einem Isolierten Platz für meinen Drucker aufbauen.

    Könnte sich vielleicht auch für PEEK eignen.

    Ich werde auch versuchen eine Raspberry pi Steuerung mit meinem Drucker zu verküpfen, dann werde ich darüber die Wasserkühlung steuern und vielleicht auch die Druckraum Temperatur überwachen.

    Im unteren Teil will ich mein Material aufbewaren mit Luftentfeuchtung durch Sillica-Gel.

    Werde mal ein paar Bilder machen wenn ich, etwas vorzeigbares zusammengebaut habe.

    Gruß Alex

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Gibt es schon neuigkeiten was Cura 2.5 betrift?

    Von meiner Seite her, bin ich nach meinen 2 Fehldrücken auf RepRap umgestiegen da sind diese Fehler nicht weiter aufgetreten.

    Ich habe aber in den Thread von Ultimaker Mark2 - Der Smart Dual Extrusion-Upgrade glaube ich den gleichen Fehler gelesen und der konnte scheinbar gelöst werden hier habe aber zur zeit keine nerv dafür um mir das anzuschauen weil auch Cura nicht die Druckqualität liefert die ich von S3D kenne!

    Hier warum!

    Gruß Gerd

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Danke für die Antwort,

    Muss ich wohl S3D ausprobieren.

    Bin gespannt auf die Ergebnisse.

    Gruß Alex

  • Link to post
    Share on other sites
    Posted · Ultimaker 2 Dual Extruder einstellen.

    Leider leider, haben beide Programme Vor-, und Nachteile:(

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...