Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker Original DIY electroncis broken?

Recommended Posts

Hello everyone!

I recently bought UO DIY kit, and just finished an assembly. I had few problems - there were some pulleys and bolts missing, but I managed to buy replacements.

As I said, today I finished as assemby. As I'm not familiar with electronics I drew special attention to connect every part of electronics as it's described in manual. I double checked connections on circuit board, but when I powered UM for the first time something unusual happend - one of the motors (Y-axis motor) started to make weird noise and controller screen started to blink very fast. I tried to power UM off, but I couldn't do it with switch. Only pulling the plug worked. When I put the plug back lillte sparks showed up between plug ang socket, motor stopped making weird noise and rectangles showed up on controller screen. The only thing that works is bottom fan and diode on top of extrusion head.

I think there is something wrong with circuit board.

Does anybody have an idea what might have happend? What should I do?

Please help!


Share this post

Link to post
Share on other sites

Play with the cables going to the ulticontroller - it's easy to get them backwards but I don't think anything will break if you hook them up wrong. also if you push on the knob it should make a buzz/beep sound.

If the board is truly damaged you should probably contact support - start here:


Share this post

Link to post
Share on other sites

Thank you for your reply.

It seems that something on the the shield is broken.

- playing with Ulticontroller cables gives no effect (two lines of screen are covered with rectangles),

- pushing the knob doesn't make buzz sound,

- on/off switch deosn't work,

- the only thing that works is bottom fan and top diode,

- two green leds (led6, led7) on the board are shining, but led 6 is stronger,

- there are sparks when I plug in power adapter - looks like short circuit to me,

- when I connect arduino with shield on top to my computer it recognizes Arduino MEGA.

Because it's brand new I will contact support/my local dealer and try to get it serviced.

But just for the curiosity - depending on those symptoms - do you have an idea what could have cause it? I will get multimeter tommorow - I can test some parameters if you tell me where to check.

Share this post

Link to post
Share on other sites

Sparks are probably normal.  If it's drawing a lot of current then that heat has to go somewhere so touch different components to see what gets hot.  Although it has to get above 100C (boiling) before you should start to worry.

Can you read schematics?  You can get information about what is definitely working if you want by looking carefully at the schematic:

ULTIMAKER 2 SCHEMATIC - click "raw":



Wait - what? Shield? This doesn't sound like the white PCB UMO kit.  What color is the PCB?  I was assuming you had the recent KIT that's been out since I think this past January.  Maybe you have an older PCB?  If so that schematic is here:


Edited by Guest
  • Like 1

Share this post

Link to post
Share on other sites

I have an older pcb. That's strange - I've recieved my kit two weeks ago, and I was being said it goes directly from Netherlands. Now you say UM ships newer version from January.

I'm a little bit confused. Maybe there's been some mistake... To be specific.. I've got Ulitmaker Original, not UO+ - don't knot if that makes a difference in case of electronics.

I think reading schematics, without electronics background (and I don't have one) would be useless in that case, so I will contact support and try to have that piece replaced.

One last question - is it possible that broken stepper motor or other part was the cause of that problem? In other words - can other elements damage that PCB board?

Thank you for all your help!

Share this post

Link to post
Share on other sites

After updating firmware my UO came back to life (at least partially). I should have done it at the beggining, I suppose, but I'm a total begginer at this field (it's my first 3d printer).

So what have changed:

- ultimaker controller screen now works fine - I can navigate through menu,

- y and z axis motors work fine.

What doesn't changed:

- I still can't switch Ultimaker off by using side switch,

- x axis motor and extruder motor doesn't work (but it's not a motor failure - when I changed x and y motor plugs on the shield, x motor started to work),

- when I choose "Preheat PLA" option, "preheat failure" text showed up and the screen began of controller started to blink.

So I'm miles ahead, but still not there. Anybody have an idea?

Share this post

Link to post
Share on other sites

I didn't know you could still buy a UMO "regular". I thought only the "+" was for sale.

When you switch it off by the side switch - could it be the USB cable that *appears* to be powering the printer (but not the steppers of course)? That is normal. In other words - try removing USB cable and switching power off - does it still stay on?

Well the UMO board has these things that are usually called "pololus" or "stepper drivers". They are socketed and there is one near each axis (X,Y,Z,E). You could try swapping the drivers for Z and X to see if the problem moves with the pololu. If so then they only need to send you a pololu maybe? Or you could buy a few - they are quite cheap (google pololu black):


Share this post

Link to post
Share on other sites

My Ulticontroller has changed to gibberish on me twice while in operation (but not printing). I was calibrating the bed and when I went to use the Ulticontroller to home the bed, it was all garbage text. It hasn't happened for a few weeks. I made sure the electronics fan was working and had airflow...it does. Just one of those odd moments.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 130 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!