Jump to content
Ultimaker Community of 3D Printing Experts

Help with Cura on OSX 10.7.4 - slicing errors


Recommended Posts

Posted · Help with Cura on OSX 10.7.4 - slicing errors

Hello.

I have problems slicing a model in cura 12.08 using Mac osx 10.7.4.

when i try to "Slice to GCode" i get an error saying:

"Something went wrong during slicing!", the log reveals:

-------------------------

File /Applications/ReplicatorG/examples/hexagon.stl is being chain exported.

Exception traceback in getModuleWithDirectoryPath in archive:

Traceback (most recent call last):

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/archive.py", line 244, in getModuleWithDirectoryPath

folderPluginsModule = __import__(fileName)

File "/Applications/Cura-12.08/Cura/cura_sf/skeinforge_application/skeinforge_plugins/craft_plugins/carve.py", line 107, in

from fabmetheus_utilities import svg_writer

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/svg_writer.py", line 14, in

from fabmetheus_utilities.xml_simple_reader import DocumentNode

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/xml_simple_reader.py", line 35, in

from fabmetheus_utilities.geometry.geometry_utilities import evaluate

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/geometry/geometry_utilities/evaluate.py", line 10, in

from fabmetheus_utilities.geometry.geometry_utilities.evaluate_elements import setting

ImportError: No module named fabmetheus_utilities.geometry.geometry_utilities.evaluate_elements

That error means; could not import a module with the fileName carve

and an absolute directory name of /Applications/Cura-12.08/Cura/cura_sf/skeinforge_application/skeinforge_plugins/craft_plugins

-------------------------

i tried various python 2.7.3 versions: the osx-shipped python 2.7.3, macports python 2.7.3 and the one manually installed one...

with all versions i get the same error.

what is wrong?

tanks for any help.

inx

  • Link to post
    Share on other sites
    Posted · Help with Cura on OSX 10.7.4 - slicing errors

    Can you check if you have the directory:

    /Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/geometry/geometry_utilities/evaluate_elements

    It tries to find the files in there, and it cannot, that's why it is giving that error.

  • Link to post
    Share on other sites
    Posted · Help with Cura on OSX 10.7.4 - slicing errors

    Yes.

    The file evaluate.py and evaluate_elements folder exists under these pathes:

    /Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/geometry/geometry_utilities/evaluate.py

    /Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/geometry/geometry_utilities/evaluate_elements

    Content of evaluate_elements is:

    -rw-r--r--@ 1 inx staff 0 Jul 6 14:34 __init__.py_

    -rw-r--r--@ 1 inx staff 2110 Apr 3 2012 creation.py_

    -rw-r--r--@ 1 inx staff 3132 Apr 3 2012 document.py_

    -rw-r--r--@ 1 inx staff 6751 Apr 3 2012 setting.py_

    ___

    inx

  • Link to post
    Share on other sites
    Posted · Help with Cura on OSX 10.7.4 - slicing errors

    There shoudn't be underscores after those filenames... any idea how those got there? They are without underscores in the package. (Should be .py not .py_)

  • Link to post
    Share on other sites
    Posted · Help with Cura on OSX 10.7.4 - slicing errors

    i was wondering about these underscores... but left them on.

    just unpacked the package osx64-Cura-12.08.tar.gz again using "The unarchiver version 3.3", browsing to the same folder shows me the files with underscores...

    unpacked them via command-line and the underlines are not there...

    so "The Unarchiver" did manipulate the files?!

    Tried again unzipping the tar.gz in the command-line first, and then using "The unarchiver" with the left over .tar file.

    This did work.

    weird.

    Using the freshly unpacked archive without underscores worked.

    Thanks!!

  • Link to post
    Share on other sites
    Posted · Help with Cura on OSX 10.7.4 - slicing errors

    You're welcome. I recommend you report this bug to the creators of Unarchiver. Seems like a nasty one.

  • Link to post
    Share on other sites
    Posted · Help with Cura on OSX 10.7.4 - slicing errors

    appended Underscores in "The Unarchiver" are a known problem in Version 3.3

    http://code.google.com/p/theunarchiver/ ... %20Summary

    should be fixed in the next update of that app.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...