Jump to content
Ultimaker Community of 3D Printing Experts

Memory: Something went wrong during slicing


Recommended Posts

Posted · Memory: Something went wrong during slicing

Everytime i try to slice a bigger model with cura I get this error.

Here's the log:

File C:\Users\Chuleo\Desktop\cellularThing_optimizedForMakerbot.stl is being chain exported.

Carve procedure took 1 minute 29 seconds.

Preface procedure took 1 minute 4 seconds.

Inset procedure took 6 minutes 7 seconds.

Fill procedure took 15 minutes 6 seconds.

Traceback (most recent call last):

File "app_main.py", line 51, in run_toplevel

File "C:\Program Files (x86)\Cura_12.08\Cura\cura.py", line 80, in

main()

File "C:\Program Files (x86)\Cura_12.08\Cura\cura.py", line 72, in main

sliceRun.runSlice(args)

File "C:\Program Files (x86)\Cura_12.08\Cura\util\sliceRun.py", line 81, in runSlice

skeinforge_craft.writeOutput(fileName)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\skeinforge_application\skeinforge_utilities\skeinforge_craft.py", line 135, in writeOutput

return pluginModule.writeOutput(fileName, shouldAnalyze)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\export.py", line 275, in writeOutput

gcodeText = skeinforge_craft.getChainTextFromProcedures(fileName, procedures[: -1], gcodeText)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\skeinforge_application\skeinforge_utilities\skeinforge_craft.py", line 44, in getChainTextFromProcedures

text = craftModule.getCraftedText(fileName, text)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\speed.py", line 143, in getCraftedText

return getCraftedTextFromText(archive.getTextIfEmpty(fileName, text), repository)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\speed.py", line 153, in getCraftedTextFromText

return SpeedSkein().getCraftedGcode(gcodeText, repository)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\speed.py", line 272, in getCraftedGcode

self.parseLine(line)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\speed.py", line 349, in parseLine

self.distanceFeedRate.addLine(line)

File "C:\Program Files (x86)\Cura_12.08\Cura\cura_sf\fabmetheus_utilities\gcodec.py", line 330, in addLine

self.output.write(line + '\n')

MemoryError

How can I fix that? As a test I sliced the same model with 1mm layer height, which worked just fine.

It can't be because of the amount of RAM (10 of 16GB Free in normal operation.) Nor can't it be because of lack of disk space.

I run Windows 7 x64 (The same thing happens with my desktop computer and my Notebook)

Best Regards

Chuleo

  • Link to post
    Share on other sites
    Posted · Memory: Something went wrong during slicing

    The 32 bit pypy implementation can only use 2GB of memory under windows. So even if you have 10GB of free ram, it will still bug out after using 2GB. Which is a bit of a shame, as the slicing process is currently quite memory hungry.

    I've never had a model so complex that it would bug out like this, but other people have had the same problem.

    However, a memory error could also indicate a problem with your RAM. I highly recommend running memtest:

    http://www.memtest.org/

    to be sure that is not it.

    (This problem is limited to Windows, Mac is always 64 bit, and for linux there is a 64bit pypy to use)

  • Link to post
    Share on other sites
    Posted · Memory: Something went wrong during slicing

    At 0.2mm layers the cellularThing_optimizedForMakerbot.stl seems to slice, but it is using a huge amount of memory, like 800MB. With thinner layers that would get even worse. Slic3r or Kisslicer might do a better job at these models.

    It's a known problem, and solving it would mean moving to another slicer (Cura is Skeinforge based), but that's no an easy change to make.

  • Link to post
    Share on other sites
    Posted · Memory: Something went wrong during slicing

    Yeah but I don't want to use a different slicer, since cura gave me excellent results - way better than netfabb.

    Instead I try to run linux in a virtual box and slice it there with cura. Hope that works...

  • Link to post
    Share on other sites
    Posted · Memory: Something went wrong during slicing

    Quick update: I installed Ubuntu in a virtual box and installed Cura there (which wasn't that easy but finally I managed to do it). Everything works just fine now.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...