Jump to content
Ultimaker Community of 3D Printing Experts
Stringman

15.04 Firmware Update Breaks Ultimaker 2?

Recommended Posts

My attempt to upgrade the firmware on our Ultimaker 2 from 15.02 to 15.04 results in an Ultimaker 2 that no longer operates. We just got an additional Ultimaker 2 Extended and I noticed a couple of improvements in its operation so I wanted to bring those changes to the older UM2 we bought at the beginning of the year.

What I Did:

- Installed the latest download of Cura on a laptop, including the Arduino drivers. TOLD IT I HAVE AN UM2.

- connected it to the running UM2

- Windows 7 thinks for a while and succeeds in setting up the USB drivers. Connecting

and disconnecting the UM2 gives the appropriate "ka-thunks" in Windows.

- Open Cura, choose menu "Machine>Install default firmware ...."

- small dialog/progress bar appears, says it is uploading firmware. At the same time, the illumination LEDs on the UM2 and the text display go dark.

- Progress bar completes, dialog says that update complete: MarlinUltimaker 2.hex

- LEDs come back up, illuminated dial gets brighter, then dims. BUT ......

- NOTHING ON THE TEXT DISPLAY. No menus, nothing happens when operating the dial or pushing it in.

- Power cycled, including completely disconnecting power. Can't get an operational startup.

- Repeat the firmware installation several times. Always appears to be uploading, always claims success.

- Yes, the Cura software says it is set for the UM2.

- But my Ultimaker is now not usable. I never get anything on the display.

- Thankful that I have the new UM2x to finish pending print jobs, but I NEED THIS MACHINE running too.

Note that we are an electronics shop servicing, designing and building engineering research instrumentation, so we can dig into this thing if need be, but it seems to be a software issue. Is there a way to revert? I suppose I should go look for an earlier version of Cura and try to reload from that?

Share this post


Link to post
Share on other sites

Additional note: fooling with the menu dial after this failure, when I spin and push it, I do get the little beeps of various pitches that suggest it thinks I am selecting a menu item, but I have nothing on the display. I have never had an issue with the display before.

Another note: I did uninstall Cura 15.04, install Cura 15.02, and do the whole thing over again. Similar results. I can click around on the menu, blindly, and something I selected started the printer moving, so it appears that I just have no display working. I would blame the display except that this happened with the firmware update, so it seems to be cause/effect.

Share this post


Link to post
Share on other sites

Just a followup . . . . at the end of the day, with excellent e-mail support from fcbrc8 technicians, we found out that yes, the display itself had failed, and they sent me a replacement free under warranty that worked. It is really strange that it died at the exact time I ran the firmware update, but it is what it is. Works fine now with latest firmware (which, yes, is a definite improvement.)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!