Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
kyyberi

Ultimaker - Cura after being in touch with Linux

Recommended Posts

I tried to find topic that discusses the same topic, but without any success. I have installed Cura to Linux and then connected Ultimaker to it. I uploaded the firmware there and tried to finish the first run wizard to the end. For some reason the Z-axis up switch does not seem to react. After trying several times, I just skipped the rest of first run. I did change the baudrate and explicitly set the port. After that I was able to connect to printer, heat up the head, slice code and start printing. All goes fine until the printer head reaches X - Y front-left corner. At that point it tries to go "outside" the frame and makes a lot of unpleasent sounding noise. I thought, ok, it might not work so well with Linux (ubuntu 12.04) and switched to Windows (Vista).

After hooking the Ultimaker to Windows, installed Cura (in the process Windows installed the drivers needed, I think). But the result is the same. Same effect head is trying to go outside the frame. Ok, I thought that perhaps some of the switches are broken and replaced the switches from another Ultimaker. Same result. After that I replaced the control unit (mounted on the bottom) and then it worked. Ok, that printer works.

But I assembled another one and that one has been used with ReplicatorG and with Windows without problems. First I hooked it with Linux again and uploaded firmware. Tried printing and it does the same thing; trying to go outside the frame. OK, again I thought that not my day and this does not work with Linux. I hooked that 2nd Ultimaker to Windows (same machine as in above case), uploaded new firmware and it does the same "outside" attempt! WTF?

It really can't be that hooking Ultimaker to Linux and using it with Cura will always break something from the control unit. Am I missing something? Some drivers? Something else. To me it sounds like that after I have uploaded new firmware to Ultimaker with linux, the windows firmware update is not able to perform perfectly eg make clean firmware update. But then again, I'm no expert in this hw /embedded stuff. Now I have two "broken" Ultimakers. Any pointers would be appreciated!

I don't have access to logs now, but can provide those tomorrow if that helps.

Share this post


Link to post
Share on other sites

Hi, I had the same problem ( not with Linux though), so i double checked the end stop connections and they where all ok.....just to eliminate any error as i had run out of options I swapped the right and left X end stop cables over on the motherboard underneath and it worked...as Diad says it had been lasered up wrong left was right and right was left.

regards

D

Share this post


Link to post
Share on other sites

Finally I had time to work with this machine/these machines again. I switched the XY cables, no difference. Or at least behaves the same. My need is to get it working, no matter how. And that I did, it works now. I removed the line

 

"G28 X0 Y0  ;move X/Y to min endstops" 

 

from start gcode to remove the XY position move in the beginning. I lef the Z-axis moving as it is. After that it works, and that is what counts atm to me. Obviously I need to manually move the printer head to XY zero position before every print but hey, as long as I can print with Linux.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

[[Template core/front/global/_customFooter does not exist. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!