Jump to content
Ultimaker Community of 3D Printing Experts
orso7

Octoprint probleme

Recommended Posts

Hallo liebe Forengemeinde,

ich habe vor kurzem versucht meinen Ultimaker 2 Extended über einen RaspberryPi mit Octopi zu bedienen und bin hier auf einige Probleme gestoßen und ich hoffe ihr könnt mir bei dem ein oder anderen weiter helfen.

1. Wenn ich über das Webinterface zum Ultimaker verbinde gehen die LEDs aus und lassen sich auch nicht mehr aktivieren (M107 befehl in der Konsole)

2. Drucken direkt aus dem Webinterface funktioniert nicht wirklich, ich verwende als Gcode Format RepRap (Marlin/sprinter) Einstellungen aus Cura Voreinstellungen. Das einzige was passiert ist das er permanent an die Endstops kommt und in der Luft druckt (Bett ist viel zu weit unten)

3. Wie bekomme ich ihn dazu das er trotzdem automatisch vorwärmt, also genau so als ob ich den Druck per Hand starte?

4. Wofür brauche ich unterschiedliche Druckerprofile? die infos sollten doch auch im Gcode hinterlegt sein oder irre ich mich da?

Hoffe mir kann hier jemand weiterhelfen, habe sonst leider nicht viel dazu gefunden =/

Edited by Guest

Share this post


Link to post
Share on other sites

Danke mal für die Antwort,

ich habe Octoprint neu aufgesetzt und eine Fixe IP im DHCP reserviert

und es funktioniert plötzlich

Nur die LEDs ein ausschalten per Gcode mit M42 Sx, funktioniert leider nicht, da hängt sich der ganze Drucker auf und muss neu gestartet werden.

Share this post


Link to post
Share on other sites

Nur die LEDs ein ausschalten per Gcode mit M42 Sx, funktioniert leider nicht, da hängt sich der ganze Drucker auf und muss neu gestartet werden.

 

Letzteres ist ein Firmware-Bug. Falls es noch ein "normaler" UM2-Extended ist (ohne "plus"), dann sollte das mit Version 15.04.3 (oder höher) behoben sein.

(Cura 15.04.4 herunterladen und Firmware-Update einspielen mit "Machine -> Install Default Firmware")

  • Like 1

Share this post


Link to post
Share on other sites

du meinst direkt vom pi? oder muss ich ihn da an den PC stecken?

 

Von letzterem weiß ich, das es funktioniert. Firmware einspielen ist ja schließlich mein zweitliebstes Hobby... :)

Aber wenn Cura auf dem Pi läuft, müsste das auch gehen. Man muss nur in Cura darauf achten, das richtige Druckermodell auszuwählen, der Rest geht dann wie von selbst... :)

  • Like 1

Share this post


Link to post
Share on other sites

dann mach ichs doch lieber vom PC aus, also einfach neueste CURA Version und auf "install default firmware"

dann sollte der LED Befehl funktionieren? werde ich mal versuchen danke für den Tipp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 25 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!