Jump to content
Ultimaker Community of 3D Printing Experts

Marlin - Retraction Off Pause Bug.


MrTechAgent
 Share

Recommended Posts

Posted · Marlin - Retraction Off Pause Bug.

I'm amazed no one has mentioned this annoying Marlin bug, I face this stupid issue every time I use flexible filaments.

Basically if you pause a print with retraction off the feeder stepper motor freaks out and starts moving a few mm back and forth and the UI freezes completely and looses its communication with the other hardware until you switch off the printer. This solves one issue but also in turn wrecks certain software functions like "Change" since it doesn't reverse, printer needs a complete factory reset for a fix.

It's annoying and honestly took me a few days to understand the root of my problem regarding this stupid Marlin bug.

Any help regarding fixes will be appreciated, thanks.

  • Link to post
    Share on other sites

    Posted · Marlin - Retraction Off Pause Bug.

    I seen this but with a few changes on how to produce it. It happens to me when I do steps calibration. If the stepper goes disabled after it has push some filament and then you tell the machine to push Xmm of filament, it goes forward more and sometimes retracts. After the initial wrong push/pull it goes ok. And indeed it's a bug for sure, but.. well, for me only affected the step calibration. Now that I know that bug I control it.

    Past weekend when I was again calibrating my umo+ I had a error more close to what you say and the screen went bananas and I had to reboot since the ulticontroller did freeze. But since I wasn't printing I did even post it. Too bad I did delete the video of the bug, but since it's working fine atm...

  • Link to post
    Share on other sites

    Posted · Marlin - Retraction Off Pause Bug.

    I seen this but with a few changes on how to produce it. It happens to me when I do steps calibration. If the stepper goes disabled after it has push some filament and then you tell the machine to push Xmm of filament, it goes forward more and sometimes retracts. After the initial wrong push/pull it goes ok. And indeed it's a bug for sure, but.. well, for me only affected the step calibration. Now that I know that bug I control it.

    Past weekend when I was again calibrating my umo+ I had a error more close to what you say and the screen went bananas and I had to reboot since the ulticontroller did freeze. But since I wasn't printing I did even post it. Too bad I did delete the video of the bug, but since it's working fine atm...

     

    Thanks for the info.

    I find it funny that "Team Ultimaker" never ran into the issue in the 2 years the Ultimaker 2 has been for sale or maybe they are just not bothered enough to fix it, pity.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...