Jump to content
Ultimaker Community of 3D Printing Experts

G-Code doesn't load properly in Cura 15.04.4


Recommended Posts

Posted · G-Code doesn't load properly in Cura 15.04.4

Hello, I'm new to this printing game, so obviously have to find out a lot.

The printer is a UM 2 ext.+ btw

I try the search function of course, but will give it a go for support from this lot if I can't find the right answer.

I'm trying prints at the moment to figure out how the different settings work.

It's quite a complex hollow model with all kinds of angles, so if I get this right I've made my first steps forward to understand how it all comes together.

To see where it actually went wrong I'm trying to reload the G-code for this file (45 Mb) into Cura, but it only comes up with a bit of the top half of the model.

I tried through "load model file" and "Load profile from G-code", but the results are poor.

Am I doing something wrong or can't Cura handle my file?

Thanks in advance for you adequate replies

  • Link to post
    Share on other sites
    Posted · G-Code doesn't load properly in Cura 15.04.4

    Hi @Erik-RS,

    If you convert a digital 3D model, like an STL, into a g-code the file is being converted into a list with commands. That is basically what a g-code is.

    A g-code is a text file which you can open in note pad for example or other similar tools.

    When you reload a g-code in Cura a lot of data it previously used to create a visual representation is lost, so it can't show it the same image it showed the STL.

    In the top right corner, you have the option to alter the view-mode from regular to overhang/transparant etc. One other option is layers.

    It will illustrate the toolpath the head will cross while building up your model.

    This is the only representation it can give you based on a g-code.

    It loads every layer, so if it only shows part of the model you may need to wait a few sections before it finished loading the entire file. It can take a little bit longer than with a regular STL.

    Let me know if this was helpful!

  • Link to post
    Share on other sites
    Posted · G-Code doesn't load properly in Cura 15.04.4

    Hi Sander,

    Cheers for the quick reply.

    I understand the G-code thing and the way the model is sliced to build up the layers.

    I want to check the supports in the printed file to make adjustments for the overhang angle to sort out problems.

    Some pics:

    The model imported as stl. With my luck my first project barely fits the platform and is a pain to position :(

    G-code%252520problem3.JPG

    This I see after loading the G-code

    G-code%252520problem.JPG

    The layer bar at 265:

    G-code%252520problem2.JPG

    BTW: Are there any workshops/courses on working these machines and it's software in NL?

    Just got the printer last saturday and would love to speed up the learning curve. Using it professionally, time is not on my side

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...