Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Hmmm...that's interesting. Can you please put your gcode somewhere and post a link to it? It it's not to disclose, you may send it to me in a PM.

What Cura version do you use and what type of machine have you defined within Cura? Do you have any dual extrusion option activated?

  • Link to post
    Share on other sites
    Posted (edited) · Solved

    M109 T1 S0? So the extruder 2 doesn't heat.... Did you set the temperature for extruder 2?

    Extruders don't work if their assigned head don't reach 170C unless you send a M302 to allow extrusion bellow 170C (it's for safety)

    Edited by Guest
  • Link to post
    Share on other sites
    Posted (edited) · Solved

    Solved

    Edited by Guest
  • Link to post
    Share on other sites

    Ah... that's the glitch with SelectExtruder Plugin. You first set the temperature (on the first extruder!) and THEN the plugin - which runs after slicing - selects the extruder.

  • Link to post
    Share on other sites
    Posted (edited) · Solved

    Well that gcode line it's weird

    It should be

    M104 S210 T1 ;set the heater 2 to 210

    M109 S210 T1 ;wait for the heater 2 to arrive 210

    but instead you have just M109 and set to 0 (edited), so it will 'just' wait for the heater to reach the temperature, but shouldn't set the temperature... so it will just wait and wait.. until the winter arrives XD

    Change that

    M109 T1 S0.000000

    to

    M104 T1 S210

    M109 T1 S210

    Edited by Guest
  • Link to post
    Share on other sites
    Posted (edited) · Solved

    Solved

    Edited by Guest
  • Link to post
    Share on other sites
    Link to post
    Share on other sites

    Well that gcode line it's weird

    It should be

    M104 S210 T1 ;set the heater 2 to 210

    M109 S210 T1 ;wait for the heater 2 to arrive 210

    but instead you have just M109 and set to 0 (edited), so it will 'just' wait for the heater to reach the temperature, but shouldn't set the temperature... so it will just wait and wait.. until the winter arrives XD

    Change that

    M109 T1 S0.000000

    to

    M104 T1 S210

    M109 T1 S210

     

    @neotko,

    do you mean I can slice without using the "Select-Extruder" plugin then edit Extruder1 to Extruder2 in gcode?

  • Link to post
    Share on other sites
    Posted (edited) · Solved

    Indeed. tinkergnome said it on the second reply. https://ultimaker.com/en/community/19329-cura-dual-extrusion-how-to-print-only-with-extruder-2-or-only-with-extruder-1?page=last#reply-133487

    Just make a normal single extruder gcode and add a T0 for extruder 1 or T1 for 2. Just incase check that the heat gcode points to t0 or t1 as needed.

    Edited by Guest
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...