Jump to content
Ultimaker Community of 3D Printing Experts

Upgrade your Ultimaker 2 with the Extrusion upgrade


Recommended Posts

  • Replies 369
  • Created
  • Last Reply

Top Posters In This Topic

Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

I have an Ultimaker 2 and have been extremely pleased with the results so I converted it to a 2+. I am so sorry that I did this upgrade. The bed rises up to strike the nozzle and it will not print. I carried out the upgrade as per the instructions including the firmware upgrade. I am thinking of removing the upgrade reverting the printer to original specification but I am worried that this could cause more problems. Has anyone had the same problem?. Old Timer.

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Thanks for the prompt reply Chrisw. I did the bed calibration, by that I think you mean resetting the bed with the plastic sheet supplied with the kit ?. Is there another bed calibration that you do with the + modification?. Does the reset to factory conditions on the sd card over ride the reset firmware on Cura ?.

  • Link to post
    Share on other sites
    Posted (edited) · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Is there another bed calibration that you do with the + modification?.    Does the reset to factory conditions on the sd card over ride the reset firmware on Cura ?.

     

    That's the calibration I was talking about, using the wizard from the UM2 LCD panel.  I don't know about the differences of factory resets using SD card vs Cura however I'd run the calibration again after resetting just in case.

    I have 2 UM2's here but no + kits.  I'm just thinking of things I know of that could have caused the problem you're describing on one of my machines, after complete disassembly and reassembly.  One of those was my forgetting to do the bed calibration.  The reassembly took a while, and once it was all finished my brain decided it's ready to print, and I forgot that step.  

    Another thing I'd recheck would be the two rods that carry the hot end.  Make sure they're both firmly popped in place on the 4 plastic boxes.  If one of those were loose it could change the height of the nozzle by a few mm.

    Edited by Guest
    • Like 1
    Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Hi' ChrisW, I did the wizard several times but the bed hits the nozzle around the left hand clip and is followed by a "grinding noise" from the "Z" gear. I have checked the X&Y rods and they are firmly seated. I will try again tomorrow and if I find the answer I will let you know. The printer is in the home of a friend (he owns it) and I am helping him print (when it works!!!). Thanks again for your help.

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Did you accidentally upgrade the firmware with the Extended+ setting? This will give the wrong Zheight value, and since 0 Z is from the bottom it would explain why it would hit the nozzle.

    I would update cura, and reinstall the firmware again making sure its UM2+ and then do a factory reset after the firmware update and try again.

    • Like 2
    Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Did you accidentally upgrade the firmware with the Extended+ setting? This will give the wrong Zheight value, and since 0 Z is from the bottom it would explain why it would hit the nozzle.

    I would update cura, and reinstall the firmware again making sure its UM2+ and then do a factory reset after the firmware update and try again.

     

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Hi' Valcrow, you may have hit the nail on the head!!!!. I could have easily accidentally updated the wrong firmware and tomorrow I will check and recheck this to make sure. Very many thanks for bringing this to my attention. I will let you know the outcome, thanks again.

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

     

    @Oldtimer: Just an FYI: You can quote and reply to someone in a single message. No need to add 2 messages for that each time. Unless perhaps its a way to get your points up? :)

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    @Blizz ;

    please keep in mind the temperature will be more precise with the new temp sensor.. so try adding about 10 degrees to your printing temp.. that should take care of your issues.

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    @Korneel: As stated, my e-steps was still configured for 282 when it needed to be 369 for the new extruder. It prints ok now :)

    (Well, apart from the persistent squeak I can't seem to find the source for, but that was already the case before the upgrade :) )

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

     

    @blizz i think you have to do a factory reset to erase those specific values because they are stored on the EEPROM (or something)

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    @DidierKlein or you can use a pronterface or run some specific g-code to change the value.

    I just used the fact that I'm running TinkerGnome's firmware, you can directly see and modify all step values via the LCD.

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    @DidierKlein or you can use a pronterface or run some specific g-code to change the value.

    I just used the fact that I'm running TinkerGnome's firmware, you can directly see and modify all step values via the LCD.

     

    Yes of course just saying in case somebody else faces the same issue :)

    • Like 1
    Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Today my Upgrade kit arrived... First Problem...

    The old printhead has a plug which is connected to jp3 8/16 step. Nothing about it the manual.

    The new printhead do not have this plug?!?

    So now? Just leave it unused?

    Please help because my um2 is now out of order and i need it tommorow.

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    @Oldtimer Have you run the bed calibration wizard already?

     

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    not sure what you mean, too lazy to check this connection atm... but basically just disconnect all plugs that are in the "black sleeve" of the old head + the feeder motor (E) , and connect all plugs in the new kit, according to the manual and you should be fine....

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    @Oldtimer: Just an FYI: You can quote and reply to someone in a single message. No need to add 2 messages for that each time. Unless perhaps its a way to get your points up? :)

     

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    @Oldtimer: Just an FYI: You can quote and reply to someone in a single message. No need to add 2 messages for that each time. Unless perhaps its a way to get your points up? :)

     

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Hi' Blizz, I am a bit confused with this site and made a few mistakes, it wasn't a ploy to get more points (whatever they are?) Oldtimer.

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

    Hi' Valcrow, you may have hit the nail on the head!!!!.  I could have easily accidentally updated the wrong firmware and tomorrow I will check and recheck this to make sure.  Very many thanks for bringing this to my attention.  I will let you know the outcome, thanks again.

     

  • Link to post
    Share on other sites
    Posted · Upgrade your Ultimaker 2 with the Extrusion upgrade

     

    Hi' Valcrow, you may have hit the nail on the head!!!!.  I could have easily accidentally updated the wrong firmware and tomorrow I will check and recheck this to make sure.  Very many thanks for bringing this to my attention.  I will let you know the outcome, thanks again.

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
        • 0 replies
    ×
    ×
    • Create New...