Jump to content
SandervG

Cura 2.1 open beta has been released!

Recommended Posts

Posted · Cura 2.1 open beta has been released!

Is there any way to switch off the using of serial ports, so it doesn't block any attached Arduino from being programmed or used?

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Do anyone know where I can adjust the bed size and/or print area for the z, y and z-axis?

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

If you never use USBPrinting, you could try removing the USBPrinting folder from the plugins folder. But that may have unexpected sideeffects.

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Hello

Sorry for my bad english.

I try this version on my Witbox 2.

Have you already had this problem?

Layers it move

Thanks

20160528_145912.thumb.jpg.14b2ea5dd163adc30c2d11cc15b86bbd.jpg

20160528_145912.thumb.jpg.14b2ea5dd163adc30c2d11cc15b86bbd.jpg

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Layers it move

 

Think this is not a software problem, looks more like a mechanical problem.

What is your "Travel Speed"?

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

I have print the same model with S3D and with Cura 15.04 and no problem

Travel speed = 60

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

 

How do you turn off Brim? In v15.X you could just set it to "None". But in 2.1 there is no such option.

 

The None option is actually a misnomer in Old Cura. It printed a skirt (which is why we changed that, so it now actually reflects what it does)

 

Would it be possible to add a "zero line skirt" named "none"? I'm not using a skirt, but if I wanted to for some reason, I'd have to change settings back and forth.

(Unless I'm the only one who feels that way. In that case, feel free to ignore me :-)

--

Another minor UI issue:

This may seem a stupid question, but how are the drop-down menues in the setup section (right hand side) supposed to be used? Click-and-hold-drag or click-and-select ?

I.e. should one click on a menu, hold the button, move towards the desired entry, release the button,

or click, let the menu appear, move the mouse to the entry, and click again?

Because the latter doesn't consistently work on my machine.

Quite often the menu closes immediately.

Also, when clicking the menu and clicking it again, without chosing a different entry, it isn't closed (as I'd expect) - at least not always. Sometimes it works. Might be my windows installation?

(I feel somewhat inadequate, posting minor UI annoyances instead of actual problems that hinder the print process...)

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

I have a similar issue as @Rejutka when selecting a menu option such as the postprocessing plugin. Menu goes by click and then it's only moving the cursor...if you click again you loose the menu (Win8.1 and Win10).

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

 

@Rejutka: thanks for reporting. I'm pretty sure we have not seen this behavior ourselves or it would have been flagged. It should behave like any combobox (click to show the dropdown menu, another click to select an option, or click outside the menu to dismiss the menu)

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

OK, now I have a problem that isn't just UI.

I think it's an old issue, I skimmed through this GitHub thread: https://github.com/daid/Cura/issues/771 and it seems to describe the problem I have.

Basically: Cura tries to create a surface in preparation of a structure without first making sure there is support below.

If there is enough infill to "catch" the new surface - fine. If not, Cura doesn't care and everything drops and leaves ugly holes.

Here's a screenshot of a GCode as displayed by Repetier Host 1.6.0 , the GCode was created by Cura 2.1.0 .

cura_surface_holes.thumb.png.c4fdc42d72d4cbaaa99bd94fccd0e4b3.png

It shows three layers, the first two only contain the shell and infill, the last one is the preparation for the surface upon which another structure is printed.

Quite a few of the lines are actually in mid-air, others may start on a line but end in mid-air, which might work but often doesn't.

It seems to me that Cura is trying to preserve filament by not covering sections that are neither built upon, nor visible.

Obviously, a solution might be to increase infill until there is enough - but that wastes time, and if I was ever visited by a goddes, it certainly wasn't the goddes of patience...

:-D

A better solution, maybe it's possible already?, would be to have an option like "close whole surface in preparation of upper structures". (Just find a better name.)

I've tried to get that by telling Cura to use more surface layers, but I don't think it had the hoped effect.

It's usually not a big deal, unless I try to print something big.

--

Unrelated, another minor UI peeve: there is no version number in the title of the program, it only says "Cura", instead of "Cura 2.1.0 beta" or something.

--

And another UI comment: Why is the bottom side of the object red? I'm assuming this is to indicate angle, but if it's the flat bottom, it shouldn't look the same as a free-hanging structure, IMO.

It took me longer than I'll admit to figure out that the underside is indeed flat and firmly against the buildplate, and not, as I first suspected, somehow hanging in space.

--

Finally, an odd bug when resizing/scaling and viewing layer mode:

Open an STL file, resize it, switch to layer view.

Result:

cura_resize_double.thumb.png.4a975ea27d9fb48e135b904c057b4f76.png

It seems to be visual only, so it does no harm except look weird. Moving the object clears it.

cura_surface_holes.thumb.png.c4fdc42d72d4cbaaa99bd94fccd0e4b3.png

cura_resize_double.thumb.png.4a975ea27d9fb48e135b904c057b4f76.png

Edited by Guest
removed the "finally" from the opening sentence. Makes it sound as if I'm hapy to post about a problem. I'm not. But I'm happy it's not just minor UI inconveniences I'm ranting about :-)

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Is retraction working on the newest release?

 

As far as I'm aware it is.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

I updated pla.cfg to tweak some settings, but the bed temperature is not taken into account.

You're using an Ultimaker 2+, right? That has its own set of profiles, and it does not use the generic material profiles. This too is being reworked for future versions.

No I'm using a RepRap (SmartrapCore) printer with a custom profile.

Is it not possible to set the bed/material temperatures in those material files?

I've set "material_bed_temperature" and "material_print_temperature" differently in profiles/materials/ but they are not taken into account in Cura.

Actually I don't think any of the settings in the profiles/material/ files are read?

Edited by Guest

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

I have some issues with thin walls, they aren't sliced.

I have 0.4mm walls with a 0.4mm nozzle but the slicer doesn't build them.

5a331dbe0355d_Screenshot2016-06-0215_05_33.thumb.png.03218d327cef2ae405f5e1182ca1f425.png5a331dbe1747d_Screenshot2016-06-0215_05_56.thumb.png.a73efec72aa120dfd367e19703ab78a0.png

Cura 15.04 was slicing almost ok (missing the first line) :

5a331dbe299ce_Screenshot2016-06-0215_14_35.thumb.png.ff530887c48654a75eab833c91543c59.png

The only way I can make Cura 2.1.1 slicing it correctly is by changing the Wall Line Width to < 0.4 (0.39).

STL:

https://dl.dropboxusercontent.com/u/7609632/print/JST%20XH%204%20pins.stl

5a331dbe0355d_Screenshot2016-06-0215_05_33.thumb.png.03218d327cef2ae405f5e1182ca1f425.png

5a331dbe1747d_Screenshot2016-06-0215_05_56.thumb.png.a73efec72aa120dfd367e19703ab78a0.png

5a331dbe299ce_Screenshot2016-06-0215_14_35.thumb.png.ff530887c48654a75eab833c91543c59.png

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Walls that are exactly walllinewidth are always problematic, as there is always the issue of rounding errors. As so much has changed, it's not that strange that in some cases the decision to ignore parts falls on the other side of the decision.

Behavior like this is also partially why we added the Wall Line Width parameter, you can lower it slightly to trick cura into not ignoring it.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

Do anyone know where I can adjust the bed size and/or print area for the z, y and z-axis?

 

In the program folder is a subdirectory "resources\machines" - the JSON files in there are the templates - copy/edit them to change these values.

[edit]There's a thread with better details somewhere, AFAIK.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Feature request (or is it a bug?):

Can the backend put important messages as popup through to the frontend, instead of merely logging them?

Example: "WARNING - No objects suitable for one at a time found, or no correct order found"

The slicer stopped working, the frontend doesn't know it. Neither does the user unless he looks into the logs.

Getting a popup would be an easy workaround.

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Getting a popup would be an easy workaround.

 

Yeah, except that these days we also have a "string freeze" due to translations. We found this too late, so it wasn't fixed.

We did change the height of the printer build area bounding box to be changed when switching to one at a time so that if it fails because of that it's more clear what is going on.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

Yay for stable Cura 2.1.2!

Good job!

Which is the preferred way to submit bugs for 2.1.2?

This thread? A new thread per bug? github?

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

@Rejutka: thanks for reporting. I'm pretty sure we have not seen this behavior ourselves or it would have been flagged. It should behave like any combobox (click to show the dropdown menu, another click to select an option, or click outside the menu to dismiss the menu)

 

Uhm... yeah you have :) Via Asana reports and "live demoed" by me at the office. And I'm glad I'm finally not the only one with this issue.

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Yay for stable Cura 2.1.2!

Good job!

Which is the preferred way to submit bugs for 2.1.2?

This thread? A new thread per bug? github?

 

Github is the prefered way of doing it right now. It's far from the perfect solution as our internal tracking is done with Jira.

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Here's a dumb question: will the beta ever support Makerbot-type printers (e.g. my FlashForge Creator Pro)? Or, can I use another flavor and just find-and-replace a few different commands? I can't wait to try out the new features!!

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 open beta has been released!

Here's a dumb question: will the beta ever support Makerbot-type printers (e.g. my FlashForge Creator Pro)?  Or, can I use another flavor and just find-and-replace a few different commands?  I can't wait to try out the new features!!

 

If anyone from the community builds it.

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

 

Now I can't test this but I'm 99% sure that this is not working for me. I could change layer one at a time yes but the rendering was not one layer at a time and that is what I want. It rendered always every layer from 1 up to the layer number I selected. And this may look cool or whatever but its not a very useful view. For now I can use a external layer viewer but I would very much have the option to just see one layer at a time.

 

Oh, now I understand what you mean. I don't think the old cura had that feature either.

 

How about explaining how its possible I clearly did not figure out how to do it.

 

https://ultimaker.com/en/resources/20511-change-machine-settings (Also, what FieldOfView said)

 

That is for Windows only.

Where do I find that folder on MacOS?

/Users/USER/Library/Application Support/Cura was only used up to Cura 15.x

Edited by Guest

Share this post


Link to post
Share on other sites
Posted (edited) · Cura 2.1 open beta has been released!

Found it!!!

It's in

/Users/marcuswolschon/.cura/machine_instances

AND IN

/Users/marcuswolschon/.cura/instances_profiles

where Cura 14.x stored it before Cura 15.x changed it to /Users/USER/Library/Application Support/Cura (where it belongs on a MacOS machine).

However it's no longer a JSON file.

Once and for all:

WHAT IS THE WORKFLOW for having Cura 2.1.x generate G-Code that an Ultimaker II extended accepts via the USB-Port (no no Ulti-GCode like from SD-card but regular G-Code)?

Where exactly do I have to put what values with Cura 2.1.x?

What values belong into machine_instances and what values into instance_profiles? What are the property and section -names to use and what is the format of these files? (looks somewhat like a Windows .ini file but that's just guessing. No idea how to do escaping and multi-line entries. )

Where do I put the values from MATERIALS.TXT (temperatures and speed+fan -overrides)?

How do I select a material?

Edited by Guest

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 14 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!