Jump to content

startmode = Expert as default


foobin

Recommended Posts

Posted · startmode = Expert as default

Im trying to package the cura and settings i use into packaged file.

How do i set so cura will always start in expert mode. Right now its always default to simple mode.

I found the command that goes to export mode in preferences file with command 'startmode = Expert' but this file is something that is set in user's profile settings after the app is loaded.

Where can i set this setting as part of the distribution?

Thanks

  • Link to post
    Share on other sites

    Posted · startmode = Expert as default

    Legacy Cura might need write permission to its installation directory to store that information. Actually, one should only once have to change it and it should stay like that.

  • Link to post
    Share on other sites

    Posted · startmode = Expert as default

    How would it be done on the most recent version of Cura?

  • Link to post
    Share on other sites

    Posted · startmode = Expert as default

    Legacy Cura might need write permission to its installation directory to store that information. Actually, one should only once have to change it and it should stay like that.

     

    The issue is im trying to make a installer package of cura with pre-defined settings for several machines. But every time cura starts, it starts in simple print mode.

    How would i get it to start in export mode? Is there a profile command or something i need to input?

  • Link to post
    Share on other sites

    Posted · startmode = Expert as default

    This information is stored in preferences.ini in the .cura\15.04x folder in the Windows user directory.

  • Link to post
    Share on other sites

    Posted · startmode = Expert as default

    This information is stored in preferences.ini in the .cura\15.04x folder in the Windows user directory.

     

    Yes, but is there anyway to set the program to default to expert mode before it writes the settings to the preferences.ini?

  • Link to post
    Share on other sites

    Posted · startmode = Expert as default

    I think i found solution

    I changed the value within the profile.py file, line 482, change default mode from Simple to Normal.

    setting('startMode', 'Normal', ['Simple', 'Normal'], 'preference', 'hidden')

    Seems to work so far!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 27 replies
    ×
    ×
    • Create New...