Jump to content
Ultimaker Community of 3D Printing Experts
Apri335

Neues "leeres" Ultimaker Board 2.1.4 ....Firmwareproblem UM2 go

Recommended Posts

Hallo zusammen,

ich hoffe mir kann jemand weiter helfen. Ich bin normalerweise von der CNC Schiene, wollte es aber nun mal mit einem 3D Drucker versuchen. Dazu hab ich mir einen Bausatz für den Ultimaten 2 go anhand Github zusammen gestellt. Die Hardware ist auch nicht das Problem, denn die ist schon zusammen gebaut.

Mein Problem ist aber mit der Firmware. Ich hab über England in Ebay das Ultimakerboard gekauft. Also das Board V2.1.4 + Ulticontroller 2.1 und dem OLED Display. Jedoch ich auf dem Board keine passende Firmware, sondern nur eine "Auslieferungsfirmware". Es kommt der Ultimaker Startbildschirm und es gibt auch Menüs, aber eben nicht die vertraute Optik und so wie es sein soll. Ich dachte mir das es ja kein Problem sein sollte, über Cura die UM 2 go Firmware drauf zu spielen, jedoch gelingt mir das einfach nicht.

Als Fehlermeldung kommt "Die Firmware ist mit dem Gerät nicht kompatibel - Versuchen Sie eine UM 2 oder UMO+ Firmware zu installieren ?". Also hab ich unter Github nach der Marlin Firmware geschaut und auch die für den UM2 (ohne go) gefunden und habe diese dann über die IDE von Arduino auch drauf gespielt. Alles soweit gut...board startet aber sagt dann natürlich Error - Stopped - Temp. Sensor BED fehlt, da dieses beim UM2 go ja nicht verbaut ist. Ich dacht mir dann, das es jetzt ja kein Problem sein sollte mit Cura das Firmware für den UM2 go automatisch drauf zu bekommen...aber leider falsch gedacht. Was kann ich jetzt tun ? Kennt jemand auch einen Link für die UM2 go firmware ? Hat vielleicht auch jemand eine Idee, warum mir das nicht Cura übernimmt ? Oder ist die Lösung, die ganze Firmware unter der IDE Arduino zu zerpflücken und die passenden Parameter umzustellen ? Ach ja...selbst wenn ich einen UM2 in Cura auswähle, kommt die selbe Fehlermeldung.

Kann mir jemand helfen ?

Für Hilfe wäre ich sehr dankbar.

VG

Share this post


Link to post
Share on other sites

Hallo,

Nur einen Fehler auszuschließen du hast in Cura den UM2GO ausgewählt?

Wenn ja, habe ich mehrere Ideen in Kopf.

Erstmal die eine:

Du könntest die originale Firmware von UM2 go mal über Cura Installiere Benutzerdefinierte Firmware installieren.

Die Dateien werden ja mit der Cura Version heruntergeladen und befinden sich in Windows Verzeichnis unter C:\Program Files (x86)\Cura_15.04.4\resources\firmware.

normal sollte er da alles installieren was man auswählt, mal sehen.

Gruß Gerd

Share this post


Link to post
Share on other sites

Hi zusammen und danke für eure hinweise und Hilfe.

Ich hab in Cura den Ultimaker 2 Go angegeben, jedoch bringt er mir die beschriebene Fehlermeldung. Ich kann aber auch einen Erfolg verzeichnen :-). Der Tipp mit der Hex war sehr gut bzw. die getippte dabei von GolaxR6 (vielen Dank dafür). Ich hatte anfangs gedacht, das er sich die jeweilige Hex-datei online holt, da ich keinen Ordner gefunden hab und auch nicht finde. Ich hab nämlich Cura auf meinem Mac laufen und finde nirgends ein entsprechendes Verzeichnis. Es wurde nur ein Verzeichnis für gespeicherte G-Codes erzeugt. Weis vielleicht einer von euch, wo die Dateien bei einem Mac zu finden sind? Es wird ja kein richtiger Installationsordner erzeugt. Frage mich halt nur, wie ich in Zukunft dann an die Hex bei einem Update komme.

Mit dem Board, hab ich mir anfangs auch gedacht, doch wenn ich mir auf Github den Schaltplan sowie die dafür gedachten Chips anschaue, kann ich bei dem Bord keinen Unterschied erkennen. Angefangen vom selben Layout bis zu dem Atme Mega. Aber es kann vielleicht sein, das es damit was zu tun hat. Aber mittlerweile (nachdem die Installation mit der Hex Datei super funktioniert hat) könnt ich mir vorstellen, das es eher das Problem mit meinem Mac ist!? Kann das sein ?....eben genau auch aus der Hinsicht, das ich nirgends die Hex-Flies finde ?

VG aus dem langsam dunkel werdenden München und danke !

Sascha

Share this post


Link to post
Share on other sites

Hey Sascha und Gruß an die Gemeinschaft,

danke dass Du das Thema aufgegriffen hast, habe bis jetzt mich nicht getraut hier anzumelden:).

Ich habe dasselbe Problem mit dem Update über Cura auch unter Win7!

Habe Anfang des Jahres den UM2 im Alurahmen nachgebaut allerdings nicht mit dem Main Board V2.1.x, sondern wie UMO mit Arduino Mega2560 (aus China:)) und einem nach dem Schaltplan von Main Board V2.1.4 erstelltem Shieldboard.

Über Arduino Software (IDE), bzw. über Cura “benutzerdefinierte Firware” lässt sich die Marlin Firmware aufspielen und den Drucker problemlos verwenden, nur über “installiere Standard Marlin Firmware” funktioniert es nicht und kommt von Dir oben beschrieben Meldung!

Habe erstmal den Bootloader im Arduino in Verdacht gehabt, deswegen habe den Bootloader mit dem stk500v2bootloader überschrieben, hat aber nicht viel gebracht

Da es Hardwareseite meiner Meinung nach, nicht viel anders seien kann, bin ich immer noch der Meinung, dass es Firmware-seitig zu regeln ist!

Da ich mich mit der Programmierung nicht besonders gut auskenne, frage an die Softwarespezialisten hier im Forum , weißt jemand woran die Cura erkennt was für Board die gerade anspricht und ob es der richtiger (oben genannter) Bootloader ist?

Danke und Gruß Alex

Share this post


Link to post
Share on other sites

Da es Hardwareseite meiner Meinung nach, nicht viel anders seien kann, bin ich immer noch der Meinung, dass es Firmware-seitig zu regeln ist!

Da ich mich mit der Programmierung nicht besonders gut auskenne, frage an die Softwarespezialisten hier im Forum , weißt jemand woran die Cura erkennt was für Board die gerade anspricht

 

Hallo,

Nach dem die richtige Firmware installiert ist, lässt sich dan die Firmware normal über cura (Installiere standart Marlin..) updaten? Wenn ja, kann ich mir vorstellen das irgendwo ein Code in der Firmware drin steht.

Share this post


Link to post
Share on other sites

Hi Gerd,

Danke für die Rückmeldung.

Ich habe, die mir bekannten Firmware auf github von „Ultimaker/Ultimaker2Marlin“ und von „TinkerGnome/Ultimaker2Marlin“ beide ausprobiert, nach dem ich die manuell aufgespielt habe, geht über “installiere Standard Marlin Firmware” leider trotzdem nicht…

Weißt du zufällig, wo die Updates von Cura gezogen werden? Ich frage mich nur, ob die Daten gleich sind die Cura sich holt und die, die auf der github- Plattform bereit gestellt werden, dann wäre es nämlich egal ob es mit Cura funktioniert, wenn ich das richtige manuell aufspielen kann…?!

Danke und Gruß Alex

Share this post


Link to post
Share on other sites

Hi Alex,

soviel ich weiß, werden keine Dateien online geholt.

Die HEX-Dateien liegen der installierten Version von Cura bei.

"Installiere Standard Marlin Firmware" benutzt diese HEX-Dateien,

dafür muß der Drucker allerdings vorher definiert sein in Cura.

Der Drucker der in Cura ausgewählt ist, wird dann Standard genannt.

Somit wird entsprechend der Auswahl bei Standard die Datei zum Drucker gesendet und keine Online-Datei oder Update. :)

Grüsse aus Bayern

Harry

Share this post


Link to post
Share on other sites

vielen Dank für die Info, das ist schon mal eine Erkenntnis, mit der man was anfangen kann!

Dann begebe ich mich gleich auf die Suche in Cura... :)

Danke und Gruß Alex aus NRW :)

 

Auf die Suche???

Die Speicherorte von windows und Mac stehen weiter oben. :D

Windows 1ter post von mir.

Mac post von dasdingo

Edited by Guest

Share this post


Link to post
Share on other sites

jap, Danke, habe gefunden und auch schon verglichen, passt alles!

Ja, wer Lesen kann,...

War doch nicht so kompliziert, bin eben davon ausgegangen, dass Cura die Daten online sich holt...., einziger Nachteil dabei, dass es hier die Settings nicht manipulieren kann, da HEX-Format, aber dafür gibt es noch github:)

Danke euch allen!

Gruß Alex

Share this post


Link to post
Share on other sites

hallo leute bin ganz neu hier habe mir vor kurzem ein neues board geleistet Ultimaker v2.1.4 steuerkarte 

jedoch habe auch ich ein problem habe die firmware istall.im displ. ist alles ok leider ruckeln die motoren auch bei mir, und die led leuchten auch nicht habe auch schon die stepper geprückt hilft auch nicht bin ratlos

Share this post


Link to post
Share on other sites

Hallo,

 

Was meinst du mit:

On 4/24/2018 at 11:49 AM, sajunky said:

firmware istall.im displ.

 

Das sagt mir nichts,

 

On 4/24/2018 at 11:49 AM, sajunky said:

eider ruckeln die motoren auch bei mir,

 

Ich lese weiter oben nichts von ruckelnde Motoren

 

Mit diesen Informationen ist es schwer zu helfen

Share this post


Link to post
Share on other sites

Hallo,

 

also wenn die Firmware richtig hochgeladen wird, ich verstehe immer noch nicht im welchen Display das angezeigt wird ist aber wahrscheinlich egal da es mir so und so nicht bekannt vorkommt.

 

Dann kann es eigentlich nur die falsche PIN Belegung des Board sein, ich habe darüber schon gelesen das die Plus und Minus Pole bei Cina´s Board´s vertauscht waren.

Hast du die Möglichkeit an einen Lüfterstecker es zu überprüfen (plus minus) und mit deinen alten Board zu vergleichen nicht das du dir noch mehr kaputt machst.

 

Und bei den Motoren kann es auch eine falsche PIN Belegung sein, ohne mich jetzt schlau zu lesen vertausche mal zwei gedrillte kabel miteinander, dann musst du nur aufpassen falls sie los stürmen das sie in die richtige Drehrichtung fahren falls nicht musst du das andere Paar vertauschen.

(ohne Gewähr sollte aber nicht kaputt gehen)

 

Die crimp contact kann man einfach wenn man hinten die wiederhaken weg drückt entfernen

 

Gruß

Edited by zerspaner_gerd
verschrieben

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Contest | Entourage 01.
      Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled models can really help to get your idea across. But besides your main model, there is more needed to get your idea across vividly! An architect regularly uses various entourage sets to help bring these ideas and models to live. 
        • Like
      • 9 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 17 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!