Jump to content
lance-greene

replaced x axis stepper motor, now it jiggles back and forth super fast

Recommended Posts

Posted · replaced x axis stepper motor, now it jiggles back and forth super fast

so my x axis stepper motor failed, i got a new one from robokits in new zealand that is the exact same as the ultimaker one and replaced it, i had some belt alignment issues but fixed them.

now when i run a part, as soon as it starts printing it jiggles very heavily and is entirely unprintable. the cable for the motor was too short so i cut some extra off the old stepper motor and soldered them together, connecting the cables all with the same color wires, then put electrical tape on the soldered points to keep them from touching.

i dont know what the problem could be, is something wrong with the firmware controlling the motor maybe? i dont know.

Share this post


Link to post
Share on other sites
Posted (edited) · replaced x axis stepper motor, now it jiggles back and forth super fast

Hi Lance,

This problem might be a wobbling pulley.

As I built my printer, I've got a few pulleys that’s had to go to the bin! They wobbled way too much.

However, I found they was drilled and had offset and was oval on one side.

I made some shims, to put on the side where there is no set screw, in this way it was possible to correct. However, in your case you may have a warranty that’s still valid, so no problem...

Well just for your info.

Regards

Torgeir.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · replaced x axis stepper motor, now it jiggles back and forth super fast

i dont think this is the issue, ive never had this problem before, the only new thing is the motor. all the pullys are the same as before

Share this post


Link to post
Share on other sites
Posted · replaced x axis stepper motor, now it jiggles back and forth super fast

Hi Lance,

Did'nt you turn the pulley on the x-stepper motor?

Some steppers have a flat part and some not, so if you turn around the pulley -things change.

The thing is; does your pulley jump up and down?

Of course, the shaft might be bended.

Just my two pence.

Good Luck.

Torgeir.

Share this post


Link to post
Share on other sites
Posted · replaced x axis stepper motor, now it jiggles back and forth super fast

i solved the issue.

when i spliced the connector to extend the length of the wires, the connector i used was from a stepper motor for a different printer we have, its connections within that connector were positioned differently than the ultimaker and signals were being crossed. i corrected this and it prints perfectly now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 23 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!