Jump to content
Ultimaker Community of 3D Printing Experts

Cura 15.04 Plugin to edit first layer

Recommended Posts

I have a Ultimaker 2+ (upgrade kit). I am printing tiny parts, and have been trying to use the plugins to modify the first few layers. However, I am having some difficulty with using these plugins:


Once I add a "Tweak at Z" step/plugin, there seems to be no way to remove it. How can I delete specific plugins? The only workaround I've found is to previously save the profile, and reload an old one with less/no plugins.

What parameters do I use to start the modification during the first layer? Specifically, I want to modify the temperature and overall speed for the first 4 layers, then thereafter to on as normally set. I have tried setting "z height to tweak at (mm)" to -1.0, 0, 0.0001, and this step/plugin does not seem to engage. Instead, the default settings from Material.txt override this first plugin. I have tried also setting "(ALT) Layer no. to tweak at" to -1, 0, and 1, and again, this first plugin does not engage. The proceeding plugin(s) that I set to start at Layer no. 2 or 3 does work perfectly fine.



Share this post

Link to post
Share on other sites

Grab the edge of the left panel of cura and drag it to the right. A tiny little "X" will appear at the top right of the plugin which you can click to remove it.


Nevermind, got it... was not interpreting "grab" as "expand". I'm a laptop so I don't see the "x" until I expand the panel so it takes up half of my screen.

Any suggestions on the second question?

Edited by Guest

Share this post

Link to post
Share on other sites

Tweaking the first layer is possible with version 4.0.3 or higher.

TweakAtZ 4.0.4


Thanks for the reply! I will try out your tweaks on the tweaks!

I spent the majority of yesterday playing around with the settings to discover that for the version I'm using (I updated it last week - 15.04.5, plugin v4.0.2), the tweaks happen after the layer # set. In other words, if I set "(ALT) Layer no. to tweak at"=2, then the tweaks will activate starting at layer 3. And unfortunately, layer 0 does not seem to be editable.


Unfortunately, the code you linked does not seem to work, either. The first layer is still using the settings in Material.txt. When I set the plugin to start at layer 0, it again starts after layer 0 is finished, effectively applying the settings for layer 1 (the second layer).

Edited by Guest

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 117 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!