Jump to content
Ultimaker Community of 3D Printing Experts

Feeder motor not working anymore


Recommended Posts

Posted · Feeder motor not working anymore

Hi fellow makers !

Coming here with hopes, but sadly I guess my Ultimaker 2 is good for a mainboard replacement :(

Some days ago, I turned my printer on as I am used to, and prepared it to change material.

Nothing happened after the hotend was hot enough and I noticed the feeder motor couldn't turn anymore.

It "vibrates" as if it wasn't getting enough current to turn. Unfortunately, there is no trimpot to turn and maybe fix this on the UM² mainboard.

Here is what I tried :

- turn it off and on again,

- turn it on without power cable connected to empty the condensers,

- factory reset

- firmware updated to latest available

- firmware downgraded to previous working version

Still, I am unable to use my printer because of this.

Got my printer brand new from Makershop.fr last year, been using it flawlessly almost everyday.

The 1 warranty just ended by April :'(

Thanks for you time and suggestions

  • Link to post
    Share on other sites

    Posted (edited) · Feeder motor not working anymore

    I guess the thing to try first is swap the motor with f.e. a xy motor and see if the issue is the motor or the board.


    Hi !

    I forgot to mention this one, but I already tried it and I've got the same behavior with another motor.

    Thanks for your suggestion

    Edited by Guest
  • Link to post
    Share on other sites

    Posted (edited) · Feeder motor not working anymore

    Since you have the extruder 2 motor unused you might want to learn to build your own firmware. This way you could change the pins.h table to make the extruder 2 work as the y motor.

    Some talking about how to compile custom firmware:



    Edited by Guest
    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 13 replies
    • Create New...