Jump to content
Ultimaker Community of 3D Printing Experts

Project planner stops early


lcollomb
 Share

Recommended Posts

Posted · Project planner stops early

Since 1 week project planner stops after slicing the first element of a group. It doesn't matter what I'm slicing. I have had the problem on another Mac. I tried saving to another folder (i.e. desktop) It seems that the windows version is not affected.

Config:

Mac OS X 10.8.2

Cura 12.11 (fresh install)

IMG_0926.thumb.JPG.66ba8d7bb94486057d720f4f1de1a88b.JPG

IMG_0927.thumb.JPG.6cefd8fa5d4978f1e462bdeb16d7caea.JPG

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    So I found a quick workaround.

    Login as a guest install a fresh copy of cura and sice. This will only work for the first slice and I cannot open the preference panel.

    After that I need to delete the guest user and login as a new one in order to slice again… strange.

    Maybe it has to do with the preference file? I cannot find where it is saved.

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    The preferences file should be saved in in your home directory in .cura (which is a hidden location)

    What you could try, is running Cura from a terminal, then you should be able to see an error log.

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    Strange still no sucsess even after removing pref and re-installing cura.

    It really stops slicing after the first object and says "it took xx secondes to export the file." with a progression bar half way there.

    How can I run cura in terminal?

    This week-end I'm doing a clean system install anyway it might help.

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    First, start a terminal (you should be able to find it in the finder)

    Then, in the black window type:

    cd /Applications/Cura/

    ./Cura/Contents/MacOS/Cura

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    Thanks for the tip. This is what I get in the terminal once its stops:

     

    Choucroute:Cura lc$ /Applications/Cura/Cura.app/Contents/MacOS/Cura Choucroute:Cura lc$ /Applications/Cura/Cura.app/Contents/Resources/Cura/util/mesh.py:69: RuntimeWarning: invalid value encountered in divide normals[:,0] /= lens/Applications/Cura/Cura.app/Contents/Resources/Cura/util/mesh.py:70: RuntimeWarning: invalid value encountered in divide normals[:,1] /= lens/Applications/Cura/Cura.app/Contents/Resources/Cura/util/mesh.py:71: RuntimeWarning: invalid value encountered in divide normals[:,2] /= lensException in thread Thread-2:Traceback (most recent call last): File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py", line 552, in __bootstrap_inner File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py", line 505, in run File "/Applications/Cura/Cura.app/Contents/Resources/Cura/gui/projectPlanner.py", line 978, in OnRun   startGCode = profile.getAlterationFileContents('start.gcode') File "/Applications/Cura/Cura.app/Contents/Resources/Cura/util/profile.py", line 534, in getAlterationFileContents   return unicode(prefix + re.sub("(.)\{([^\}]*)\}", replaceTagMatch, alterationContents).rstrip() + '\n' + postfix).strip().encode('utf-8') File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/re.py", line 151, in sub File "/Applications/Cura/Cura.app/Contents/Resources/Cura/util/profile.py", line 430, in replaceTagMatch   return pre + time.strftime('%d %b %Y')UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)

     

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    Looks like a possible problem with language settings. What native language do you have configured in your Mac?

    Most likely, removing the "at: {day} {date} {time}" from the start code works around this.

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    My system language is english, but I use the Swiss-french time and date setting.

    On a freshly installed system project-planner works again. If it starts acting strange I'll try removing the gcode you mentioned.

    Thanks for the support!

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    Removing the specified comment in the start.gcode worked for me. I am using French also..

    Thanks for the Great Support !

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    Same here, my brother removed the "at: {day} {date} {time}" on his setup and it works fine again!

    Thanks!

  • Link to post
    Share on other sites

    Posted · Project planner stops early

    Also fixed this for the next release :-) it will no longer stop slicing, and replace none-ascii chars with a question mark (best I can do right now, most of the code is build around ascii strings instead of unicode strings)

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...