Jump to content
Ultimaker Community of 3D Printing Experts

Problems with Cura: Generating incomplete Gcode files


Recommended Posts

Posted (edited) · Problems with Cura: Generating incomplete Gcode files

Hello Community!

I am new to the 3D printing community and I am having problems in generating complete Gcodes withCura 15.04.6 and  this 3d model.

As you can see in the attached image there's a part of the gcode of the 3d model, mainly in part where it has to support that its not generating the layers and supports to print. I have an Hephestos Prusa I3 Xl and the model is mainfolded and fixed at Netfabb. When I generate the gcode at Cura it is correct but when I open the gcode to check the file it is always this kinds of errors . What am I doing wrong or what I could do be able to generate the gcode properly?

Thanks in advance

My best regards

Adolfo

5a331e984c269_gcodewithproblems1.thumb.jpg.da31d05a8d8ef290e65dc25e50d7dfe4.jpg

5a331e981838e_gcodewithproblems.thumb.jpg.247a7a6556ba90c92dac8bb29528821b.jpg5a331e986901f_gcodewithproblems2.thumb.jpg.ed10343d4698638001e06ba022e4c0fe.jpg

Edited by Guest
  • Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    I don't see the problem. Maybe zoom in to the "problem" area? You can print vertical things with no support. You can tilt that vertical to 45 degrees from vertical and still - no support needed - you will get a perfect surface. You can tilt further to 60 degrees from vertical. Now the surface is getting a bit rough but still the quality is probably better than if you added support and then broke off the support. You can tilt further to 75 degrees and now the quality is definitely getting worse but still about the same as if you had support so why waste time printing support? You can tilt further to 80 degrees from vertical (10 degrees from horizontal) at this point it will still print but you will have much better results with support. If you tilt further to 85 degrees from vertical (5 degrees from horizontal) now you definitely want support.

    In summary you don't need support for surfaces tilted only 45 degrees from vertical. Cura has advanced settings that let you change this angle.

    • Like 1
    Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    Hello gr5!

    Thanks fot your answer!

    In the images you can see that the gcode doesn't touch the base. There is a gap withou the layers between o and 50. I am trying to reduce the printing time.

    I'm sending you the gcode if you want so you can see the problem. I've tried to put things in vertical but I have fear that it will loose the form because of heat. Also my teacher explained me to print it in horizontal . As you can see in the attached file i pointed out in orange colour the defects of the gode file ate the base of the sculpture. You can see the missing parts coloured in yellow and green. It has some wings that need to have supports.

    5a331ea33e266_gcodewithproblems2.thumb.jpg.1edc5177236c8b211f9c0cbb29e89749.jpg 5a331ea38a678_gcodewithproblems3.thumb.jpg.424567019f552ecfbc0437558b0f4bff.jpg 5a331ea3b2b79_gcodewithproblems.thumb.jpg.fa7e291544016c25ccf30b23c9956ca5.jpg

    Hope my explanation was clarifying.

    Thanks in advance.

    My best regards

    Adolfo

     

    I don't see the problem.  Maybe zoom in to the "problem" area?  You can print vertical things with no support.  You can tilt that vertical to 45 degrees from vertical and still - no support needed - you will get a perfect surface.  You can tilt further to 60 degrees from vertical.  Now the surface is getting a bit rough but still the quality is probably better than if you added support and then broke off the support.  You can tilt further to 75 degrees and now the quality is definitely getting worse but still about the same as if you had support so why waste time printing support?  You can tilt further to 80 degrees from vertical (10 degrees from horizontal) at this point it will still print but you will have much better results with support.  If you tilt further to 85 degrees from vertical (5 degrees from horizontal) now you definitely want support.

    In summary you don't need support for surfaces tilted only 45 degrees from vertical.  Cura has advanced settings that let you change this angle.

     

    5a331ea33e266_gcodewithproblems2.thumb.jpg.1edc5177236c8b211f9c0cbb29e89749.jpg

    5a331ea38a678_gcodewithproblems3.thumb.jpg.424567019f552ecfbc0437558b0f4bff.jpg

    5a331ea3b2b79_gcodewithproblems.thumb.jpg.fa7e291544016c25ccf30b23c9956ca5.jpg

  • Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    I didn't get any gcode files. Maybe post it on dropbox or google driver or somewhere and post a link to the gcode file here on the forum. On the right of your screen there is a slider. Try sliding it down to the "missing" layer area. Is it possible that it *will* print on those areas but it simply isn't showing it visually? You can tell by sliding the layer view down to those layers. It was my impression that the "empty" layers was just an affect of the angle and if you rotated the view or zoomed in a bit you would see it's fine.

    If it truly is a blank layer like you say, then try looking at the model in xray view. Any red areas are a problem. You might be able to fix it by going to the expert settings and there are 4 checkboxes in the "fix horrible" section. Try "combine everything" both type a and b. if that still doesn't work try type A or type B (never both) in combination with the other 2 checkboxes. I know - there's 11 possible configurations (never check A and B both). Sorry.

  • Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    Hello Gr5!

    Thank you for your answer!

    I`ve checked the model in xray view and i doesn`t have any issues coloured in red. I'm sending you the model in stl file and the gcode file so you can see what I am talking about.

    I'm going to generate the gcode with the adjustments checkin the fix horrible section inside the expert menu. Thanks for your instructions. I'm sending dropbox links of both the stl file here:

    Stl File Here:

    https://www.dropbox.com/s/rt441w9y875us07/Alegoria%20de%20la%20Victoria_fixed.stl?dl=0

    Gcode file Here:

    https://www.dropbox.com/s/rfsen7vuvy2a0jh/Alegoria%20de%20la%20Victoria_fixed.gcode?dl=0

    My best regards

    Adolfo

    I didn't get any gcode files.  Maybe post it on dropbox or google driver or somewhere and post a link to the gcode file here on the forum.  On the right of your screen there is a slider.  Try sliding it down to the "missing" layer area.  Is it possible that it *will* print on those areas but it simply isn't showing it visually?  You can tell by sliding the layer view down to those layers.  It was my impression that the "empty" layers was just an affect of the angle and if you rotated the view or zoomed in a bit you would see it's fine.

    If it truly is a blank layer like you say, then try looking at the model in xray view.  Any red areas are a problem.  You might be able to fix it by going to the expert settings and there are 4 checkboxes in the "fix horrible" section.  Try "combine everything" both type a and b.  if that still doesn't work try type A or type B (never both) in combination with the other 2 checkboxes.  I know - there's 11 possible configurations (never check A and B both).  Sorry.

     

  • Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    Hello!

    Could anyone please help me ?

    I'm not been able to solve the problem. The code and stl files are in another message so you could see the problem,

    Thanks in advance.

  • Link to post
    Share on other sites
    Posted (edited) · Problems with Cura: Generating incomplete Gcode files

    Hi Adolfo,

    First off, welcome to the community :)

    I downloaded one of your models and set it up in Cura 15.04.5. The question I have is - why do you rotate your model to print on its side rather than on the flat base? If you print your models instead with the flat base facing downwards, you'll have better quality overall and can reduce the amount of supports needed. Just my $0.02.

    Anyway, after I loaded your model in I checked layer view and it seems to be fine. I would guess the problem is the supports needed when you try to print it on its side. Too many, or too thin for the nozzle to make? I'm not sure. But it looks like it will work fine standing upright on the flat base. Here's a screenshot:

    adolfo1.thumb.png.f109a58d5eb63174c7628758693893c6.png

    Hope this helps!

    adolfo1.thumb.png.f109a58d5eb63174c7628758693893c6.png

    Edited by Guest
    said I was using 15.04.6 but it's really 15.04.5 ;)
  • Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    There are no missing layers. I looked at your gcode file using "repetier host" which has better graphics and you can see there are no missing layers. You just have a very very large gcode file so I suppose cura has trouble displaying things clearly and quickly. If you had used the layer viewer scroller like I suggested and scrolled to the "missing" layers and waited a minute you would have seen that there is nothing missing. Here is a screen shot from repetier host of your file on dropbox:

    a.thumb.png.b50faa7b9e4cd151087cbe89db10ef0d.png

    a.thumb.png.b50faa7b9e4cd151087cbe89db10ef0d.png

  • Link to post
    Share on other sites
    Posted (edited) · Problems with Cura: Generating incomplete Gcode files

    However you also used support pattern "lines".  I think that's the default.  That doesn't work very well for more than 1cm height as they fall over.  I suggest you use pattern "grid".  Concentric is okay also.  Generating these supports is slow in cura 2.1.2 so you might want to try cura 14.X.X.

    b.png.edbf2de9a374f1baed9b79219bd517d0.png

    Also you might want to reduce the size of your stl.  It has many more triangles than needed for your model unless your printer is 5 meters wide!  So this isn't necessary but it will speed up your slicing step and probably speed up your printing also:

    http://www.shapeways.com/tutorials/polygon_reduction_with_meshlab

    b.png.edbf2de9a374f1baed9b79219bd517d0.png

    Edited by Guest
  • Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    Before taking Remy's advice about standing uprgight - slice it both ways and see which takes more time to print. Certainly the quality will be better upright.

    Also I recommend printing this small at first as you seem to be new to 3d printing and it takes lots of practice to be really good and get perfect models every time. The most common problem is not leveling the bed higher than recommended - you want the plastic to squish into the glass so the models stick well.

    • Like 1
    Link to post
    Share on other sites
    Posted · Problems with Cura: Generating incomplete Gcode files

    Hello Remy!

    Thank you for your answer. I've been away from the computer so I couldn't answer before. I print the model that way because my teacher in the 3d printing course told me that it will be faster that way. The problem I have found is that at the moment of looking at the gcode file in different computers the layers appear and dissappear depending on which computer I see them. It is very strange and I don't know what could be happening.

    Anyway, I really appreciate your answer and thank you a lot for that.

    My best Regards

    Adolfo

     

    Hi Adolfo,

    First off, welcome to the community :)

    I downloaded one of your models and set it up in Cura 15.04.5. The question I have is - why do you rotate your model to print on its side rather than on the flat base? If you print your models instead with the flat base facing downwards, you'll have better quality overall and can reduce the amount of supports needed. Just my $0.02.

    Anyway, after I loaded your model in I checked layer view and it seems to be fine. I would guess the problem is the supports needed when you try to print it on its side. Too many, or too thin for the nozzle to make? I'm not sure. But it looks like it will work fine standing upright on the flat base. Here's a screenshot:

    adolfo1.thumb.png.f109a58d5eb63174c7628758693893c6.png

    Hope this helps!

    [/quot

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...