Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

Raspberry Pi won't connect to 3D Printer

Recommended Posts



I've recently purchased a Ultimaker, and while it works fine on my Windows machine, I just can't for the life of me get the Raspberry Pi to talk to it properly. The printer is running the Marlin firmware (whichever version is installed by Cura 12.10).

I've done a fresh install of Raspbian (October release, was latest at the time), and tried several different programs to connect to the printer - sendg (via Mono), printerface (pronsole.py), pronterface, Cura (which crashes in the UI), austerusG, and had no success.

After that round of failures, I've tried doing apt-get update and apt-get dist-upgrade. I've also run rpi-update. Same results on all five programs.

The printer is supposed to be at /dev/ttyACM0, and it does exhibit some reaction when I first open the port to it (it makes sounds as if motors are making a very subtle movement), but I receive a bunch of gibberish as response and none of the programs behave as expected. I've tried connecting with baud rates 115200, 230400 and 250000 (which is, I understand, the ideal baud rate). 250000 seems to behave differently, crashing the pronsole.py immediately (no error messages, it just immediately terminates) instead of estabilishing a borked connection. I've also tried overclocking the UART by 1.085x and connecting at 230400 (which would then actually be 250000), but that didn't work either (I've since reverted that change). I have not tried patching the printer firmware because it's my understanding that it shouldn't matter (though correct me if I'm mistaken) and I didn't want to risk causing issues on Windows as well.

The hardware setup is a Model B Raspberry Pi (256 MB version) with an 8 GB SDHC Sandisk card, an Edimax EW-7811UN wireless adapter connected to the top USB port and a powered USB hub on the bottom USB port. The printer is connected to the powered hub. I'm SSHing into the RPi, though I've also tried keyboard and monitor, to no success.

Lots of people seem to be able to drive their Ultimakers with the Raspberry Pi, and I don't seem to be doing anything particularly different from their instructions...

Share this post

Link to post
Share on other sites

UM1 or UM2?

Have you installed the pyserial patch that allows the Pi to communicate at 250000 baud? That was what my UM1 did before I installed the patch. I've heard it now comes preinstalled with some things, but probably worth a shot.


This or installing the custom 115200 baudrate firmware. (from Cura/resources/firmware)


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 122 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!