Jump to content
Ultimaker Community of 3D Printing Experts
lance-greene

cura generating infill when infill is set to 0

Recommended Posts

Ah I only just noticed its not verticle.

Its not infill its top/Bottom layers

You would have to use something like the swap at z plugin where you set the model to have top/bottom layers on, then use swap at z to turn it off after the bottom layers has finished, then use it again to turn it back on for the top layers.

Or use a g code modifier.

Share this post


Link to post
Share on other sites

Wow - Lances talking to each other.

I don't know any good way to turn off top/bottom infill in one part of the print but turn it on in another, sorry. I guess I don't understand what the problem is. If you want the walls top be thinner you can just set the top/bottom thickness to be thinner - set it to one layer height and that might remove the infill you want to remove. But then maybe your walls are nice and thin but your top/bottom is too thin? I don't know exactly what the issue is. Are you just trying to speed up the print a little? There's other ways to speed up a print. Or is this extra thick walls causing a problem with quality somehow?

Share this post


Link to post
Share on other sites

yes that infill is causing nasty looking scars to show up on the outside of the print. it seems odd that the solid infill function fixes this, when this problem is present for the first 40 layers or so all the way up until the part starts printing straight vertical. you cans see how the part is building up on an angle, this forced infill persists all the way until that angle stops and it starts printing vertical, it seems on that the solid infill function can produce features that persist all the way up the part that high.

Share this post


Link to post
Share on other sites

I was about to suggest making the shell width 2 passes (.8mm) to hide this but then realized you are already printing something very thin.

You could try cura 2.1.X as it has 3 options related to this (which are all on by default). Although I'm not sure that this feature already existed (all 3 forced turned on):

a.png.a5f00213d8916f7a5def186eb10355cb.png

The idea is that if there is infill between 2 walls and there isn't enough space it doesn't do 100% flow but instead does the amount of flow that will fit. Not sure this will do anything though if cura thinks of this as "bottom". That might explain everything - when you do 100% fill it probably does less than 100% flow - it does just the right amount. When infill is off and it considers this "bottom" it doesn't do the nice algorithm.

Hmm.

What's wrong with 100% infill? You can break up your part into sections and only do 100% flow in the walls if that helps. It's tricky - you need to break it up into cad - do different settings for each part and then merge it back together. Cura 2.X does this but not Cura 15.X. Or is 100% infill also bad?

a.png.a5f00213d8916f7a5def186eb10355cb.png

Share this post


Link to post
Share on other sites

I've been using cura 15.X to do all of my slicing as I wasn't a fan of 2.X when it came out. I'll try the new one with the update that just came out (2.1.3 I believe was just released) and I'll try those settings.

the part has been designed specifically to print hollow (0 infill) and using infill produces more of these negative qualities that we are trying to avoid. a few hundred of this part will be printed so it has been optimized to print as quickly as possible. All the kinks have been worked out except this 1 issue.

Thanks for all the help so far! I'll give the new cura a slice and check it out

Share this post


Link to post
Share on other sites

Doing that does remove the extra infill but I don't think it's something you'd want to do in most cases since so much of the strength in the part comes from the solid top/bottom.

I've been thinking about it for a while now but I can't come up with a way to remove it without getting fancy and splitting the model. Which annoys me, because I could've sworn I heard/read about it somewhere...

Share this post


Link to post
Share on other sites

Lance there is another option - you can split your model up into 3 parts (top, bottom, walls) and give each section a different set of parameters. This is especially worth your trouble if you are printing lots of these. I have never done this but it's a feature somewhat hidden in cura 2.1.X. First split the model into 3 with CAD. Then open all 3 pieces in Cura and on the left you can set different settings for each part. Then you "merge" the 3 pieces and Cura automatically knows exactly how to assemble them (because they are still referenced to 0,0 in CAD).

Share this post


Link to post
Share on other sites

Thanks for all the help guys.

the reason that infill was causing a problem was it was causing heat buildup and the part was starting to sag and get gloppy in those areas. we tried a lot to reduce the heat build up but were never able to fully solve the problem until the other day, we finally got a setup that is cool enough that the heat buildup is not a problem anymore and the part is 98% perfect.

98% is okay for us haha.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!