Jump to content

builplate UM2 stucks


Recommended Posts

Posted · builplate UM2 stucks

Hello, today my buildplate doesn't lower anymore ...

Tried to make 2 prints and each print: the buildplate got stuck at a different hight ...

Yesterday everything was ok ....

What could be wrong?


  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    So homing fails?

    Or homing works but plate stops moving at a certain height and you get a massive ball of filament on the "final" layer? or it only gets stuck a few layers and then starts moving again?

    Photo would help.

  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    yo, tried 3 prints. At different hights buildplate stopped lowering. So print continued at same level (pic)IMG_20160823_160855.thumb.jpg.d07c1b2f20129171c113119d7210b313.jpg.

    After third try-out print got error message: x-axis stuck....


  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    I don't understand why the homing procedure would move it right past this spot but when printing it gets stuck.

    Is this a UM2? If it's a UMO or UM2 you should be able to push the bed up and down by lifting and pushing at the back of the bed near the z-screw. It takes quite a bit of force - about the amount needed to lift the machine. Once it starts moving it doesn't need as much force. Pushing down is much easier.

    See if you feel something wrong. Maybe the screw isn't fully attached to the Z stepper? I've heard of prints not moving for maybe 1 or 2 layers in Z but they usually start moving again after 2 layers of moving less than nominal.

  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    We're talking about a UM2.

    Manually moving the buildplate up and down is no problem.

    Problem is: at some hight (different from print to print) the printing continues at the same hight.

    And most strange of all: the printing follows the model ...

    The plate doesn't lowers all of a sudden during the print.

    There is no clog initially but after some laps printing at the same hight a clog is growing at the nozzle.

  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    You are the first person to have this issue that I know of. And I think I've read every post on this forum for the last few years.

    Bad wire to the Z stepper motor? Oh - the Z stepper driver can possibly overheat. Are you in a hot climate? is it much hotter than 21C where you are? I wouldn't think Belgium is that hot. Usually when the Z stepper overheats it only shuts off for 1 second and then starts back up no problem. There is a "fix" where you lower the current to the Z stepper. This fix is in the latest firmware. I don't think this is the problem though.

    I would hook a USB cable between a computer and your printer and install pronterface (it's free):


    Connect to the printer with that and command the Z to home and then go to position zero:

    G0 Z20

    G0 Z10

    G0 Z0

    G0 Z1

    G0 Z2

    G0 Z2.2

    The above commands tell the Z to move to various positions. Start with 30 to be safe (not sure if the head hits the glass around Z=20 or around Z=0. Probably Z=0.

    See if you can get the problem to duplicate. See if it's just sticky and starts moving again - or if the Z is completely electrically silent - when servo is off you should be able to push gently down on the bed and it should slide easily.

    I'm guessing the Z stepper is fine (but not certain!) and there's something wrong with the Z screw - it may need cleaning. Or maybe the two vertical rods and bearings are bad and jam up but you said it felt fine so that seems unlikely even though this is a very common problem.

    Z screw issues are also a common problem but it doesn't stop for 3 layers usually - usually the Z stops moving only 1 layer or moves half a layer height instead of the whole thing. You really need to isolate this problem into mechanical or electrical.

  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    I rember past summer my Z started yo do some weird stuff like moving half the distance per layer during print and you could hear the bed sound trying to finish the move. But that was at a room temp of 30C. Using the airconditioning system on the room fixed that issue. This year I prepared myself using heatsinks on the stepper chips. No issues again even at 28C

  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    Hi, i'm back. Was very busy last days.

    Indeed, the room was very hot ... (heatwave).

    Next week I will figure out what went wrong taking all remarks in mind ...

    My supplier is willing to do the repair ... but I want to do it myself if possible.

    I'll share my solution when UM is fixed.

  • Link to post
    Share on other sites

    Posted · builplate UM2 stucks

    Well you can adjust the current to the Z stepper. In fact there is a firmware patch that does just this as the latest boards for umo+ and um2 have an issue with the stepper drivers.

    This command adjusts the current (until you power cylce the machine):

    M907 Z900

    I think the current used to be 1200ma and now I think 900ma is recommended. To save permanently you need:


    Which saves to permanent memory so you can power cycle and the setting is saved.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • 🎄✨ Thingiverse Tree Ornament Challenge! ✨🎄
        We've been running a Tree Ornament Challenge with a chance to win an UltiMaker S3 or colorFabb filament.
        Design a 3D printable tree ornament and join our festive challenge on Thingiverse. 🎁✨

        📆 Submission Deadline: December 22
        🏷️Tag your designs with Holidays2023

        Click here to join and check out the over 300 other amazing designs

        How to Enter
        Design an Ornament
        Create a 3D printable tree ornament that captures the magic of the winter season. Think snowflakes, sleighs, reindeer, cozy mittens, or anything that embodies the joy of the holidays. Upload to Thingiverse
        Share your masterpiece on Thingiverse and add the tag Holidays2023. Don't forget to include a captivating description and images that showcase your design from different angles. Submit by December 22
        All entries must be submitted by December 22nd to be eligible for consideration.
          Entering a new design
        Entering an existing design
        Winning designs should:
        Be original Creations
        Your designs should be original works, avoiding the use of others' intellectual property without permission. Include STL Files
        Each submission must include at least one STL file for 3D printing. Showcase a Completed Print
        Provide at least one photograph featuring a completed print of your design. Include Documentation
        Share the creative journey! Include documentation of your design process, giving us a peek behind the scenes. For example, show a screenshot of the model in your design program. Use the Tag Holidays2023.
        Use this tag to ensure your entry is counted in the Tree Ornament Challenge. Be submitted after October 1st, 2023
        Ensure your design was uploaded to Thingiverse after October 1st, 2023. Adhere to Submission Guidelines and Terms of Service
        Make sure your submission aligns with our guidelines and Thingiverse's Terms of Service.  
        Good luck 🎉
        • 1 reply
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 15 replies
    • Create New...