Jump to content
Ultimaker Community of 3D Printing Experts
ffreak

builplate UM2 stucks

Recommended Posts

So homing fails?

Or homing works but plate stops moving at a certain height and you get a massive ball of filament on the "final" layer? or it only gets stuck a few layers and then starts moving again?

Photo would help.

Share this post


Link to post
Share on other sites

I don't understand why the homing procedure would move it right past this spot but when printing it gets stuck.

Is this a UM2? If it's a UMO or UM2 you should be able to push the bed up and down by lifting and pushing at the back of the bed near the z-screw. It takes quite a bit of force - about the amount needed to lift the machine. Once it starts moving it doesn't need as much force. Pushing down is much easier.

See if you feel something wrong. Maybe the screw isn't fully attached to the Z stepper? I've heard of prints not moving for maybe 1 or 2 layers in Z but they usually start moving again after 2 layers of moving less than nominal.

Share this post


Link to post
Share on other sites

We're talking about a UM2.

Manually moving the buildplate up and down is no problem.

Problem is: at some hight (different from print to print) the printing continues at the same hight.

And most strange of all: the printing follows the model ...

The plate doesn't lowers all of a sudden during the print.

There is no clog initially but after some laps printing at the same hight a clog is growing at the nozzle.

Share this post


Link to post
Share on other sites

You are the first person to have this issue that I know of. And I think I've read every post on this forum for the last few years.

Bad wire to the Z stepper motor? Oh - the Z stepper driver can possibly overheat. Are you in a hot climate? is it much hotter than 21C where you are? I wouldn't think Belgium is that hot. Usually when the Z stepper overheats it only shuts off for 1 second and then starts back up no problem. There is a "fix" where you lower the current to the Z stepper. This fix is in the latest firmware. I don't think this is the problem though.

I would hook a USB cable between a computer and your printer and install pronterface (it's free):

http://koti.kapsi.fi/~kliment/printrun/

Connect to the printer with that and command the Z to home and then go to position zero:

G0 Z20

G0 Z10

G0 Z0

G0 Z1

G0 Z2

G0 Z2.2

The above commands tell the Z to move to various positions. Start with 30 to be safe (not sure if the head hits the glass around Z=20 or around Z=0. Probably Z=0.

See if you can get the problem to duplicate. See if it's just sticky and starts moving again - or if the Z is completely electrically silent - when servo is off you should be able to push gently down on the bed and it should slide easily.

I'm guessing the Z stepper is fine (but not certain!) and there's something wrong with the Z screw - it may need cleaning. Or maybe the two vertical rods and bearings are bad and jam up but you said it felt fine so that seems unlikely even though this is a very common problem.

Z screw issues are also a common problem but it doesn't stop for 3 layers usually - usually the Z stops moving only 1 layer or moves half a layer height instead of the whole thing. You really need to isolate this problem into mechanical or electrical.

Share this post


Link to post
Share on other sites

I rember past summer my Z started yo do some weird stuff like moving half the distance per layer during print and you could hear the bed sound trying to finish the move. But that was at a room temp of 30C. Using the airconditioning system on the room fixed that issue. This year I prepared myself using heatsinks on the stepper chips. No issues again even at 28C

Share this post


Link to post
Share on other sites

Hi, i'm back. Was very busy last days.

Indeed, the room was very hot ... (heatwave).

Next week I will figure out what went wrong taking all remarks in mind ...

My supplier is willing to do the repair ... but I want to do it myself if possible.

I'll share my solution when UM is fixed.

Share this post


Link to post
Share on other sites

Well you can adjust the current to the Z stepper. In fact there is a firmware patch that does just this as the latest boards for umo+ and um2 have an issue with the stepper drivers.

This command adjusts the current (until you power cylce the machine):

M907 Z900

I think the current used to be 1200ma and now I think 900ma is recommended. To save permanently you need:

M500

Which saves to permanent memory so you can power cycle and the setting is saved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy