Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up
Nooger

How to set IP address without WiFi or DHCP

Recommended Posts

Posted · How to set IP address without WiFi or DHCP

Any ideas why this results in error:

connmanctl config ethernet_ccbdd30035dl_cable --ipv4 manual 138.208.11.208 255.255.255.0 138.208.11.254
Error ethernet_ccbdd30035dl_cable: Method "SetProperty" with signature "sv" on interface "net.connman.Service" doesn't exist

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

Update to previous post. SSH worked great to set static IP. My issue was a simple syntax error. The number 1 looks exactly like a lower case l in the PuTTY interface. Thanks freesbee.

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

@Daid, I think this is what we are asking for. handle the WIFI and Eth as you do, separately. But have a toggle on the touch GUI to use DHCP as normal or to use static IP that is manually configured, one for each interface separately (WIFI could be DHCP and Eth could be Static IP, or any other combination). user settings would be, IP Address, Subnet Mask, and Default Gateway.

 

Thoughts?,

 

Cheers,

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

Is there any progress on this topic?

 

We are using the S5 in a university environment and are totally disappointed by the lack of a possibility to set ethernet parameter manually. It's not uncommon to set IP, Gateway, Subnet etc. manually in a university/company network. I really don't get it, why this function is missing in a 6000$ machine while being standard for 99% of 3D printers. Sorry for being harsh, but we just need to get this thing working in our network. We can't buy more if there's no solution although they make good results.

 

Where do I have the best chance to set IP, Gateway, Subnet etc.? 🙂 Do you have any tips or recommendations? 

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

I know.  It sucks.  Sorry.

 

There's lots of ways to do this - none of them from the front panel on the S5.

 

One option is to take the printer to a network somewhere that has DHCP.  Make sure the printer is in "developer mode".  You can then ssh into the printer (username/password = root/ultimaker).  Then you can use connman to setup any tcp/ip settings you can possibly imagine both for wired and wireless.  There is tons of info on connman if you google.

 

Another option is to use a crossover cable and connect the printer to a computer directly where both are off network.  You have to have the computer support DHCP server though so the printer can get an ip address.

 

Note that when the printer has an IP address it will display this address on the top of the screen on the printer.  As long as you are in "developer mode".

 

You could use a small hub instead of a crossover cable.

 

You could take it home and plug it into a home ethernet network.  Or a home wireless network.

 

But there is no way to do this from the front panel.

 

Note that there is more information on connman on page 1 of this topic.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP
9 hours ago, gr5 said:

I know.  It sucks.  Sorry.

 

There's lots of ways to do this - none of them from the front panel on the S5.

 

One option is to take the printer to a network somewhere that has DHCP.  Make sure the printer is in "developer mode".  You can then ssh into the printer (username/password = root/ultimaker).  Then you can use connman to setup any tcp/ip settings you can possibly imagine both for wired and wireless.  There is tons of info on connman if you google.

 

Another option is to use a crossover cable and connect the printer to a computer directly where both are off network.  You have to have the computer support DHCP server though so the printer can get an ip address.

 

Note that when the printer has an IP address it will display this address on the top of the screen on the printer.  As long as you are in "developer mode".

 

You could use a small hub instead of a crossover cable.

 

You could take it home and plug it into a home ethernet network.  Or a home wireless network.

 

But there is no way to do this from the front panel.

 

Note that there is more information on connman on page 1 of this topic.

 

@gr5 Thank you very much for your help! I appreciate it 🙂 I will try the connman approach now

Share this post


Link to post
Share on other sites
Posted (edited) · How to set IP address without WiFi or DHCP

So, I connected to printer via ssh, which works fine and shows the "Ultimaker" logo but when I execute

connmanctl services

I don't get any result. Just an empty line. So is there no connmanctl service or did i do sth wrong? I only entered via ssh and typed in the command above. I attached a screenshot.

 

Thanks for your help in advance!

 

@freesbee do you have an idea?

 

EDIT: So I was able to enter connman tool, look at "help" etc. but for some reason, no service is running. I tried to enable ethernet via

 

connman enable ethernet

and it says

Enabled ethernet

but it is still:

Powered = False
Connected = False
Tethering = False

 

ultimaker_conn.png

Edited by frowin

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

...sorry, I'm on vacation several thousand miles away from where I could test anything on the printer, not even which firmware version I have on. I am afraid that you need to ask to the guy who is responsible of firmwares at Ultimaker @Daid (well, if he didn't correct such a problem after one year of time I wouldn't know what to expect... it's quite embarrassing...).

BTW I am not a big fun of connection manager... it's normally one of the first things that I disable on my linux machines.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

I finally (after some hours) managed to get it run now. What I did:

 

1. I took a computer, installed DHCP and connected it directly to printer via cable (so that the printers gets any IP, doesn't matter which)

2. I used ssh to connect to the printer via cable with this computer (running DHCP)

3. I found out service-id with

connmanctl services

4. I executed the following command

connmanctl config <service> --ipv4 manual <IP address> <netmask> <gateway>

and it worked! Hopefully I didn't miss a step above...

 

After reboot (with developer mode turned off) it keeps the static IP settings. So for us, everything works fine except the "Cloud" functionality. But this does not work for our Formlabs either (maybe some ports blocked by university or so).

 

We wasted a lot of time with finding out the service-id of ethernet connection. It seems like, there is no service running if 1. no cable is connected, 2. there is no DHCP server providing IP and 3. you use ssh via "Wifi configuration mode". I'm not sure whether point 3 is just a coincidence or not. For me, ssh connection via cable worked and via wifi not (but that does not mean anything, I'm not a network/linux guy).

 

Thank you very much @freesbee and all others for the tutorials in this thread 🙂

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP
17 hours ago, freesbee said:

I am afraid that you need to ask to the guy who is responsible of firmwares at Ultimaker @Daid (well, if he didn't correct such a problem after one year of time I wouldn't know what to expect... it's quite embarrassing...).

I'm no longer responsible for the firmware at Ultimaker. As I left Ultimaker 2 months ago. Didn't make a huge fuzz about it. But I left to focus more on my family. The travel time to Ultimaker was no longer acceptable for me anymore.

 

Also, I suggested to develop a feature to import/export network settings to a text file on USB to handle all "odd" configuration options. But it never got priority.

 

 

 

And:

connman enable ethernet

Won't do anything, because the network managment service that is part of the firmware will disable it again, which is linked to the printer settings network configuration. So enabling cabled connection in the firmware menu, will enable the ethernet in connman.

  • Like 1
  • Thanks 4

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP
59 minutes ago, Daid said:

I left Ultimaker 2 months ago

 

Thanks for the passion you brought to all the things you did over the years!

  • Like 9

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

   __  ______  _                 __
  / / / / / /_(_)___ ___  ____ _/ /_____  _____
 / / / / / __/ / __ '__ \/ __ '/ //_/ _ \/ ___/
/ /_/ / / /_/ / / / / / / /_/ / ,< /  __/ /
\____/_/\__/_/_/ /_/ /_/\__,_/_/|_|\___/_/
Welcome to our kingdom. Please be responsible.
(Cmd) 
 

 

I'd like to repeat above procedure, but I get different prompt and commands are not working.  I use username and password "ultimaker". Printer is S5. Where is a mistake?

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP
1 hour ago, Sandi said:

I'd like to repeat above procedure, but I get different prompt and commands are not working.  I use username and password "ultimaker". Printer is S5. Where is a mistake?

 

You used the wrong username, that's all. Follow point 2 of the instructions more careful:

 

https://community.ultimaker.com/topic/15804-how-to-set-ip-address-without-wifi-or-dhcp/?do=findComment&comment=215658

 

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

root@ultimakersystem-ccbdd3008xxx:~# ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1372 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1372 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:557981 (544.9 KiB)  TX bytes:557981 (544.9 KiB)

tether    Link encap:Ethernet  HWaddr 00:0E:8E:8A:1C:A1
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::bc4c:ff:fe92:d90f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:989 errors:0 dropped:0 overruns:0 frame:0
          TX packets:523 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:87614 (85.5 KiB)  TX bytes:78325 (76.4 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:0E:8E:8A:1C:A1
          inet6 addr: fe80::20e:8eff:fe8a:1ca1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:988 errors:0 dropped:0 overruns:0 frame:0
          TX packets:904 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:101440 (99.0 KiB)  TX bytes:141143 (137.8 KiB)

 

root@ultimakersystem-ccbdd3008xxx:~# connmanctl


Error getting VPN connections: The name net.connman.vpn was not provided by any                 connmanctl>
connmanctl> exit
root@ultimakersystem-ccbdd3008xxx:~# connmanctl services

 

root@ultimakersystem-ccbdd3008xxx:~# ls


root@ultimakersystem-ccbdd3008xxx:~#
 

 

 

ls command also not working. Should I see eth0?

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP
On 2/28/2017 at 10:00 AM, Daid said:

Not to sound harsh, but I rather work on the solution so this works for everyone. (I'm the guy in charge of firmware at Ultimaker)

 

Hi there, is there any conclusion to this thread?. We have the UM5 in office. It is connected via LAN to the company LAN. We are behind firewall and use windows. What exactly do I need to ask my IT manager to be able to see and eventually stop the printing process from home, preferably simply via the chrome browser on my cell phone?

(The question was originally posted here:https://community.ultimaker.com/messenger/19286/?tab=comments#comment-33879)

I have tried the cloud but it appears not to work as expected. Cant see printing process and cant stop printer. When I'm in office it works perfectly through Cura. However these features are mostly relevant if we let the printer work after hours so the printjob can be monitored from home. 

We have contacted the dealer which bounces the problem to our IT department, which bounces it to us.

Any help is greatly appreciated.

Best Regards

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

@thorsenrune

 

If you can monitor from your PC at work, LAN connection inside your company is fine. I assume, that you can also access the dashboard of the printer via its IP address.

 

Did you connect your printer to Cura "cloud"? If so, it's maybe the same problem as within our network. The Ultimaker needs specific ports for communication with Ultimaker-Servers. The camera stream needs port 8080 for example. In our network all these ports are blocked so the Ultimaker cannot call home. If its a similar problem with your printer, you need to ask your IT-department to unlock these ports (its like 2-3 or so). You could also tell them to unblock them only for specific addresses (Ultimaker-Server only). I don't know whether I have noted the ports and addresses anywhere ... but one can easily ask for them.

 

I hope I understood your question right, if not, tell me 🙂

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

Yes I can connect fine to the printer within the network. 

I downloaded the Android App for cloud which apparently is not functional yet.

On the cloud I can see the print status but not the webcam and I can't stop the printer. Is it a functionality that should be there or is it pending?

Thanks for your reply in advance.

Rune

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP
1 hour ago, thorsenrune said:

On the cloud I can see the print status but not the webcam and I can't stop the printer.

I am not sure about the abort function, I think it should be possible, but not sure. 

The webcam is not working currently via the cloud, but it is planned.

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

So the conclusion is that only by making the 'NAT' connection we can monitor the UM5!?

Is there anyway to make a password access to the printer ( which is the worry of our IT admin).?

Best Regards

Rune 

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

No, NAT is the worst solution, you open your printer to the world if do that and there is no user authentication.

The best solution and the most secure one, is to use VPN to your network. Talk to your IT Admin I guess he will be happy with this solution.

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

It appears that the IT department has solved the problems. Video and control from cellphone works

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

Just closing the topic. It now works perfectly. The IT department has set up a DNS Record and a Reverse Proxy so when we put in or credentials we can access the webcam and control the printer. Very nice.  It took some time so I would probably be good to have the procedure described in detail somewhere.

Made some really nice dual extrusion prints that puts our Olivetti 3D S3 to shame.

Cheers

Rune

Share this post


Link to post
Share on other sites
Posted · How to set IP address without WiFi or DHCP

As this seems to be the one post every one else is referring to for setting up a static IP address for the cable bound LAN port and as it is mid 2020 by now and still the firmware does not allow (yet) to set a static IP/Mask via the panel I would like to push up the prio of this feature (which is hopefully still on the dev-list) a little bit:

+1

 

thanks,

Tiger

 

PS: as yes, there are secure company networks that do not allow WLAN nor DHCP servers. Still. :-)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...