Jump to content



Recommended Posts


I want to use my Ultimaker with Octoprint.

Everything works accept of the extruder.

No filament comes out.

I tried to change the settings with an intruduction from the Ultimaker community:


Hope you can help I you need further informations please ask.



  • Link to post
    Share on other sites

    Also see the ReadMe for the OctoPrintPlugin here:



    The Ultimaker 2(+) family uses a flavor of GCode named UltiGCode. Unfortunately printing using UltiGCode flavor does not work when printing over the USB connection. That is why using OctoPrint does not work with UltiGCode flavor.

    For the Ultimaker 2/Ultimaker 2 Extended, you can use "Machine Settings" on the "Printers" pane of the preferences to change your GCode flavor to "RepRap (Marlin/Sprinter)".

    The Ultimaker 2+/Ultimaker 2 Extended+ currently don't support "Machine Settings". You can use one of these alternative printer definitions instead:



    Ultimaker2 Extended+


    Copy these files into the resources/definitions folder of your Cura application. Restart Cura and add a new printer. You should see the option to add a Ultimaker 2+ (RepRap) and/or Ultimaker 2 Extended+ (RepRap) (depending on which file(s) you installed.


    Cura 2.4 will have support for Machine Settings with the UM2+ so it is easier to set the gcode flavor.

    • Like 2
    Link to post
    Share on other sites

    Ultimaker printers have Marlin firmware which doesn't let the extruder move unless the nozzle is above a certain temperature (170C?). Make sure you are in reprap mode. I haven't tried cura 2.X with reprap mode so I'm not certain it works but I think it should. If not cura 15.X definitely works. You have to tell cura that it is *not* an UM2 but instead a generic reprap mode printer.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
          • Confused
        • 6 replies
    • Create New...