Jump to content
Ultimaker Community of 3D Printing Experts
3dnerd

Cura 2.3.1 TweakAtZ 5.1 not working on first layer?

Recommended Posts

Hi,

today first time I used TweakAtZ (V5.1) to increase print temperature for the first layer, but it seams not to work :-(.

1st question is: in Cura the first layer has the No. 1, but in the G-Code of Cura 2.3.1 the first Layer has No. 0. So I don't know what layer No. I have to choose in TweakAtZ to tweak the first layer of my print (where the brim is).

2nd question: If I change e.g. the temperature settings in the TweakAtZ plugin that Cura is slicing again in the background. But if I view the G-gode I cannot find any command the changes the temperature for the first layer. I tried both numbers 0 and 1 as layer number in the TweakAtZ plugin.

If I try a higher layer No. e.g. 18 then I can see a command like M104 S240.0.

It seems TweakAtZ has problems with first layers to tweak?

8yKfvnX.jpg[/img]

What I am missing?

Share this post


Link to post
Share on other sites

To avoid double postings, please see https://ultimaker.com/en/community/34198-post-processing-plugin-tweakatz-51-not-wotking?.

Anyway, TweakAtZ 5.1 is a bit buggy atm.

Originally, the TweakAtZ supported only tweaks starting from the second layer as on the first layer settings should be applied on the printer (UM2 family) or in Cura (UMO, UM3). However, this was changed somewhere end of last year or begin of this year.

Share this post


Link to post
Share on other sites

@Dim3nsioneer: thanks, I know about the other thread but it does not answer my questions.

Could you tell me why TweakAtZ starts layer counting from 0 and not from 1 as Cura is doing? E.g. if I want to change the 50th layer using TweakAtZ then I have to enter 49 in the TweakAtZ plugin!?! This is very confusing to the user - or not? Or do I something wrong here?

Further problem with TweakAtZ 5.1 is that I can enter layer 60 even if I only have 50 layers in my design!?!

And again my question will it get fixed that I can also change the very first layer using TweakAtZ plugin?

Thanks...

Edited by Guest

Share this post


Link to post
Share on other sites

It is Cura who made the confusion by naming the first layer on the gui 1 and using 0 internally. TweakAtZ is just consequent and uses 0 for the first layer as it is in the gcode.

If you don't want to mess around with layer numbers you always can use z height in mm.

Yes, you can enter layer 60 but having only 50. It should not break anything.

The still existing bugs will be fixed until next Cura release.

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!