Jump to content
Ultimaker Community of 3D Printing Experts
Max2Wheels

Problème feeder - Tourne à l'envers

Recommended Posts

Salut,

Ce n'est pas parce que le moteur tourne qu'il est bien alimenté. Je m'explique:

- Un moteur pas à pas ne fonctionne pas comme un moteur électrique classique.

Les 4 fils servent tous à des alimentations.  Il n'y as pas deux fils d’alimentation et deux fils de signal.

Les 4 fils fonctionnent par paire qui alimentent chacune une bobine différente.  L'ordre des bobines alimentées et le sens du courant font que le moteur va passer d'un pas à l'autre.

Regarde sur les images sur wikipedia moteur à aiment permanent bipolaire

On voit une séquence de 4 pas.

Et le sens de rotation est déterminé par le séquençage des pas.

1  2  3  4   on  tourne dans un sens

4  3  2  1  on tourne dans l'autre sens

Or on s'aperçoit que si une des deux bobines n'est pas alimenté alors la séquence est la suivante

1  3  1  3  1  3    (ou 2  4  2  4  2)    on tourne dans un sens

3  1  3  1  3  1    (ou 4  2  4  2  4) on tourne dans l'autre sens.

Et c'est la qu'il y'a un pb --> Comment le moteur fait la différence du sens de rotation ? En effet  3  1  3    ou 1  3  1    ça pose un pb.  Il y'a toujours un 3 qui précède un 1 dans les deux sens de rotation.  La différence se joue sur le premier pas qui est effectué.

Et c'est comme ça que tu te retrouve avec un moteur qui choisi son sens de rotation un peu au grès de ses envies.

Le fait que depuis le menu de maintenance cela soit différent de quand tu fais une procédure de chargement de filament peut s'expliquer par le courant de commande ou par un hasard total.

Donc je maintiens mon idée que ton moteur doit être bon mais qu'il y a un pb de connexion avec la CM ou alors le driver qui est HS.

C'est pas facile d'expliquer ça à l'écris.

Regarde aussi ce site ça apprends des choses;

 

ClapClapClap!!! (Applaudissements :D)

Déjà en premier: merci pour ton explication et le temps que tu as consacré à cette dernière! Vraiment super! ;)

Il me semble que le moteur tourne à l'envers, par le mode maintenance, lorsqu'il a déjà effectué le bug! Cela semble logique d'après ton explication..

Du coup, si j'ai bien compris, mon soucis est que d'un coup, le moteur se met à croire qu'il tournait dans l'autre sens alors que tout était OK. Il reçois donc toujours le même signal mais se met à mal l'interpréter.. Le passage entre ces deux états pourrait également être la source du bruit (du lien ci-dessus).

Il me semble que je n'arrive pas à déclencher ce défaut directement par le menu maintenant, est-ce utile de tester avec l'alimentation de l'axe X comme tu me l'avais expliqué? Ou il serait plus adapté de mettre à jour le driver, pour éliminer cette source, et ainsi savoir d’où vient le soucis?

Edit: Tout comptes fait, j'ai fais face au soucis, de part le menu maintenance.. Je go tester avec l'alimentation de l'axe X! Merci beaucoup Electromu! ;)

Mais mon menu maintenance ne m'offre pas la possibilité de bouger l'axe X, seul le moteur du feeder (donc maintenant l'axe X, vu que j'ai inversé les alimentations) peux être manipuler par ce menu..

Edited by Guest

Share this post


Link to post
Share on other sites

Bonjours à tous!!

Je reviens une dernière fois vers vous car Electromu à trouvé et solutionné mon soucis!

Il s'agissait très certainement d'un défaut de l'alimentation du feeder directement sur la carte mère de l'imprimante ! Grâce à Electromu, j'ai compilé un firmware modifié sur mon imprimante, afin de tromper cette dernière et qu'elle envoi les informations du feeder 1 sur l'alimentation du feeder 2 (prévu pour la deuxième tête d'extrusion sur la CM). Il m'a ensuite fallut brancher mon feeder à l'alimentation du deuxième et le soucis est enfin résolu! :)

Déjà 2 petites pièces de 20min imprimé avec succès et une autre un peu plus grosse de 2h30!!

Merci à tous pour le temps passé sur ce post et un gros merci à Electromu qui s'est rendu très disponible pour moi!! Je peux enfin reprendre mes prints! :D

Edited by Guest
  • Like 1

Share this post


Link to post
Share on other sites

Ha ! Cet @electromu : la grande classe électronique

 

La grand classe tout court même! Ce chère monsieur m'a appelé sur mon téléphone, m'a proposé de passer physiquement et m'a effectué lui même les modifications sur le firmware.. Cela représente beaucoup de temps et je lui en suis très reconnaissant!

Ça fait plaisir de voir qu'il existe encore des personnes passionné qui ne bosse pas que pour la monnaie!! :)

Longue vie à cette communauté et encore merci!

Edited by Guest
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

Concernant le coupleur téflon pour l'UM3 j'ai cherché pendant un moment les dimensions pour finalement trouver que c'est du PTFE id=1/8" od=3/16" .

Maintenant je l'achète au mètre sur La Baie pour 3 rondelles de saucisson :) .

Par exemple l'objet numéro 221725783613 sur Ebay.fr

Je suppose que ce sont les mêmes dimensions pour l'UM2 mais sans aucune certitude.

Attention il faut faire une coupe nette et bien d'équerre .

Pour se faire j'utilise un cutter avec une lame quasi neuve .

"Impriment vôtre" ... ;)

Merci pour tous le temps consacré à mon soucis et ta rapidité de réponse!

Au sujet du coupleur téflon, c'est un collègue qui l'a repercé en constatant que le filament accrochait légèrement. Depuis nous avons réalisé une belle quantité d'impression sans aucun soucis!! Ok il s'agit de petites économies, mais ça évite toujours 15€ de dépenses inutiles..

Pour ton hypothèse au sujet du blocage du filament à l'entré du bloc Olsson, les deux éléments suivantes me permettent, de mon point de vue, d'éliminer cette hypothèse: le filament bloque parfois dans le feeder directement, il sort à peine de 2/3mm dans le bowden et repars ensuite en arrière. De plus lorsque je débranche le bowden de la tête et que j'insère un filament manuellement, aucune résistance n'a lieu et le filament fond correctement.. Qu'en penses-tu?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 130 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!