Jump to content
Ultimaker Community of 3D Printing Experts

Extruder motor won't move (UMO)


Recommended Posts

Posted · Extruder motor won't move (UMO)

After five years of ownership and four moves, it seems I've finally done something to hurt my Ultimaker Original. After setting up in my new apartment, the extruder motor doesn't turn anymore, either when trying to print or controlling it through the "Prepare" menu of my Ulticontroller.

Some things I've tried:

- Replugging all the cables: No difference.

- Swapping the motor to a different port: the extruder now moves when I control the other axis.

- Swapping the driver: extruder driver works in other slots, new driver does not work in extruder slot.

Visual inspection doesn't show any obvious issues with the electronics (no exploded caps or broken joints that I can see). The above testing makes me think that I need to replace either the electronics or the Arduino Mega. However, I think I could work around the problem in firmware; I have an unused second extruder port, so I should be able to make the firmware treat that as the primary extruder instead of the other one.

Any ideas how I could do this? Is it an option somewhere, or would I have to modify some code (which I am not adverse to doing)? Also, if anyone has seen an issue like this before, it would be helpful to know where the problem might lie so I could go deeper into troubleshooting. But I really just want it to work!

  • Link to post
    Share on other sites
    Posted · Extruder motor won't move (UMO)

    Assigning one motor to other is easy (if you know how to build a Marlin) by changing the pins.h table

    Gr5 posted a link for other user machine, but it should help you getting a custom marlin firmware running.

    https://ultimaker.com/en/community/39160-cura-firmware-eeprom?page=last#reply-173645

    You would need to edit the pins.h file of your board to make extruder 1 the 2 and the 2 the 1.

  • Link to post
    Share on other sites
    • 3 years later...
    Posted · Extruder motor won't move (UMO)

    I have the same problem as the original poster on this older post.  Extruder motor works on another port, but not on the original port.  Not to revive the dead, but can anyone point me in a direction for a current best practice fix for this issue?  The link supplied above does not work.  I have some questions:

    1. Is it possible that the extruder no longer runs from the "Prepare" menu properly?  I know, I'm grasping here, but how could it just die like this?
    2. Is it possible the extruder only runs during prints?  I doubt it, also a reach.

    I'm thinking of these options:

    1. Move the extruder from port 1 to port 2
    2. Tell original firmware I have a second extruder (possible?) and config in Cura, then run?
    3. If that doesn't work, can I modify native firmware to use other extruder port?
    4. If that doesn't work, Marlin firmware, pin assignment?
    5. OR, can I replace board/driver?  Easy to do?

    I'm a little stuck here, any pointers?

  • Link to post
    Share on other sites
    Posted · Extruder motor won't move (UMO)

    Normally the extruder WILL NOT MOVE if the temperature is below around 170C on the heater.

     

    There is a gcode to override this.  google something like "gcode extrude override" or look for gcode at reprap website and search for override.

     

    Or just heat up the nozzle.

     

    If it still doesn't rotate then it could be the driver is damaged.  You can just buy another driver.  is this UMO green board?  Or UMO+ with white board?

     

    If green board you can just remove the driver and put another one in there.  They cost around 20 euros/dollars.

     

    if white board, then yes you can reprogram firmware to use the other driver.  Look for my posts about building the firmware and the only thing you have to change is pins.h.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Startups, apply for the Forward AM Innovation Award!
        Are you a startup using 3D printing? Perhaps you should continue reading... 
         
        Together with BASF we are launching the Forward AM Innovation Award - the very first global contest for startups developing new applications with 3D printing!
         
        Why apply?
        The winning startup will receive €100,000 in goods and services*, along with coaching and marketing exposure from top-notch leaders in the industry.
         

         
        Who can apply?
        Your startup creates products using Additive Manufacturing, is less than 5 years old, and has less than 50 employees. We are looking for 3D printing applications with a strong focus on innovation, sustainability and scalability.
         
        Dental aligners, shoes, tools, automotive parts, music instruments, industrial tooling and molding, medical implants, sports equipment, toys, architecture, fashion, construction... all are welcome to join!
         
        Do you have an innovative, sustainable and scalable idea that leverages the unique possibilities of 3D printing? Then it is time to apply!
        More information can be found here.
         
        Applications close on March 28th, 2021
        * What does "in goods and services" mean?
        The winner will be able to pick any item from the overall product and service portfolio of the sponsors, e.g. printers, materials, consulting, software... Choose whatever you need to accelerate your startup.
         
          • Like
        • 0 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...