Jump to content
Nicolinux

Olsson Ruby Nozzle - problems with extrusion

Recommended Posts

Posted · Olsson Ruby Nozzle - problems with extrusion

I have a weird problem with the Olsson Ruby. Printed only PLA with it and it worked fine until now. Suddenly it wouldn barely extrude and would grind down filament. At first I thought it might be the coupler.

Fun fact: I haven't changed the coupler ever since I've installed the extrusion upgrade kit... So this thing was super durable.

However, I changed the coupler, inspected the bowden tube, the feeder (no obstructions) and the Olsson block.

It would still not work. The Olsson Ruby nozzle looks absolutely fine. Since it has a translucent tip, it is pretty easy to see through and it is completely clear. The inner walls look fine too.

If I mount another nozzle, the extrusion is fine.

Any ideas? Did I miss something?

Btw. that's how the filament tip looks like after performing a couple of atomic pulls (perfectly clean)

IMG_7691.thumb.JPG.bac72b6531781ffb7fc5079b105858e1.JPG

IMG_7691.thumb.JPG.bac72b6531781ffb7fc5079b105858e1.JPG

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

I know you have some kind of needle so run that needle up and down the inside of the ruby (nozzle sex?). Do it dozens of times and try to scrape the inside of the nozzle clean - you can't scratch ruby with mere steel so don't worry about that. Something is in there somewhere. This should fix anything adhering to the walls deep where you can't see.

Also it could be something at the top of the ruby (the hardest spot to get to). so do an atomic pull but while it's cooling again run the needle up there to push any blockage into the slowly cooling pla. Do it 10 times. Then when it's cool do the atomic pull (with the needle long since removed).

If none of this works, try working on it while it is not attached to the printer. If you have a gas stove you can turn it on medium. I put a drop of water on the nozzle then hold the nozzle with pliers and heat until the water boils all while counting seconds. then I double that count of seconds. So if it takes 10 seconds to boil all the water away then I hold it in the flame for another 10 seconds. Then you can push filament by hand into the nozzle and experiment. For a brass nozzle I have heated to 400C to burn everything to ash. That might help possibly. Ruby can handle well over 1000C (brass will melt first but glow cherry red before it melts so you aren't likely to overheat it).

Of course hold the nozzle with pliers.

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

@gr5:

Do you happen to know what is holding the ruby in the brass part? Is there an adhesive that could possibly be damaged by heating it to such a high temperature? Or is it just a press fit?

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

When it stops extruding; dismount bowden, cut the filament, and try to move the filament manually "a mano" in the bowden. Visually inspecting it is not enough. Or your PT100 is shot. Your Cold pull looks perfect

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

Thanks for the ideas guys.

I am pretty sure that everything is fine except for the ruby nozzle because I can print fine with another nozzle.

I'll try to:

  • poke it with a needle
  • do reverse atomics

Share this post


Link to post
Share on other sites
Posted (edited) · Olsson Ruby Nozzle - problems with extrusion

Thanks for the ideas guys.

I am pretty sure that everything is fine except for the ruby nozzle because I can print fine with another nozzle.

I'll try to:

  • poke it with a needle
  • do reverse atomics

We have never seen this before, and we have a lot of Olsson ruby nozzles out being used heavily all over the world.

I'm not sure what what might have happened, but in case you don't get it solved, just e-mail to info@olssonruby.com and we will provide you with a replacement, and ask you to return yours for analysis.

Thanks

Daniel

Edited by Guest
  • Like 4

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

Alright tried both things (needle poking and reverse atomics) but the issue still persists. I have no idea what's wrong. Looked at the nozzle tip through a magnifying glass and I can see that the ruby tip is completely clean inside.

@gadgetfreak: I'll contact support. Thanks for the offer.

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

@nicolinux

Could you try a silly test?

Remove the nozzle after an atomic. Wait for all to be cold bellow 45C and insert a piece of filament from below. Does it pass freely or there's any point where it fells like there's friction?

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

 

@neotko But what would it test? Since I can print perfectly fine with another nozzle, it means that everything else up to the nozzle is not problematic, right?

Share this post


Link to post
Share on other sites
Posted (edited) · Olsson Ruby Nozzle - problems with extrusion

Depends, ruby does use, thinking outloud a 5% extra pressure to extrude vs a brass nozzle. Anders did optimize his design from first beta to current making the need for more heat an almost negligible issue, but it does generate more pressure. So, if there's pressure on the coupler area, the difference can be noticed with the ruby.

Also in my experience with almost a year with ruby nozzles, they tend to show everything and they help me a lot to debug issues to the most insane precision (and you know I'm quite insane XD )

Basically e3d/normal nozzles hide the machine issues better by softening the extrusion, ruby shows everything the machine does right or wrong.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

Ok but I still don't understand what you mean.

I printed with the ruby nozzle fine ever since it was released and then suddenly extrusion was super bad. Swappted the TFM coupler but still had bad extrusion. Swapped the nozzle -> perfect extrusion.

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

I think neotko is saying you have this force budget. The extruder can push with about 5kg. The ruby is a longer passage so it needs maybe 50% more force than usual nozzles at a given speed. So if the bowden takes up 1kg friction and the tfn takes up 1kg and normal nozzle needs 3kg you are fine (adds up to 5kg) but with the ruby you need 4.5kg for the same print and so you get underextrusion.

I don't really believe that's the problem. If it was you could cut your print speed in half and now the ruby should need less force than a regular nozzle at the original speed and should extrude just as well as the regular nozzle.

I think there is something in the narrow passage or just above it in the ruby. It may look perfect but something is probalby wrong with it such as some tiny piece of debris that entered the nozzle along with the filament. Personally I would try burning it out. It sounds like ruby can handle temperatures up to where brass melts and brass will glow red hot before melting and it sounds like there is no glue involved.

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

I've sent the ruby nozzle to Daniel for further inspection. Let's see what they find out.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

I've sent the ruby nozzle to Daniel for further inspection. Let's see what they find out.

I might have the same problem as you. After changing to ruby I have problems getting a normal flow, even though I have a bondtech extruder on my UM2.

Curious on what you found out..

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

They didn't get back to me and didn't react to my mails. I even got two replacement nozzles but since nobody responds, I'll keep them...

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion

Did you ever solve this issue? I am having exactly the same issues with a ruby nozzle, and ran across this thread.

 

I have tried everything even mentioned in this thread and yet the problem persists I really want to use this specific nozzle but non stop failures due to under extrusion, just wont work for me.

 

One thing i have noticed is when i remove the material after a "under extrusion failure" the last 33mm of the filament are slightly thicker than the rest. I believe this could be the issue but i have replaced the PTFE coupler many times entire hotend a few times and the problem still persists.

Share this post


Link to post
Share on other sites
Posted · Olsson Ruby Nozzle - problems with extrusion
On 9/10/2019 at 8:12 PM, mayo77 said:

...

One thing i have noticed is when i remove the material after a "under extrusion failure" the last 33mm of the filament are slightly thicker than the rest. I believe this could be the issue but i have replaced the PTFE coupler many times entire hotend a few times and the problem still persists.

 

If the filament is swollen above the nozzle and teflon coupler, could it be that your little fan that does not work (=the one behind the nozzle)? Sometimes, strands and hairs of molten filament get sucked up in it, and slow it down.

 

Anyway, if you would want to do atomic pulls, but in a much more gentle way without brute force, you could try my old manual:

https://www.uantwerpen.be/nl/personeel/geert-keteleer/manuals/

 

And then scroll down a little bit.

 

This works by cooling deeper, and then gently wiggling and rotating, instead of brutal pulling. No risk of bending rods or displacing nozzle parts. But it is equally effective for me.

 

Share this post


Link to post
Share on other sites
Posted (edited) · Olsson Ruby Nozzle - problems with extrusion

I actually figured this out prior you mentioning this but yes your exactly correct that was the issue. My motherboard was shot (j46 plug in) the little fan was not working at all. I had to repair my motherboard to solve this issue but your exactly right that was the issue was the ptfe coupler fan was not turning on. This ended up not being related to the Olsson ruby at all, as my printer has been printing perfectly for days now with the olsson ruby.
 

Thanks so much I figured i should mention the solution for me,  so anyone else that came across this issue this may help.

Edited by mayo77
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!